Bug 466205 - Request backporting of Apache 2.2.6 internal dummy connection -handling
Request backporting of Apache 2.2.6 internal dummy connection -handling
Status: CLOSED DUPLICATE of bug 367981
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: httpd (Show other bugs)
5.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Joe Orton
BaseOS QE
http://wiki.apache.org/httpd/Internal...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-09 02:59 EDT by Jari Turkia
Modified: 2008-10-09 04:21 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-09 04:21:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jari Turkia 2008-10-09 02:59:12 EDT
Description of problem:
Under heavy (or moderate) load on a server serving dynamic web pages Apache's internal requests may consume all available Apache resources.

Version-Release number of selected component (if applicable):
httpd-2.2.3-11.el5_1.3


How reproducible:
difficult to reproduce, we ran 8 months without any problems

Steps to Reproduce:
1. set up a web-server with dynamic content
2. put it under stress /w hundreds of child-processes running simultaneously
3. watch legitimate client requests fight with Apache's internal requests
  
Actual results:
Site slowing down considerably. Internal requests stop only after Apache's Timeout-directive (RHEL default 120 seconds). Scoreboard has lot of Apache processes in "Sending Reply" -state. These hang up processes consume other resources too (DB-handles, etc.).

Expected results:
Smoothly running site with fast response time for legitimate users. No system resources wasted on Apache's own clumsiness.

Additional info:
The problem can be defeated using a couple of mod_rewrite -directives separating internal requests from others and telling them to "take a hike".

However, this is a gum/glue/duct tape workaround to save system resources. The problem in Apache does not go away by looking into another direction.
Comment 1 Joe Orton 2008-10-09 04:21:15 EDT
Thanks for the request.  This is already scheduled to be fixed in the next update by switching to use of "OPTIONS *" rather than "GET /" in the dummy request.

*** This bug has been marked as a duplicate of bug 367981 ***

Note You need to log in before you can comment on or make changes to this bug.