Bug 466231 - Pulseaudio dying when playing audio
Pulseaudio dying when playing audio
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-09 06:04 EDT by Peter Robinson
Modified: 2009-02-24 20:38 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 20:38:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2008-10-09 06:04:35 EDT
I had been regularly but randomly seeing issues right through Fedora-9 with rhythmbox stopping playing of music but I haven't been able to work out what the issue was. When playing a video with totem from the command line the other day I got the following:

$ totem video.mp4
*** PULSEAUDIO: Unable to create stream.
totem: pcm_pulse.c:198: pulse_pointer: Assertion `pcm->stream' failed.
$ !t
totem 01002_16.mp4
*** PULSEAUDIO: Unable to connect: Connection refused
*** Is your sound server running?
*** See: http://www.pulseaudio.org/wiki/Troubleshooting

I've also been seeing random lock ups with pidgin, so I decided to try that from the command line and I get the following when it locks up:

$ pidgin 
*** PULSEAUDIO: Unable to connect: Connection refused
*** Is your sound server running?
*** See: http://www.pulseaudio.org/wiki/Troubleshooting
*** PULSEAUDIO: Unable to connect: Connection refused
*** Is your sound server running?
*** See: http://www.pulseaudio.org/wiki/Troubleshooting
*** PULSEAUDIO: Unable to connect: Connection refused
*** Is your sound server running?
*** See: http://www.pulseaudio.org/wiki/Troubleshooting

(pidgin:10471): GStreamer-CRITICAL **: 
Trying to dispose element play, but it is not in the NULL state.
You need to explicitly set elements to the NULL state before
dropping the final reference, to allow them to clean up.


(pidgin:10471): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_object_unref: assertion `((GObject *) object)->ref_count > 0' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_object_unref: assertion `((GObject *) object)->ref_count > 0' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_object_unref: assertion `((GObject *) object)->ref_count > 0' failed
*** PULSEAUDIO: Unable to connect: Connection refused
*** Is your sound server running?
*** See: http://www.pulseaudio.org/wiki/Troubleshooting
*** PULSEAUDIO: Unable to connect: Connection refused
*** Is your sound server running?
*** See: http://www.pulseaudio.org/wiki/Troubleshooting
*** PULSEAUDIO: Unable to connect: Connection refused
*** Is your sound server running?
*** See: http://www.pulseaudio.org/wiki/Troubleshooting

(pidgin:10471): GStreamer-CRITICAL **: 
Trying to dispose element play, but it is not in the NULL state.
You need to explicitly set elements to the NULL state before
dropping the final reference, to allow them to clean up.


(pidgin:10471): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_object_unref: assertion `((GObject *) object)->ref_count > 0' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_object_unref: assertion `((GObject *) object)->ref_count > 0' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_object_unref: assertion `((GObject *) object)->ref_count > 0' failed
*** PULSEAUDIO: Unable to connect: Connection refused
*** Is your sound server running?
*** See: http://www.pulseaudio.org/wiki/Troubleshooting
*** PULSEAUDIO: Unable to connect: Connection refused
*** Is your sound server running?
*** See: http://www.pulseaudio.org/wiki/Troubleshooting
*** PULSEAUDIO: Unable to connect: Connection refused
*** Is your sound server running?
*** See: http://www.pulseaudio.org/wiki/Troubleshooting

(pidgin:10471): GStreamer-CRITICAL **: 
Trying to dispose element play, but it is not in the NULL state.
You need to explicitly set elements to the NULL state before
dropping the final reference, to allow them to clean up.


(pidgin:10471): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_object_unref: assertion `((GObject *) object)->ref_count > 0' failed
*** PULSEAUDIO: Unable to connect: Connection refused
*** Is your sound server running?
*** See: http://www.pulseaudio.org/wiki/Troubleshooting
*** PULSEAUDIO: Unable to connect: Connection refused
*** Is your sound server running?
*** See: http://www.pulseaudio.org/wiki/Troubleshooting
*** PULSEAUDIO: Unable to connect: Connection refused
*** Is your sound server running?
*** See: http://www.pulseaudio.org/wiki/Troubleshooting

(pidgin:10471): GStreamer-CRITICAL **: 
Trying to dispose element play, but it is not in the NULL state.
You need to explicitly set elements to the NULL state before
dropping the final reference, to allow them to clean up.


(pidgin:10471): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_object_unref: assertion `((GObject *) object)->ref_count > 0' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_object_unref: assertion `((GObject *) object)->ref_count > 0' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_object_unref: assertion `((GObject *) object)->ref_count > 0' failed
*** PULSEAUDIO: Unable to connect: Connection refused
*** Is your sound server running?
*** See: http://www.pulseaudio.org/wiki/Troubleshooting
*** PULSEAUDIO: Unable to connect: Connection refused
*** Is your sound server running?
*** See: http://www.pulseaudio.org/wiki/Troubleshooting
*** PULSEAUDIO: Unable to connect: Connection refused
*** Is your sound server running?
*** See: http://www.pulseaudio.org/wiki/Troubleshooting

(pidgin:10471): GStreamer-CRITICAL **: 
Trying to dispose element play, but it is not in the NULL state.
You need to explicitly set elements to the NULL state before
dropping the final reference, to allow them to clean up.


(pidgin:10471): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_object_unref: assertion `((GObject *) object)->ref_count > 0' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_object_unref: assertion `((GObject *) object)->ref_count > 0' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed

(pidgin:10471): GStreamer-CRITICAL **: gst_object_unref: assertion `((GObject *) object)->ref_count > 0' failed


Killed

So it looks like all my problems are due to pulseaudio dying. The audio on my laptop is a standard Intel 945 chipset audio, nothing special but it makes using the desktop somewhat painful.
Comment 1 Laurent Aguerreche 2008-10-12 12:45:16 EDT
Hello,

what happens if you try to run pulseaudio after it died? :
 $ pulseaudio

My system also uses an Intel chipset (I don't know whether it is exactly the same than yours) :

$ /sbin/lspci -v
...
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
        Subsystem: Dell Unknown device 01cf
        Flags: bus master, fast devsel, latency 0, IRQ 21
        Memory at efffc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

I also see pulseaudio ramdomly crashing when I use Flash (for instance) and I get this message :

Soft CPU time limit exhausted, terminating.
Hard CPU time limit exhausted, terminating forcibly.


I read at http://www.pulseaudio.org/ticket/207 that this is an ALSA bug... I'm using a 2.6.26.5-45.fc9.x86_64 kernel.
Comment 2 Laurent Aguerreche 2008-10-12 13:10:24 EDT
It seems I am not the only one to have this bug : https://bugzilla.redhat.com/show_bug.cgi?id=464816
Comment 3 Peter Robinson 2008-10-12 13:32:26 EDT
Similar but not necessarily the same. I'm not seeing the CPU issue and it happens even when under light load. The Intel audio chip is a ICH7 not ICH8 as it appears to be on the other ticket

# /sbin/lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
Comment 4 John Poelstra 2008-10-17 14:43:13 EDT
removing F10 blockers... didn't realize this was an F9 bug
Comment 5 Lennart Poettering 2008-10-19 16:42:08 EDT
Which PA version is this?
Comment 6 Laurent Aguerreche 2008-10-19 16:51:48 EDT
Mine is pulseaudio-0.9.10-2.fc9.x86_64.
With Flash 10 and without libflashsupport, I doesn't have problems anymore (for the moment)...
Comment 7 Peter Robinson 2008-10-19 17:04:32 EDT
Mine is as follows (latest F-9 updates):

# rpm -qa | grep pulse|sort
alsa-plugins-pulseaudio-1.0.16-4.fc9.x86_64
gstreamer-plugins-pulse-0.9.5-0.5.svn20070924.fc9.x86_64
pulseaudio-0.9.10-2.fc9.x86_64
pulseaudio-core-libs-0.9.10-2.fc9.x86_64
pulseaudio-esound-compat-0.9.10-2.fc9.x86_64
pulseaudio-libs-0.9.10-2.fc9.x86_64
pulseaudio-libs-devel-0.9.10-2.fc9.x86_64
pulseaudio-libs-glib2-0.9.10-2.fc9.x86_64
pulseaudio-libs-zeroconf-0.9.10-2.fc9.x86_64
pulseaudio-module-gconf-0.9.10-2.fc9.x86_64
pulseaudio-module-x11-0.9.10-2.fc9.x86_64
pulseaudio-module-zeroconf-0.9.10-2.fc9.x86_64
pulseaudio-utils-0.9.10-2.fc9.x86_64
Comment 8 Per Nystrom 2008-10-25 13:56:06 EDT
I'm getting the same kind of problems -- glitches, lags, and crashes -- with rhythmbox, xmms, and other sound apps on Fedora 9 x86_64.

# uname -r
2.6.26.6-79.fc9.x86_64

# lspci | grep Audio
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia

# rpm -q pulseaudio
pulseaudio-0.9.10-2.fc9.x86_64
Comment 9 Lennart Poettering 2008-12-17 17:16:28 EST
Please don't hijack bug reports! Let the maintainers merge bug reports unless it is 100% obvious that you are encountering exactly the same bug.

Peter, please run PA in a terminal like this: "pulseaudio -vvvv" (you might need to run pulseaudio -k first to kill the running instance). Then try to reproduce the issue that PA dies and paste the output of PA here.

Also, have you checked syslog for messages from PA?
Comment 10 Peter Robinson 2009-02-18 09:10:40 EST
I have no way of reproducing this now as I no longer have Fedora 9 as all my devices that were seeing the issue are now running clean installs of F-10.
Comment 11 Lennart Poettering 2009-02-24 20:38:25 EST
Ok, closing then.

Note You need to log in before you can comment on or make changes to this bug.