Bug 466296 - When enabling full disk encryption, some modules are loaded twice in initrd
When enabling full disk encryption, some modules are loaded twice in initrd
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Peter Jones
Release Test Team
:
Depends On:
Blocks: RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2008-10-09 12:13 EDT by Gary Case
Modified: 2010-07-01 18:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When using an encrypted device, the following error message may be reported during bootup: insmod: error inserting '/lib/aes_generic.ko': -1 File exists This message can safely be ignored.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-01 18:05:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Case 2008-10-09 12:13:32 EDT
Description of problem:
When the initrd is created during RHEL5.3 install, the aes_generic.ko file is loaded twice. This generates a harmless (but troubling) error message on boot:

insmod: error inserting '/lib/aes_generic.ko': -1 File exists

If you look at the init file in the initrd package, you see the cause of the problem:

echo "Loading aes-x86_64.ko module"
insmod /lib/aes-x86_64.ko
echo "Loading aes_generic.ko module" 
insmod /lib/aes_generic.ko            <-- 1st load request
echo "Loading aes_generic.ko module"
insmod /lib/aes_generic.ko            <-- 2nd load request
echo "Loading crypto_api.ko module"
insmod /lib/crypto_api.ko


Version-Release number of selected component (if applicable):
RHEL5.3 20081006.0 build

How reproducible:
Every time the system boots.

Steps to Reproduce:
1. Install RHEL5.3, checking the disk encryption checkbox
2. Boot system
3. Error appears 
  
Actual results:
Error appears on screen, then boot continues normally.

Expected results:
No errors.

Additional info:
Comment 1 David Lehman 2008-10-09 12:47:10 EDT
Anaconda doesn't do anything special with mkinitrd. In fact, it doesn't even directly call mkinitrd.
Comment 2 Gary Case 2008-10-09 18:41:47 EDT
In the 32-bit arch, the insmod and echo lines for the /lib/padlock.ko module are duplicated but the aes_generic.ko line only appears once.
Comment 4 Denise Dumas 2008-12-02 15:08:39 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
This release note is for 5.3.

When using an encrypted device, you may see the following error message on boot:
insmod: error inserting '/lib/aes_generic.ko': -1 File exists

This message is harmless and can be ignored.
Comment 6 Ryan Lerch 2008-12-02 18:11:39 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,6 +1,5 @@
-This release note is for 5.3.
+When using an encrypted device, the following error message may be reported during bootup:
 
-When using an encrypted device, you may see the following error message on boot:
 insmod: error inserting '/lib/aes_generic.ko': -1 File exists
 
-This message is harmless and can be ignored.+This message can safely be ignored.
Comment 7 Denise Dumas 2009-06-30 16:48:48 EDT
Moving to RHEL 5.5 so it doesn't get mistakenly closed by the bot
Comment 8 Alexander Todorov 2009-08-24 03:42:53 EDT
Denise,
isn't this one a duplicate of bug #472227 ? At least they are quite close.
Comment 9 RHEL Product and Program Management 2010-07-01 18:05:00 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.