Bug 466306 - dhcp6c is not executed if IPv4 is not configured
dhcp6c is not executed if IPv4 is not configured
Status: CLOSED DUPLICATE of bug 486507
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-10-09 13:07 EDT by Stas
Modified: 2014-03-16 23:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-02-20 09:44:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stas 2008-10-09 13:07:08 EDT
Description of problem:

dhcp6c is executed in the very end of ifup-eth. Control doesn't reach that point if IPv4 is not configured, because of:

if [ "${BOOTPROTO}" = "bootp" -o "${BOOTPROTO}" = "dhcp" ]; then
if [ -n "${DYNCONFIG}" -a -x /sbin/dhclient ]; then
    if [ -z "${IPADDR}" ]; then
         /etc/sysconfig/network-scripts/ifup-ipv6 ${CONFIG}
         exec /etc/sysconfig/network-scripts/ifup-post ${CONFIG} ${2}

Version-Release number of selected component (if applicable):

How reproducible:


Steps to Reproduce:
1. set the following in /etc/sysconfig/network-scripts/ifcfg-eth0
2. make sure that IPV4 configuration is turned off in ifcfg-eth0 (BOOTPROTO, IPADDR are not set)
3. ifup eth0
4. ps axlww | grep dhc
Actual results:

dhcp6c is not running

Expected results:

dhcp6c should be running

Additional info:
Comment 1 Bill Nottingham 2008-10-09 13:16:15 EDT
BOOTPROTO isn't supposed to be a IPv4 configuration - it's generic.
Comment 2 Stas 2008-10-09 14:16:44 EDT
According to ifup-eth script, setting BOOTPROTO enables running dhclient, so having BOOTPROTO off is the only way to avoid IPv4 configured on host, if DHCP server is configured on network.
Comment 3 Stas 2008-10-09 14:31:14 EDT
Also sysconfig.txt says that there's separate option to enable DHCP6:
   IPv6-only option to enable DHCPv6 client: 
      This will enable the DHCPv6 client, dhcp6c, to be run for the interface.      See man dhcp6c(8) and dhcp6c.conf(5).
Comment 4 Stas 2008-10-14 15:16:02 EDT
To clarify: it is not clear what settings you think should be set for a system which is configured via DHCPv6 with IPv4 disabled -- could you please give an example?
Comment 5 Bill Nottingham 2008-10-14 16:36:43 EDT
Your point is correct, but BOOTPROTO was *supposed* to be generic, alas, the IPv6 configuration parameters weren't well thought out.
Comment 6 Bug Zapper 2008-11-25 22:42:47 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
Comment 7 Michel Zehnder 2008-11-30 13:10:21 EST
I've got the same problem.

Having NO IPv4 address, and DHCP6C for IPv6 does not work.

DHCP6C initialization is missing in /etc/sysconfig/network-scripts/ifup-eth after:

Line 225: /etc/sysconfig/network-scripts/ifup-ipv6 ${CONFIG}

Needs DHCP Code added there:

if [[ "${DHCPV6C}"  = [Yy1]* ]] && [ -x /sbin/dhcp6c ]; then
    /sbin/dhcp6c ${DEVICE};
    dhcp6_pid=(`/bin/ps -eo 'pid,args' | /bin/grep "dhcp6c ${DEVICE}" | egrep -v grep`);
    echo ${dhcp6_pid[0]} > /var/run/dhcp6c_${DEVICE}.pid

It then works as expected.
Comment 8 Bill Nottingham 2009-02-20 09:44:43 EST

*** This bug has been marked as a duplicate of bug 486507 ***

Note You need to log in before you can comment on or make changes to this bug.