Bug 486507 - ifup-eth doesn't run dhcpv6c if no IPv4 address
ifup-eth doesn't run dhcpv6c if no IPv4 address
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
: 466306 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 22:25 EST by Bill Nickless
Modified: 2014-03-16 23:17 EDT (History)
3 users (show)

See Also:
Fixed In Version: 8.86.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-20 12:04:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for ifup-eth to start dhcp6c when no IPv4 address is configured (624 bytes, patch)
2009-02-19 22:25 EST, Bill Nickless
no flags Details | Diff

  None (edit)
Description Bill Nickless 2009-02-19 22:25:42 EST
Created attachment 332664 [details]
Patch for ifup-eth to start dhcp6c when no IPv4 address is configured

Description of problem:

ifup-eth is supposed to start dhcp6c if the ifcfg-eth? has DHCPV6C=yes.  But if IPADDR is blank, ifup-eth doesn't do that.

Version-Release number of selected component (if applicable):

initscripts-8.86-1

How reproducible:

Put these configuration lines in /etc/sysconfig/network:

NETWORKING=yes
NETWORKING_IPV6=yes
HOSTNAME=centos52.v6tb.labworks.org

Put these configuration lines in /etc/sysconfig/network-scripts/ifcfg-eth0:

DEVICE=eth0
HWADDR=00:50:56:94:5F:F7
DHCPV6C=yes
ONBOOT=yes

Actual results:

The dhcp6c client process is not started, so the DHCPv6 server never assigns the appropriate client address.

Expected results:

The dhcp6c client should be started and the interface should get its IPv6 address from the local DHCPv6 server.

Additional info:
Comment 1 Bill Nottingham 2009-02-20 09:44:43 EST
*** Bug 466306 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2009-03-20 12:04:58 EDT
Fixed differently here, mainly just to avoid code duplication:

http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=eb389d68f4637418983e4b514a67eb84cf2f4d7b

Also backported to F-10 branch for a future update.
Comment 3 Fedora Update System 2009-04-02 14:04:35 EDT
initscripts-8.86.1-1 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/initscripts-8.86.1-1
Comment 4 Fedora Update System 2009-04-03 00:16:17 EDT
initscripts-8.86.2-1 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/initscripts-8.86.2-1
Comment 5 Fedora Update System 2009-04-22 16:22:46 EDT
initscripts-8.86.3-1 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.