Bug 466385 - boot message: don't know how to make device "loop1"
boot message: don't know how to make device "loop1"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: MAKEDEV (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 466560 (view as bug list)
Depends On:
Blocks: F10Preview
  Show dependency treegraph
 
Reported: 2008-10-09 20:04 EDT by Dennis Jacobfeuerborn
Modified: 2013-01-09 23:50 EST (History)
22 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 13:33:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Difference between the patch that got actually applied and the latest version of the patch (6.33 KB, patch)
2008-10-22 03:53 EDT, Jakub Jelinek
no flags Details | Diff

  None (edit)
Description Dennis Jacobfeuerborn 2008-10-09 20:04:18 EDT
Using the latest MAKEDEV-3.23-7.i386 I get the following output when booting:

Starting udev: don't know how to make device "loop1"
don't know how to make device "loop2"
don't know how to make device "loop3"
don't know how to make device "loop4"
don't know how to make device "loop5"
don't know how to make device "loop6"
don't know how to make device "loop7"
don't know how to make device "lp1"
don't know how to make device "lp2"
don't know how to make device "lp3"

The machine continues to boot fine though.
Comment 1 sangu 2008-10-10 09:31:00 EDT
Using nvidia driver(livina rpm),  I get following messages, also.
don't know how to make device "nvidia1"
don't know how to make device "nvidia2"
don't know how to make device "nvidia3"

$ cat /etc/udev/makedev.d/60-nvidia.nodes
nvidia0
nvidia1
nvidia2
nvidia3
nvidiactl
Comment 2 Oleg Girko 2008-10-11 22:48:13 EDT
Looks like the recent patch breaks matching between device minor number and "%d" token in device name when parsing configuration files in "/etc/makedev.d" directory. Before, "%d" was matched against the minor number. Now it's matched against 0 only.

Assume we have the following configuration:

c $CONSOLE 195 0 1 255 nvidia%d

Before the version 3.23-7 this was interpreted the following way:
for each N in range 0..254 device "nvidiaN" has major 195 and minor N.

In version 3.23-7 this is interpreted the different way:
for each N in range 0..254 device "nvidia0" has major 195 and minor N.

This becomes evident when invoking "MAKEDEV -v -x nvidia0": it creates "/dev/nvidia0" 255 times with minor numers from 0 to 254 in sequence. As the end result, we have "/dev/nvidia0" with minor 254. And when invoking "MAKEDEV -v -x nvidia1", it complains that "nvidia1" is not found.

As a temporary workaround, I've downgraded MAKEDEV package to the previous version 3.23-6 until the problem with "%d" matching is fixed.
Comment 3 Frank Murphy 2008-10-13 03:12:48 EDT
(In reply to comment #0)
> Using the latest MAKEDEV-3.23-7.i386 I get the following output when booting:
> 
> Starting udev: don't know how to make device "loop1"
> don't know how to make device "loop2"
> don't know how to make device "loop3"
> don't know how to make device "loop4"
> don't know how to make device "loop5"
> don't know how to make device "loop6"
> don't know how to make device "loop7"
> don't know how to make device "lp1"
> don't know how to make device "lp2"
> don't know how to make device "lp3"
> 
> The machine continues to boot fine though.


Same result
Comment 4 Eric Paris 2008-10-13 15:12:31 EDT
looks to be the same as BZ 466560
Comment 5 Harald Hoyer 2008-10-14 11:44:42 EDT
*** Bug 466560 has been marked as a duplicate of this bug. ***
Comment 6 Ralf Corsepius 2008-10-20 21:52:21 EDT
I am seeing the same w/ current (2008-10-21) rawhide 
(udev-127-2.fc10.i386, MAKEDEV-3.23-7.i386)
Comment 7 Tom Horsley 2008-10-21 21:18:23 EDT
This bug still lingers after several rawhide updates. If it isn't gonna
get fixed, how about someone just take the source for 3.23-6, call it 3.23-8,
and rebuild it so it is safe to update again without paying special
attention to avoid getting the utterly busted 3.23-7 version?
Comment 8 Jakub Jelinek 2008-10-22 03:53:09 EDT
Created attachment 321125 [details]
Difference between the patch that got actually applied and the latest version of the patch

The problem is that what got applied to MAKEDEV git is apparently not the latest patch I've posted.  I'm attaching interdiff between what was applied and the latest version.  Among some speedups (e.g. using obstack) or cleanups, it contains a fix for this bug (the part where num2++ is used if entry->modulo == 0
instead of incrementing num1) and fixes for the configuration files.
Comment 9 Chris Lumens 2008-10-22 10:17:21 EDT
This should be fixed in MAKEDEV-3.24-1.  Thanks for the patch, Jakub.
Comment 10 Chris Lumens 2008-10-27 13:33:37 EDT
Yep, works for me today.  No error messages and plenty of /dev/loop device nodes.
Comment 11 Tom Horsley 2008-10-27 13:43:32 EDT
The newest 3.24 version is also working fine for me.

Note You need to log in before you can comment on or make changes to this bug.