Bug 466390 - mvapich2 is failing on being unable to open mpd conf file
mvapich2 is failing on being unable to open mpd conf file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mvapich2 (Show other bugs)
5.3
All Linux
high Severity high
: beta
: ---
Assigned To: Doug Ledford
:
: 467532 (view as bug list)
Depends On:
Blocks: RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2008-10-09 20:31 EDT by Gurhan Ozen
Modified: 2013-11-03 20:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
mvapich and mvapich2 in Red Hat Enterprise Linux 5 are compiled to support only InfiniBand/iWARP interconnects. Consequently, they will not run over normal ethernet or other network interconnects.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:03:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gurhan Ozen 2008-10-09 20:31:16 EDT
Description of problem:
# mpirun -n 1 ./hello_world
/usr/lib64/mvapich2/1.0.3-gcc/bin/mpdroot: open failed for root's mpd conf filempiexec_dhcp71-141.rhts.bos.redhat.com (__init__ 1171): forked process failed; status=255

Version-Release number of selected component (if applicable):
mvapich2-1.0.3-2.el5

How reproducible:
Very


Steps to Reproduce:
1. Compile and run an mpi helloworld program
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 8 Doug Ledford 2008-10-22 09:55:06 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Both mvapich and mvapich2 are compiled to support InfiniBand/iWARP interconnects and will only build support for one interconnect at a time.  As a result, they will not run over normal ethernet or other network interconnects.
Comment 9 Gurhan Ozen 2008-10-22 16:55:51 EDT
*** Bug 467532 has been marked as a duplicate of this bug. ***
Comment 10 Ryan Lerch 2008-10-22 22:31:46 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1 @@
-Both mvapich and mvapich2 are compiled to support InfiniBand/iWARP interconnects and will only build support for one interconnect at a time.  As a result, they will not run over normal ethernet or other network interconnects.+mvapich and mvapich2 in Red Hat Enterprise Linux 5 are compiled to support only InfiniBand/iWARP interconnects. Consequently, they will not run over normal ethernet or other network interconnects.
Comment 14 errata-xmlrpc 2009-01-20 16:03:27 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0152.html

Note You need to log in before you can comment on or make changes to this bug.