Bug 467532 - No tcp support for mvapich?
No tcp support for mvapich?
Status: CLOSED DUPLICATE of bug 466390
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mvapich (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Doug Ledford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-17 21:49 EDT by Gurhan Ozen
Modified: 2013-11-03 20:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-22 16:55:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gurhan Ozen 2008-10-17 21:49:34 EDT
Description of problem:
I am not sure if this is a bug or working as expected. I wasn't able to run mvapich programs over tcp stack only. It can only run over infiniband stacks:

# mpirun_rsh  -np 2 dhcp71-141.rhts.bos.redhat.com dhcp71-142.rhts.bos.redhat.com /usr/lib64/mvapich/1.1.0-gcc/bin/mpitests-com
MPI process terminated unexpectedly
Abort signaled by rank 1: No ACTIVE ports found
MPI process terminated unexpectedly

Child exited abnormally!
Killing remote processes...DONE

# modprobe ib_mthca ; ifup ib0

#  mpirun_rsh  -np 2 dhcp71-141.rhts.bos.redhat.com dhcp71-142.rhts.bos.redhat.com /usr/lib64/mvapich/1.1.0-gcc/bin/mpitests-com

################################################################################

  com Point-to-Point MPI Bandwidth and Latency Benchmark
  Version 1.4.0
  Run at 10/17/08  17:37:01, with rank 0 on dhcp71-141.rhts.bos.redhat.com

################################################################################

  Test            Processes  Op Size (bytes)    Ops       BW (MB)
 -----------------------------------------------------------------
  Unidirectional          2               32     10        30.000
  Unidirectional          2               64     10        97.778
  Unidirectional          2              128     10       193.684
  Unidirectional          2              256     10       378.182
  Unidirectional          2              512     10       742.400
  Unidirectional          2             1024     10       984.615
  Unidirectional          2             2048     10      1488.980
  Unidirectional          2             4096     10      1828.224
  Unidirectional          2             8192     10      1454.730
  Unidirectional          2            16384     10       332.670
  Unidirectional          2            32768     10       442.812
  Unidirectional          2            65536     10       527.029
  Unidirectional          2           131072     10       577.537
  Unidirectional          2           262144     10       621.636
  Unidirectional          2           524288     10       637.936
  Unidirectional          2          1048576     10       648.530
  Unidirectional          2          2097152     10       649.504
  Unidirectional          2          4194304     10       651.998
  Unidirectional          2          8388608     10       653.362

  Test            Processes  Op Size (bytes)    Ops       BW (MB)
 -----------------------------------------------------------------
  Bidirectional           2               32     10        11.646
  Bidirectional           2               64     10        25.108
  Bidirectional           2              128     10        32.005
  Bidirectional           2              256     10        57.528
  Bidirectional           2              512     10       140.274
  Bidirectional           2             1024     10       192.305
  Bidirectional           2             2048     10       364.096
  Bidirectional           2             4096     10       507.639
  Bidirectional           2             8192     10       589.475
  Bidirectional           2            16384     10       267.603
  Bidirectional           2            32768     10       494.612
  Bidirectional           2            65536     10       678.251
  Bidirectional           2           131072     10       892.253
  Bidirectional           2           262144     10      1017.344
  Bidirectional           2           524288     10      1156.220
  Bidirectional           2          1048576     10      1186.709
  Bidirectional           2          2097152     10      1193.411
  Bidirectional           2          4194304     10      1181.195
  Bidirectional           2          8388608     10      1185.686

  Test            Processes  Op Size (bytes)    Ops  Latency (us)
 -----------------------------------------------------------------
  Latency                 2                0     10         8.600

  Max Unidirectional  Bandwidth :        1828.22 for message size of    4096 bytes
  Max Bidirectional   Bandwidth :        1193.41 for message size of 2097152 bytes

################################################################################

Test Parameters
---------------

Process pair allocation              : block
MB size for BW calculation           : 1000000

Barrier not included in measurement.

Bandwidth calculated as sum of process bandwidths.

MPI_Wtick returns           0.000010000
MPI_Wtime overhead          0.000000200

################################################################################



Version-Release number of selected component (if applicable):
mvapich-1.1.0-0.2931.3.el5

How reproducible:
Everytime
Comment 1 Gurhan Ozen 2008-10-22 16:55:50 EDT
See #466390 for the explanation. TCP is not supported since it's compiled with IB and it'll be release noted.

*** This bug has been marked as a duplicate of bug 466390 ***

Note You need to log in before you can comment on or make changes to this bug.