Bug 466455 - RHBA-2008:0362 causes logwatch to find unmatched entries in /var/log/up2date
RHBA-2008:0362 causes logwatch to find unmatched entries in /var/log/up2date
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: logwatch (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ivana Varekova
BaseOS QE
:
: 548117 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 06:53 EDT by Issue Tracker
Modified: 2013-04-12 15:54 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-13 07:19:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2008-10-10 06:53:14 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2008-10-10 06:53:15 EDT
Indicate the platform(s) (architectures) the problem is being reported against.
>> RHEL5 32bit and 64bit

Provide clear and concise problem description as it is understood at the time of escalation
>> Installing RHBA-2008:0362 causes logwatch to find unmatched entries in /var/log/up2date
It complains 

--------------------- up2date Begin ------------------------  
 
**Unmatched Entries**
updateLoginInfo() login info
updateLoginInfo() login info
updateLoginInfo() login info
 
---------------------- up2date End -------------------------  

Steps to reproduce
>> 
- On a RHEL5 U1 system install packages associated with RHBA-2008:0362
- Register the system against RHN Hosted/Satellite
- Install or upgrade few packages
- Execute rhn-profile-sync 
- Let logwatch scan /var/log/up2date log file

Observed behavior
>>
On executing rhn-profile-sync it would log 

[Thu Oct  9 16:45:57 2008] up2date updateLoginInfo() login info
[Thu Oct  9 16:45:57 2008] up2date logging into up2date server
[Thu Oct  9 16:45:57 2008] up2date successfully retrieved authentication token from up2date server
[Thu Oct  9 16:45:57 2008] up2date Updating package profile

On this logwatch reports 
--------------------- up2date Begin ------------------------  
 
**Unmatched Entries**
updateLoginInfo() login info

---------------------- up2date End -------------------------  


Desired behavior 
>> Either the information logged through up2date should be 

[Thu Oct  9 16:45:52 2008] up2date logging into up2date server
[Thu Oct  9 16:45:52 2008] up2date successfully retrieved authentication token from up2date server
[Thu Oct  9 16:45:52 2008] up2date Updating package profile

OR the logwatch filters should be edited to ignore "updateLoginInfo() login info"

State specific action requested of SEG
>> Would like SEG to review this and decide whether a change is to be done in information logged in /var/log/up2date revert the message "updateLoginInfo() login info" to "up2date logging into up2date server"
or the filters mentioned under /usr/share/logwatch/scripts/services/up2date

Attach sosreport
>> Have attached the sosreport of the system on which this issue is seen. Refer /var/log/up2date.
 
List any customer applied changes from the last 30 days 
>> Upgraded/Installed RHBA-2008:0362 on the system.

This event sent from IssueTracker by mpoole  [Support Engineering Group]
 issue 228117
Comment 2 Issue Tracker 2008-10-10 06:53:17 EDT
Under /usr/share/logwatch/scripts/services/up2date it has :

   if ( ( $ThisLine =~ /^updating login info$/ ) or

This is the old string. It doesn't have the new string. 


Issue escalated to Support Engineering Group by: pmutha.
pmutha assigned to issue for Production Support (Pune).
Category set to: RHN::up2date
Internal Status set to 'Waiting on SEG'
Status set to: Waiting on Tech

This event sent from IssueTracker by mpoole  [Support Engineering Group]
 issue 228117
Comment 3 Cristóbal Palmer 2009-02-26 12:33:34 EST
Proposed fix is here:

http://linux.derkeiler.com/Mailing-Lists/RedHat/2008-07/msg00085.html

Basically it would on your end amount to adding this line:

( $ThisLine =~ /^updateLoginInfo\(\) login info/ ) or

to /usr/share/logwatch/scripts/services/up2date instead of the end user having to copy that file to /etc/logwatch/scripts/services/up2date and add that line her/himself. I have done the latter and will post back if it fixes for tonight's logwatch runs. Diff for what I did:

--- /usr/share/logwatch/scripts/services/up2date        2008-01-03 08:59:00.000000000 -0600
+++ /etc/logwatch/scripts/services/up2date      2009-02-26 10:19:37.000000000 -0600
@@ -25,6 +25,7 @@
       $DebugCounter++;
    }
    if ( ( $ThisLine =~ /^updating login info$/ ) or
+        ( $ThisLine =~ /^updateLoginInfo\(\) login info/ ) or
         ( $ThisLine =~ /^Opening rpmdb in \/var\/lib\/rpm\/ with option .$/ ) or
         ( $ThisLine =~ /^successfully retrieved authentication token from up2date server$/ ) or 
         ( $ThisLine =~ /^(getA|a)vailablePackageList from network$/ ) or
Comment 4 Cristóbal Palmer 2009-02-27 16:39:51 EST
(In reply to comment #3)
> I have done the latter and will post back if it fixes for
> tonight's logwatch runs.

The change did fix the issue. Please commit this or have upstream commit.
Comment 5 Cristóbal Palmer 2009-02-27 16:49:51 EST
I have sent an email to eric.moret@epita.fr, the maintainer listed in the file in question.
Comment 6 Eric Moret 2009-02-27 17:59:02 EST
Could you please send your patch and bug report to the upstream mailing lists shown on the logwatch main page:

http://www.logwatch.org/index.html

# logwatch-bugs@logwatch.org: Report a bug
# logwatch-patches@logwatch.org: Submit a patch (unified diff format please (diff -u))

Thank you,
__
Eric
Comment 7 RHEL Product and Program Management 2009-03-26 13:10:08 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 13 errata-xmlrpc 2010-01-13 07:19:35 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0033.html
Comment 15 Jan Synacek 2012-07-10 08:41:20 EDT
*** Bug 548117 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.