This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 548117 - logwatch/up2date fix and extension
logwatch/up2date fix and extension
Status: CLOSED DUPLICATE of bug 466455
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: logwatch (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Jan Synacek
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-16 12:05 EST by Peter Bieringer
Modified: 2013-04-12 16:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 737247 (view as bug list)
Environment:
Last Closed: 2012-07-10 08:41:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Extension for /usr/share/logwatch/scripts/services/up2date (1.27 KB, application/octet-stream)
2009-12-16 12:06 EST, Peter Bieringer
no flags Details

  None (edit)
Description Peter Bieringer 2009-12-16 12:05:38 EST
Description of problem:
logwatch's up2date service misses at least one fix for a changed logging line of the yum-rhn-plugin and also I have 2 extensions for an extension requested for yum-rhn-plugin

Version-Release number of selected component (if applicable):
logwatch-7.3-6.el5

How reproducible:
Always

Steps to Reproduce:
1. always
  
Actual results:
 --------------------- up2date Begin ------------------------

 **Unmatched Entries**
 updateLoginInfo() login info

 ---------------------- up2date End -------------------------



Expected results:
Not such message

Additional info:

Following extension fixes this problem:

--- /usr/share/logwatch/scripts/services/up2date.orig   2009-12-16 16:47:04.000000000 +0000
+++ /usr/share/logwatch/scripts/services/up2date        2009-12-16 17:03:31.000000000 +0000
@@ -25,6 +25,7 @@
       $DebugCounter++;
    }
    if ( ( $ThisLine =~ /^updating login info$/ ) or
+        ( $ThisLine =~ /^updateLoginInfo\(\) login info$/ ) or
         ( $ThisLine =~ /^Opening rpmdb in \/var\/lib\/rpm\/ with option .$/ ) or
         ( $ThisLine =~ /^successfully retrieved authentication token from up2date server$/ ) or
         ( $ThisLine =~ /^(getA|a)vailablePackageList from network$/ ) or


Note: it can be seen that log line had only small changes sometime in the past


And please add also following extension for my requested extension of logging of yum-rhn-plugin https://bugzilla.redhat.com/show_bug.cgi?id=548111

@@ -47,10 +48,14 @@
       # We don't care about these
    } elsif ( $ThisLine =~ s/^installing packages: ([^ ]+)/$1/ ) {
       $PackageInstalled{$ThisLine}++;
+   } elsif ( $ThisLine =~ s/^Installed: ([^ ]+)/$1/ ) {
+      $PackageInstalled{$ThisLine}++;
    } elsif ( $ThisLine =~ s/^Adding packages to package profile: ([^ ]+)/$1/ ) {
       $PackageAddedToProfile{$ThisLine}++;
    } elsif ( $ThisLine =~ s/^Removing packages from package profile: ([^ ]+)/$1/ ) {
       $PackageRemovedFromProfile{$ThisLine}++;
+   } elsif ( $ThisLine =~ s/^Erased: ([^ ]+)/$1/ ) {
+      $PackageRemovedFromProfile{$ThisLine}++;
    } else {
       # Report any unmatched entries...
       push @OtherList,$ThisLine;
Comment 1 Peter Bieringer 2009-12-16 12:06:18 EST
Created attachment 378794 [details]
Extension for  /usr/share/logwatch/scripts/services/up2date
Comment 2 Karel Klíč 2010-04-12 05:57:46 EDT
Hello,

now it seems only the following part needs a fix:
 **Unmatched Entries**
 updateLoginInfo() login info
Comment 3 Karel Klíč 2010-04-12 06:02:34 EDT
This is a candidate for fastrack.
Comment 5 RHEL Product and Program Management 2011-01-11 15:29:39 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2011-01-11 18:02:09 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 7 RHEL Product and Program Management 2011-05-31 09:23:01 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 Yury V. Zaytsev 2011-09-08 08:00:30 EDT
This is also relevant to RHEL6. Could someone please clone this bug?
Comment 9 Yury V. Zaytsev 2011-09-10 06:39:23 EDT
Cloned as https://bugzilla.redhat.com/show_bug.cgi?id=737247 .
Comment 10 RHEL Product and Program Management 2011-09-22 20:13:02 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 12 Jan Synacek 2012-07-10 08:41:20 EDT

*** This bug has been marked as a duplicate of bug 466455 ***
Comment 13 Yury V. Zaytsev 2012-07-10 09:07:02 EDT
Do'h, hope it's gonna make into RHEL6 too...

Note You need to log in before you can comment on or make changes to this bug.