Bug 466456 - System ---> Shut Down Missing!
System ---> Shut Down Missing!
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
: 466700 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 07:04 EDT by Jóhann B. Guðmundsson
Modified: 2008-10-15 12:05 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 12:05:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2008-10-10 07:04:30 EDT
Description of problem:
Shut down missing from menu

Version-Release number of selected component (if applicable):

Latest rawhide updated F10

How reproducible:

Always

Steps to Reproduce:
1.Log into gnome
2.Going to shut down/restart the computer 
3.
  
Actual results:

No Shut Down under System

Expected results:

Shut Down being under system

Additional info:
Comment 1 Matthias Clasen 2008-10-10 15:49:41 EDT
Is gnome-power-manager running ?
Comment 2 Shaopu Chiu 2008-10-11 10:07:03 EDT
The same problem here.
Gnome-power-manager running.
Comment 3 Allen Halsey 2008-10-12 05:46:37 EDT
Me too.

Smolt Profile:
http://www.smolts.org/show?uuid=pub_3eb65d6c-6aa7-48d6-860b-7c3e965cd954

Gnome-power-manager is running.

$ ps p `pgrep power`
  PID TTY      STAT   TIME COMMAND
 4448 ?        Ss     0:00 gnome-power-manager
Comment 4 Allen Halsey 2008-10-12 14:09:08 EDT
Adding to my Comment #3...

Logging into a Gnome Session for this first time after a fresh reboot, the Shut Down menu is there. But if I log out of my Gnome Session and then back in, it is gone.
Comment 5 Matthias Clasen 2008-10-12 22:34:45 EDT
*** Bug 466700 has been marked as a duplicate of this bug. ***
Comment 6 Mikkel Lauritsen 2008-10-13 04:32:51 EDT
I have the same problem - just logged in after rebooting and the Shut Down menu item doesn't exist.

http://smolts.org/show?uuid=pub_48efb25d-123e-4b21-8b80-c413d61b1fab
Comment 7 Hans Ulrich Niedermann 2008-10-13 05:04:20 EDT
As bug 466700 has just been marked as a duplicate of this one... that one had been not complaining about the missing "Shut Down" menu item in the "System" menu, but about the presence of an annoying enforced 60 second timeout in the dialog which follows after selecting the (existing!) "System -> Shut Down" menu item, due to the absence of a "Shut Down (NOW)" button in that dialog.
Comment 8 Ray Strode [halfline] 2008-10-13 12:23:36 EDT
What version of gnome-panel, what version of gnome-session?
Comment 9 Jóhann B. Guðmundsson 2008-10-13 16:49:54 EDT
Fully updated to today's rawhide on a 64bit system after the weekend and the shut down is present again. 

Will test against fresh install tomorrow on a i686 system

I have to agree that the 60 second time out is unnecessary
Comment 10 Flóki Pálsson 2008-10-13 17:55:08 EDT
I have got this problem to.
gnome-panel-2.24.0-7.fc10.x86_64
gnome-session-2.24.0-10.fc10.x86_64
Comment 11 Mikkel Lauritsen 2008-10-14 03:00:46 EDT
gnome-panel-2.24.0-6.fc10.x86_64 and gnome-session-2.24.0-10.fc10.x86_64 here.
I have just upgraded to gnome-panel-2.24.0-7.fc10.x86_64 and rebooted the machine, but the Shut Down menu item is still missing.
Comment 12 Flóki Pálsson 2008-10-14 04:02:56 EDT
After rebooting then Shut Down is in menu for System and working.
If user is log out then after login in again then Shut down in menu for System is missing and Log Out Button on panel is grayed out.It is possible to right click on Log Out Button on panel to get help.
See comment #10.
System language is IS.
Comment 13 Adam Pribyl 2008-10-14 10:41:48 EDT
I have the same problem on an i686 installation... just to mention this is not x86_64 related.
Comment 14 chris desjardins 2008-10-14 11:14:05 EDT
When I start the gnome session shut down is always missing.  if i open alacarte then shut down magically appears in the system menu.  i am running up to date rawhide.
Comment 15 chris desjardins 2008-10-14 11:14:40 EDT
opening alacarte always makes shut down appear.
Comment 16 Ray Strode [halfline] 2008-10-15 12:05:08 EDT
I looked at this a bit today with Matthias and we discovered a bogus check that was causing a race condition.

Should be fixed in tomorrow's rawhide.

If you still experience issues, please reopen.

Note You need to log in before you can comment on or make changes to this bug.