Bug 466700 - F10snap1 LiveCD "System -> Shut Down" dialog has no shutdown button
F10snap1 LiveCD "System -> Shut Down" dialog has no shutdown button
Status: CLOSED DUPLICATE of bug 466456
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-12 19:24 EDT by Hans Ulrich Niedermann
Modified: 2008-10-13 13:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-12 22:34:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans Ulrich Niedermann 2008-10-12 19:24:33 EDT
Description of problem:

  You boot your system from the LiveCD, log in as the livecd
  user, and use the LiveCD some.

  When you are finished using the LiveCD, you go to the Gnome
  menu and select "System -> Shut down".

  Now a dialog pops up which looks about like this:

   +------------------------------------------------------------+
   | __Shut down this system now?__                             |
   |                                                            |
   | You are currently logged in as "Live System User".         |
   | This system will automatically be shut down in 60 seconds. |
   |                                                            |
   |                           [Suspend*] [Hibernate] [Cancel]  |
   +------------------------------------------------------------+

  * Suspend button not available when running F10snap1
    in qemu.

  The "60 seconds" will decrease by 10 every 10 seconds.

  Why can't there just be a "Shut Down" button which shuts the
  system down right now, like on any normal non-Live-CD system?

Version-Release number of selected component (if applicable):

  F10 Snap1 LiveCD

How reproducible:

  100%

Steps to Reproduce:
1. qemu -m 512 -cdrom path/to/F10-Snap1-i686-Live.iso
   (or boot the physical system from the F10 Snap1 LiveCD)
2. Wait until system has booted up to Gnome desktop.
3. Select "System -> Shut down" to shut down.
4. Curse about the unnecessary enforced 60 second wait.
  
Actual results:

  No "Shut Down" button.

Expected results:

  A "Shut Down" or "Shut Down NOW" button.

Additional info:

  This might be related to or duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=444870 but I'll leave that for the experts to decide.
  A comment there suggests that this might be related to
  gnome-panel, gnome-session, GDM, ConsoleKit. Please reassign this bug
  to the appropriate package when necessary.
Comment 1 Hans Ulrich Niedermann 2008-10-12 19:27:04 EDT
I forgot: Ping me if you need the F10 Snap1 ISO image without waiting a week for the torrent to finish.
Comment 2 Hans Ulrich Niedermann 2008-10-12 19:54:31 EDT
I appears that, when running under qemu (and unlike when running directly on the bare metal) the system is not actually shut down when that timeout expires.
Comment 3 Ray Strode [halfline] 2008-10-12 19:59:46 EDT
what version of gnome-session is on the livecd?
Comment 4 Hans Ulrich Niedermann 2008-10-12 20:56:54 EDT
[liveuser@localhost ~]$ rpm -q kernel gnome-session gnome-panel ConsoleKit gdm upstart
kernel-2.6.27-1.fc10.i686
gnome-session-2.24.0-8.fc10.i386
gnome-panel-2.24.0-6.fc10.i386
ConsoleKit-0.3.0-2.fc10.i386
gdm-2.24.0-8.fc10.i386
upstart-0.3.9-19.fc10.i386
[liveuser@localhost ~]$
Comment 5 Matthias Clasen 2008-10-12 22:34:45 EDT

*** This bug has been marked as a duplicate of bug 466456 ***
Comment 6 Ray Strode [halfline] 2008-10-13 13:03:14 EDT
This was a problem in gnome-session-2.24.0-8 that got fixed in gnome-session-2.24.0-9

Note You need to log in before you can comment on or make changes to this bug.