This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 466493 - spinfinity looks like it freezes
spinfinity looks like it freezes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
: 469503 (view as bug list)
Depends On:
Blocks: F10DesktopTarget
  Show dependency treegraph
 
Reported: 2008-10-10 11:07 EDT by Mads Kiilerich
Modified: 2009-05-11 16:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 16:53:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2008-10-10 11:07:44 EDT
Description of problem:
Spinning infinity looks very nice. But it is unfortunate that it looks like it hangs when the tail is about to disappear to the left.

Please make sure that it fades away as smooth as the animation otherwise does.

Further, in the end of the boot sequence the animation just stops. It would look a lot better if it faded completely away first.

Version-Release number of selected component (if applicable):
plymouth-plugin-spinfinity-0.6.0-0.2008.10.08.1.fc10.i386
Comment 1 Ray Strode [halfline] 2008-10-13 15:36:00 EDT
so it's supposed to complete the animation before ending. There must be a bug, in that code.
Comment 2 Ray Strode [halfline] 2008-10-30 17:54:59 EDT
So it looks like i added a become_idle hook, but never call it.
Comment 3 Ray Strode [halfline] 2008-11-01 14:47:13 EDT
*** Bug 469503 has been marked as a duplicate of this bug. ***
Comment 4 Bug Zapper 2008-11-25 22:44:50 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Ray Strode [halfline] 2009-05-11 16:53:08 EDT
this is fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.