Bug 466619 - mount -l Segmentation Fault
mount -l Segmentation Fault
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
: 467706 468011 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-11 09:14 EDT by Charles R. Anderson
Modified: 2008-11-05 23:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 23:07:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace mount -l output (9.21 KB, text/plain)
2008-10-11 09:14 EDT, Charles R. Anderson
no flags Details
/etc/mtab (412 bytes, text/plain)
2008-10-11 09:15 EDT, Charles R. Anderson
no flags Details
/etc/blkid/blkid.tab (1.49 KB, text/plain)
2008-10-11 09:16 EDT, Charles R. Anderson
no flags Details

  None (edit)
Description Charles R. Anderson 2008-10-11 09:14:55 EDT
Created attachment 320090 [details]
strace mount -l output

Description of problem:

mount -l crashes with a Segmentation fault.

Version-Release number of selected component (if applicable):
util-linux-ng-2.13.1-8.3.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1. mount -l
  
Actual results:

# mount -l
/dev/mapper/garibaldi-root on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
Segmentation fault (core dumped)

Expected results:
no crash

Additional info:

Core was generated by `mount -l'.
Program terminated with signal 11, Segmentation fault.
[New process 3773]
#0  0x00000000009d99c2 in strcmp () from /lib64/libc-2.8.so
(gdb) bt
#0  0x00000000009d99c2 in strcmp () from /lib64/libc-2.8.so
#1  0x00000000003323c2 in blkid_get_dev (cache=<value optimized out>,
    devname=<value optimized out>, flags=<value optimized out>) at devname.c:99
#2  0x0000000000335c3d in blkid_get_tag_value (cache=<value optimized out>,
    tagname=<value optimized out>, devname=<value optimized out>)
    at resolve.c:45
#3  0x00007f159d8ba398 in print_one (me=<value optimized out>) at mount.c:260
#4  0x00007f159d8bddde in main (argc=<value optimized out>,
    argv=<value optimized out>) at mount.c:280
Comment 1 Charles R. Anderson 2008-10-11 09:15:55 EDT
Created attachment 320091 [details]
/etc/mtab
Comment 2 Charles R. Anderson 2008-10-11 09:16:39 EDT
Created attachment 320092 [details]
/etc/blkid/blkid.tab
Comment 3 Karel Zak 2008-10-13 16:06:43 EDT
Eric, backport the below patch to F9, please.

  commit bb47c2a4aff6ec6b9be7f30cd04cf7c858a84de4
  Author: Theodore Ts'o <tytso@mit.edu>
  Date:   Sun Jul 13 19:10:10 2008 -0400

  libblkid: Make sure we never reference a null dev->bid_type
Comment 4 Eric Sandeen 2008-10-13 16:16:06 EDT
Karel, thanks.  I have a few other e2fsprogs open on F9 that are solved upstream, I'll bring 1.41.3 back now I think.
Comment 5 Fedora Update System 2008-10-13 17:06:06 EDT
e2fsprogs-1.41.3-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/e2fsprogs-1.41.3-2.fc9
Comment 6 Fedora Update System 2008-10-15 22:12:10 EDT
e2fsprogs-1.41.3-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update e2fsprogs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8884
Comment 7 backslash 2008-10-17 12:05:38 EDT
i tried 
yum --enablerepo=updates-testing update e2fsprogs
as root but yum says no package to be updated, but the version installed (with yum info) is 1.41.0 release 2.fc9
Comment 8 Eric Sandeen 2008-10-17 12:22:11 EDT
I see e2fsprogs-1.41.3-2.fc9.x86_64.rpm on, for example, the facebook mirror, so perhaps your mirror just isn't updated quite yet?

-Eric
Comment 9 Karel Zak 2008-10-20 16:49:44 EDT
*** Bug 467706 has been marked as a duplicate of this bug. ***
Comment 10 Charles R. Anderson 2008-10-20 17:03:58 EDT
The new e2fsprogs fixes this problem for me.
Comment 11 Ralf Corsepius 2008-10-20 21:24:55 EDT
e2fsprogs-1.41.3-2.fc9.x86_64 seems to fix this issue for me.

(In reply to comment #7)
Try
yum --enablerepo=updates-testing-newkey update e2fsprogs
Comment 12 Karel Zak 2008-10-22 17:50:28 EDT
*** Bug 468011 has been marked as a duplicate of this bug. ***
Comment 13 Fedora Update System 2008-11-05 23:06:57 EST
e2fsprogs-1.41.3-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.