Bug 467706 - mount -l segfaults
mount -l segfaults
Status: CLOSED DUPLICATE of bug 466619
Product: Fedora
Classification: Fedora
Component: util-linux-ng (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-20 08:51 EDT by Ralf Corsepius
Modified: 2008-10-20 16:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 16:49:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2008-10-20 08:51:17 EDT
Description of problem:

# mount -l
/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
Segmentation fault (core dumped)

Version-Release number of selected component (if applicable):
util-linux-ng-2.13.1-8.3.fc9.x86_64

How reproducible:
Always.

Additional info:

# gdb /bin/mount core.3710 
GNU gdb Fedora (6.8-22.fc9)
...
Core was generated by `mount -l'.
Program terminated with signal 11, Segmentation fault.
[New process 3710]
#0  0x00000000009d99c2 in strcmp () from /lib64/libc-2.8.so
(gdb) where
#0  0x00000000009d99c2 in strcmp () from /lib64/libc-2.8.so
#1  0x00000000003323c2 in blkid_get_dev (cache=<value optimized out>, devname=<value optimized out>, flags=<value optimized out>) at devname.c:99
#2  0x0000000000335c3d in blkid_get_tag_value (cache=<value optimized out>, tagname=<value optimized out>, devname=<value optimized out>) at resolve.c:45
#3  0x00007f32925f6398 in print_one (me=<value optimized out>) at mount.c:260
#4  0x00007f32925f9dde in main (argc=<value optimized out>, argv=<value optimized out>) at mount.c:280
Comment 1 Karel Zak 2008-10-20 16:49:44 EDT

*** This bug has been marked as a duplicate of bug 466619 ***

Note You need to log in before you can comment on or make changes to this bug.