Bug 466792 - Erratic cursor and text display when emacs uses X-window display; Toshiba A305-S6857
Erratic cursor and text display when emacs uses X-window display; Toshiba A30...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-13 12:41 EDT by Richard Ryniker
Modified: 2008-10-29 19:21 EDT (History)
1 user (show)

See Also:
Fixed In Version: xorg-x11-drv-i810-2.5.0-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 19:21:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg startup log. (77.20 KB, text/plain)
2008-10-13 12:43 EDT, Richard Ryniker
no flags Details
Xorg startup log for working, revised configuration. (75.02 KB, text/plain)
2008-10-13 21:46 EDT, Richard Ryniker
no flags Details

  None (edit)
Description Richard Ryniker 2008-10-13 12:41:34 EDT
Description of problem: emacs window suffers erratic display of cursor and
keyboard-entered data.  Hardware:  Toshiba laptop A305-S6857, Intel
Graphics Media Accelerator X3100.  Software:  Fedora 10 snap1 installed
to hard drive, updated from rawhide.


Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.4.2-9.fc10.x86_64
emacs-22.2-5.fc9.x86_64
emacs-common-22.2-5.fc9.x86_64

How reproducible: always with local (laptop) display.  Does not occur when
using remote display (different host, different display hardware).


Steps to Reproduce:
1. Start emacs with X-window display.
2. Observe cursor, enter text or use cursor movement keys.
3.
  
Actual results:
After a short while (less than 30 seconds) the cursor disappears (stops
blinking).  It may re-appear some seconds later, then disappear, etc.
When entering text from the keyboard, display of characters typed may
stop.  Ctrl-L forces redisplay of window, then the missing characters appear and
cursor display resumes, but the condition is likely to recur a short while later.

Expected results:
No interrupted display of cursor or characters entered from keyboard.

Additional info:
Comment 1 Richard Ryniker 2008-10-13 12:43:53 EDT
Created attachment 320202 [details]
Xorg startup log.
Comment 2 Richard Ryniker 2008-10-13 21:43:17 EDT
Improvement.

Executed system-config-display, which would not offer the native display
resolution of 1280x800 but 1024X758 at best.  Manually configured as a
generic LCD display with 1280x800 resolution, using system-config-display.

Early indication, after reboot, is this has corrected the problem.

I surmise it is the presence of an xorg.conf file, rather than this specific
display definition, that results in superior initialization of the X server.
I shall attach the present, working Xorg startup log so it can be compared
with the original log.

This bug is probably incorrectly associated with component xorg-x11-drv-i810
now, but where it belongs is not clear to me.
Comment 3 Richard Ryniker 2008-10-13 21:46:37 EDT
Created attachment 320240 [details]
Xorg startup log for working, revised configuration.
Comment 4 Matěj Cepl 2008-10-14 10:10:26 EDT
Isn't this duplicate of bug 463023 ?
Comment 5 Matěj Cepl 2008-10-14 10:27:08 EDT
(In reply to comment #4)
> Isn't this duplicate of bug 463023 ?

No, it isn't
Comment 6 Matěj Cepl 2008-10-15 04:52:00 EDT
Are you using compiz?
Comment 7 Richard Ryniker 2008-10-15 16:07:11 EDT
Compiz is part of the Snap1 live image that was installed on this machine,
and the compiz libraries are present.  However, "desktop effects"
(System->Preferences->Look and Feel->Desktop Effects->Enable Desktop Effects)
was never selected.  Therefore, if I understand your question accurately,
the answer is "No."
Comment 8 Richard Ryniker 2008-10-15 16:13:30 EDT
"Improvement" reported in Comment #2 is incorrect.  The problem continues.

I have a qualitative impression it is less frequent than originally
perceived, but it definitely occurs.
Comment 9 Richard Ryniker 2008-10-29 18:38:15 EDT
Bug fixed after update from xorg-x11-drv-i810-2.4.2-9.fc10.x86_64
to xorg-x11-drv-i810-2.5.0-1.fc10.x86_64 (or maybe by a change in
a related package).  I assume this was an upstream change, and therefore
this report can now be closed.

Note You need to log in before you can comment on or make changes to this bug.