Bug 466801 - Fedora 10 Beta DVD fails to install on Dell Optiplex GX270
Fedora 10 Beta DVD fails to install on Dell Optiplex GX270
Status: CLOSED DUPLICATE of bug 461829
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-10-13 13:42 EDT by Jaroslav Franek
Modified: 2008-11-06 12:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-11-06 12:31:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jaroslav Franek 2008-10-13 13:42:31 EDT
Description of problem:

The installation process using the DVD is abruptly stopped right before entering the graphical mode with fatal messages from anaconda installer. Since the messages are very verbose they manage to slide off the screen quickly. I just got a glimpse of the following:

/usr/bin/anaconda  line 832
in <module>

...  (scrolls quickly out of the screen)

  File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 67, in _
RuntimeError: could not open display
install exited abnormally [1/1]

Machine details:
name: Dell Optiplex GX270
CPU:  Intel Pentium IV 2.8GHz  (i686)
graphics: Intel Corp. 82865G Integrated Graphics Device (rev 02) (prog-if 00 [VGA])

Version-Release number of selected component (if applicable):
Fedora 10 Beta

How reproducible:
Trying to install Fedora 10 Beta from the DVD

Steps to Reproduce:
1. Trying to install Fedora 10 Beta from the DVD
Actual results:
abnormal installation termination, given a nice message that it is safe to reboot the computer..., unable to install

Expected results:
able to install cleanly

Additional info:
I tried also nomodeset kernel parameter with no effect, still the same fatal error. And yes, the DVD was tested before the installation ;-)
Comment 1 Jaroslav Franek 2008-11-06 11:28:48 EST
update for Fedora 10 Preview:

Anaconda installer no longer fires a call stack, it just informs that initialization of X failed, and therefore the installer switches itself into text mode. Same result when using kernel boot parameter 'nomodeset'.

Text mode allows F10 to install. However, X is not working. At least I can now get some diagnostic from the kernel:

# dmesg | grep drm

[drm] Initialized drm 1.1.0 20060810
[drm:i915_driver_load] *ERROR* failed to enable MSI
[drm] Initialized i915 1.6.0 20080730 on minor 0
[drm:i915_gem_object_bind_to_gtt] *ERROR* GTT full, but LRU list empty
[drm:i915_gem_object_pin] *ERROR* Failure to bind: -12

kernel boot params include 'nomodeset'

Looks like a driver problem (Intel graphics adapter, see comment #1), and problem with the new graphical memory manager (GEM).
Comment 2 Jaroslav Franek 2008-11-06 12:30:33 EST
Ah, new kernel just came out: Updated everything from rawhide. All right, this is the result: `dmesg | grep drm` is clean now, no problem written into kernel log (fixed or silenced?). But /var/log/Xorg.0.log shows an issue:

X.Org X Server 1.5.2          (-12.fc10.i686)
(II) intel(0): xf86BindGARTMemory: bind key 2 at 0x06000000 (pgoffset 24576)
(EE) intel(0): Failed to pin front buffer: Cannot allocate memory

Fatal server error:
Couldn't bind memory for BO front buffer

(II) intel(0): xf86UnbindGARTMemory: unbind key 0

Therefore still no graphics mode available. However now this bug degenerates to a duplicate of Bug #461829.
Comment 3 Jaroslav Franek 2008-11-06 12:31:40 EST

*** This bug has been marked as a duplicate of bug 461829 ***

Note You need to log in before you can comment on or make changes to this bug.