Bug 466843 - ext4 bug when resuming from suspend from disk
ext4 bug when resuming from suspend from disk
Status: CLOSED DUPLICATE of bug 467161
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 00:54 EDT by Gabriel Ramirez
Modified: 2008-10-16 11:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-16 11:40:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
is the log from a console attached at a serial port in the Virtual machine, I removed the "rhgb quiet" from the kernel boot line (15.08 KB, text/plain)
2008-10-14 00:54 EDT, Gabriel Ramirez
no flags Details

  None (edit)
Description Gabriel Ramirez 2008-10-14 00:54:40 EDT
Created attachment 320249 [details]
is the log from a console attached at a serial port in the Virtual machine, I removed the "rhgb quiet" from the kernel boot line

Description of problem:
unable to boot after suspending to disk with Fedora 10 Beta upgraded to rawhide, the last rpms updated were openoffice 3.0

I was running a kde session from where I suspended to disk and the virtual machine shutdown fine.

but when I try to boot the virtual machine stops with:

EXT4-fs: dm-0: orphan cleanup on readonly fsice                                 
BUG: unable to handle kernel NULL pointer dereference at 00000004
 and a kernel panic.

- I will attach a log of the console

- I'm unable to boot a earlier kernel version because the fstab have ext4 and not ext4dev


this a virtual machine created with VirtualBox 2.0.2
guest OS: Fedora 10 beta updated to rawhide
/boot ext3
/ ext4
swap swap

host OS: Fedora 9 x64


Version-Release number of selected component (if applicable):
Linux version 2.6.27-3.fc10.i686

How reproducible:
I don't  know if its reproducible in other machine, but the steps were:


Steps to Reproduce:
1. install F10 Beta partitions
/boot ext3
LVM
- / ext4
- swap
2. updated to the updates in rawhide until openoffice 3.0, 12th October 2008
3. suspend to to disk, from kde 4.1.2
4. the machine shutdown fine
5. try to boot - I don't have this log after  10 minutes the virtual machine didn't boot I reset it
6. attached a console to serial port 
7. the subsequent time trying to boot shows the info in the log attached 

  
Actual results:
the virtual machine stops with a kernel panic in ext4 code


Expected results:
resuming the machine state from disk

Additional info:
this is a Virtual machine under virtualbox 2.0.2 in the VM settings I disabled the io-apic options that caused random troubles to boot

I don't have any info in the virtual machine I can reinstall it, but maybe is a bug in ext4 code 

thanks
Comment 1 Dave Jones 2008-10-16 11:40:55 EDT

*** This bug has been marked as a duplicate of bug 467161 ***

Note You need to log in before you can comment on or make changes to this bug.