Bug 467161 - kerneloops on boot (ext4 related)
kerneloops on boot (ext4 related)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
: 466843 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-16 02:11 EDT by James Cassell
Modified: 2008-10-16 12:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-16 12:12:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel oops message (2.40 KB, text/plain)
2008-10-16 02:11 EDT, James Cassell
no flags Details
kernel oops message (3.67 KB, text/plain)
2008-10-16 11:21 EDT, James Cassell
no flags Details

  None (edit)
Description James Cassell 2008-10-16 02:11:40 EDT
Created attachment 320517 [details]
kernel oops message

Description of problem:
system won't boot.  Kernel panic after logical volumes are active (my guess is when it reads filesystem).  I'm guessing that my filesystem is corrupt, because it happens with all the kernels I have (back to the one right before .27-3)

Version-Release number of selected component (if applicable):
2.6.27-13.fc10.x86_64

How reproducible:
unknown/always

Steps to Reproduce:
1.turn on system
I really have no idea how to reproduce this
  
Actual results:
system should boot normally

Expected results:
kernel panic

Additional info:
Comment 1 James Cassell 2008-10-16 02:13:31 EDT
the oops message I attached is only the first part/halfish.  I will type the rest of it if someone says it's necessary, but I don't have time right now (perhaps tomorrow)
Comment 2 James Cassell 2008-10-16 11:21:05 EDT
Created attachment 320565 [details]
kernel oops message

I got the remainder from a separate boot (same kernel, of course), but the call trace is exactly the same.  A couple of registers were different
Comment 3 Dave Jones 2008-10-16 11:40:55 EDT
*** Bug 466843 has been marked as a duplicate of this bug. ***
Comment 4 Eric Sandeen 2008-10-16 12:12:09 EDT
Needed to update the ext4 patch queue again; the "do_mballoc_init_before_doing_filesystem_recovery" patch should take care of this failure.

Should be in the next build.

Thanks,
-Eric

Note You need to log in before you can comment on or make changes to this bug.