Bug 466864 - Latest NM-vpnc (svn4175) doesn't connect
Latest NM-vpnc (svn4175) doesn't connect
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 466972 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 04:34 EDT by Denis Leroy
Modified: 2008-12-21 18:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-14 15:24:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denis Leroy 2008-10-14 04:34:36 EDT
Since the update from svn4024 to svn4175, NM-vpnc no longer works. After entering the password, a "Connection failed" notify window immediatly pops up. Connecting manually using vpnc works fine.

This shows up on /var/log/messages :

Oct 14 10:33:31 jupiler NetworkManager: <info>  Starting VPN service 'org.freedesktop.NetworkManager.vpnc'...
Oct 14 10:33:31 jupiler NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.vpnc' started (org.freedesktop.NetworkManager.vpnc), PID 5033
Oct 14 10:33:31 jupiler NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.vpnc' just appeared, activating connections
Oct 14 10:33:31 jupiler NetworkManager: <info>  VPN plugin state changed: 1
Oct 14 10:33:44 jupiler NetworkManager: <info>  VPN plugin state changed: 3
Oct 14 10:33:44 jupiler NetworkManager: <info>  VPN connection 'Sun VPN' (Connect) reply received.
Oct 14 10:33:44 jupiler NetworkManager: <info>  VPN plugin failed: 1
Oct 14 10:33:44 jupiler NetworkManager: <info>  VPN plugin state changed: 6
Oct 14 10:33:44 jupiler NetworkManager: <info>  VPN plugin state change reason: 0
Oct 14 10:33:44 jupiler NetworkManager: <WARN>  connection_state_changed(): Could not process the request because no VPN connection was active.
Oct 14 10:33:44 jupiler NetworkManager: <WARN>  nm_system_replace_default_ip4_route(): replace_default_ip4_route() returned error Success (0)
Oct 14 10:33:44 jupiler NetworkManager: <info>  Policy set 'Auto Wanadoo_eae9' (wlan0) as default for routing and DNS.
Comment 1 Dan Williams 2008-10-14 10:52:24 EDT
Could you, as root, run:

killall -TERM nm-vpnc-service
/usr/libexec/nm-vpnc-service

then try to connect and paste in the output here?  Thanks!
Comment 2 Denis Leroy 2008-10-14 12:28:36 EDT
# /usr/libexec/nm-vpnc-service
** Message: <info>  vpnc started with pid 26576

/usr/sbin/vpnc: missing IPSec secret

** (process:26553): WARNING **: <WARN>  vpnc_watch_cb(): vpnc exited with error code 1
Comment 3 Dan Williams 2008-10-14 12:39:20 EDT
Do you by chance not store your user password in the keyring?
Comment 4 Denis Leroy 2008-10-14 12:46:37 EDT
Only the group password. I've never stored the user password as we use one-time passwords from a cryptocard thingie.

I'm on #fedora-devel if you need more info.
Comment 5 Dan Williams 2008-10-14 15:24:25 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=880563

please test, thanks!
Comment 6 Denis Leroy 2008-10-14 15:38:37 EDT
Fix is verified. Thanks!
Comment 7 Dan Williams 2008-10-15 10:52:19 EDT
*** Bug 466972 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2008-11-23 18:05:43 EST
NetworkManager-0.7.0-0.12.svn4326.fc9,NetworkManager-vpnc-0.7.0-0.11.svn4326.fc9,NetworkManager-openvpn-0.7.0-16.svn4326.fc9,NetworkManager-pptp-0.7.0-0.12.svn4326.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0-0.12.svn4326.fc9,NetworkManager-vpnc-0.7.0-0.11.svn4326.fc9,NetworkManager-openvpn-0.7.0-16.svn4326.fc9,NetworkManager-pptp-0.7.0-0.12.svn4326.fc9
Comment 9 Fedora Update System 2008-11-23 18:08:03 EST
NetworkManager-0.7.0-0.12.svn4326.fc8,NetworkManager-vpnc-0.7.0-0.11.svn4326.fc8,NetworkManager-openvpn-0.7.0-16.svn4326.fc8,NetworkManager-pptp-0.7.0-0.12.svn4326.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0-0.12.svn4326.fc8,NetworkManager-vpnc-0.7.0-0.11.svn4326.fc8,NetworkManager-openvpn-0.7.0-16.svn4326.fc8,NetworkManager-pptp-0.7.0-0.12.svn4326.fc8
Comment 10 Fedora Update System 2008-12-21 18:38:11 EST
NetworkManager-0.7.0-0.12.svn4326.fc9, NetworkManager-vpnc-0.7.0-0.11.svn4326.fc9, NetworkManager-openvpn-0.7.0-16.svn4326.fc9, NetworkManager-pptp-0.7.0-0.12.svn4326.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2008-12-21 18:43:16 EST
NetworkManager-0.7.0-0.12.svn4326.fc8, NetworkManager-vpnc-0.7.0-0.11.svn4326.fc8, NetworkManager-openvpn-0.7.0-16.svn4326.fc8, NetworkManager-pptp-0.7.0-0.12.svn4326.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.