Bug 466972 - NetworkManager-vpnc fails to connect (regression)
NetworkManager-vpnc fails to connect (regression)
Status: CLOSED DUPLICATE of bug 466864
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 16:03 EDT by Jeremy Fitzhardinge
Modified: 2008-10-15 10:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 10:52:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Fitzhardinge 2008-10-14 16:03:17 EDT
Description of problem:
Connecting to a Cisco VPN with vpnc via NetworkManager fails

Version-Release number of selected component (if applicable):
NetworkManager-vpnc-0.7.0-0.10.svn4175.fc10.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Configure vpnc connection
2. Try to connect
3.
  
Actual results:
Connection fails immediately with "The VPN connection 'XXX' failed", and no other details.

Expected results:
Should connect

Additional info:
I'm using an RSA token, so the password is never saved.  The group password is saved.

Strace shows (XXX=redacted):
4573  read(0, "Script /usr/libexec/nm-vpnc-service-vpnc-helper\nCisco UDP Encaps
ulation Port 0\nIPSec ID XXX\nDPD idle timeout (our side) 90\nIPSec gatew
ay XX.XX.XX.XX\nNAT Traversal Mode natt\nXauth username XXX\nXauth password 
IPSec secret\n"..., 4096) = 231
4573  read(0, ""..., 4096)              = 0
4573  uname({sys="Linux", node="abulafia.goop.org", ...}) = 0
4573  write(2, "/usr/sbin/vpnc: "..., 16) = 16
4573  write(2, "missing IPSec secret"..., 20) = 20
4573  write(2, "\n"..., 1)              = 1

This was working fine with the previous version (1:0.7.0-10.svn4024).  This is a regression in the Oct 12 update (1:0.7.0-10.svn4175).
Comment 1 Jeremy Fitzhardinge 2008-10-14 16:04:46 EDT
Oh, connecting directly with vpnc continues to work fine.
Comment 2 Dan Williams 2008-10-15 10:52:19 EDT
Updates were built yesterday, please check the duped bug for more details.

*** This bug has been marked as a duplicate of bug 466864 ***

Note You need to log in before you can comment on or make changes to this bug.