Bug 466879 - Package Review: perl-Crypt-GeneratePassword - Generate secure random pronounceable passwords
Package Review: perl-Crypt-GeneratePassword - Generate secure random pronounc...
Status: CLOSED DUPLICATE of bug 452458
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Tibbitts
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F-Spacewalk
  Show dependency treegraph
 
Reported: 2008-10-14 06:39 EDT by Miroslav Suchý
Modified: 2008-12-03 07:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 07:18:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tibbs: fedora‑review+
huzaifas: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2008-10-14 06:39:33 EDT
Spec: http://miroslav.suchy.cz/fedora/perl-Crypt-GeneratePassword/perl-Crypt-GeneratePassword.spec
SRPM: http://miroslav.suchy.cz/fedora/perl-Crypt-GeneratePassword/perl-Crypt-GeneratePassword-0.03-3.f10.src.rpm
Description:
Crypt::GeneratePassword generates random passwords that are (more or less)
pronounceable. Unlike Crypt::RandPasswd, it doesn't use the FIPS-181 NIST
standard, which is proven to be insecure. It does use a similar interface,
so it should be a drop-in replacement in most cases.

Scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=879667

$ rpmlint perl-Crypt-GeneratePassword-0.03-3.fc10.noarch.rpm
1 packages and 0 specfiles checked; 0 errors, 0 warnings.
$ rpmlint perl-Crypt-GeneratePassword-0.03-3.fc10.src.rpm
1 packages and 0 specfiles checked; 0 errors, 0 warnings.
Comment 1 Jason Tibbitts 2008-10-17 16:29:18 EDT
Not much to say here, really.  I guess I could point out that most people tend to prefer calling iconv over patching to fix utf8 issues, but that's up to you.

* source files match upstream:
   4274d1aedcdd6e5ad54f417390dae75bc9231726c7431ab1aee40a507b3748c3  
   Crypt-GeneratePassword-0.03.tar.gz
* package meets naming and versioning guidelines.
* specfile is properly named, is cleanly written and uses macros consistently.
* summary is OK.
* description is OK.
* dist tag is present.
* build root is OK.
* license field matches the actual license.
* license is open source-compatible.
* license text not included upstream.
* latest version is being packaged.
* BuildRequires are proper.
* %clean is present.
* package builds in mock (rawhide, x86_64).
* package installs properly.
* rpmlint is silent.
* final provides and requires are sane:
   perl(Crypt::GeneratePassword) = 0.03
   perl-Crypt-GeneratePassword = 0.03-3.fc10
  =
   perl(:MODULE_COMPAT_5.10.0)
   perl(Exporter)
   perl(strict)
   perl(vars)

* %check is present and the one test passes.  It's about the minimal useful test 
   suite you can get for a Perl module, but it's there.
* owns the directories it creates.
* doesn't own any directories it shouldn't.
* no duplicates in %files.
* file permissions are appropriate.
* code, not content.
* documentation is small, so no -doc subpackage is necessary.
* %docs are not necessary for the proper functioning of the package.

APPROVED

The package review process needs reviewers!  If you haven't done any package
reviews recently, please consider doing one.
Comment 2 Miroslav Suchý 2008-10-21 08:21:59 EDT
New Package CVS Request
=======================
Package Name: perl-Crypt-GeneratePassword
Short Description: Generate secure random pronounceable passwords
Owners: msuchy
Branches: devel F-9 F-10 EL-4 EL-5 
InitialCC:
Cvsextras Commits: yes
Comment 3 Huzaifa S. Sidhpurwala 2008-10-22 06:34:42 EDT
cvs done
Comment 4 Jason Tibbitts 2008-12-02 18:25:14 EST
Any reason this ticket is still open?
Comment 5 Miroslav Suchý 2008-12-03 06:33:41 EST
Hmm, there is one problem.
We both missed that is package is already included:
https://bugzilla.redhat.com/show_bug.cgi?id=452458
But it now bring the situation that I'm owner of F-10, F-9, EL-4 and  EL-5 branch. And nigelj is owner of devel and F-8. 
https://admin.fedoraproject.org/pkgdb/packages/name/perl-Crypt-GeneratePassword
Comment 6 Miroslav Suchý 2008-12-03 07:18:57 EST

*** This bug has been marked as a duplicate of bug 452458 ***

Note You need to log in before you can comment on or make changes to this bug.