Bug 467000 - Hostname property not available via D-Bus anymore
Hostname property not available via D-Bus anymore
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 21:42 EDT by David Cantrell
Modified: 2008-10-15 10:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 10:56:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Cantrell 2008-10-14 21:42:10 EDT
anaconda bug #466775 was affected by a change in the recent NetworkManager build that appeared in rawhide.  The Hostname property is no longer available via D-Bus, which is how we were getting the hostname to display in the installer.  The latest nightly build has broken network installations for everyone because of this problem.

If this is a permanent change to NetworkManager, it should wait for F-11.  We are in a development freeze for F-10 at this point.
Comment 1 Dan Williams 2008-10-15 10:56:14 EDT
clumens and I went over this yesterday and he should have fixed it...  the fallback code to gethostname(2) is actually correct; just the bits to ask NM for the hostname should be removed.  Having the hostname as part of the IP4 config doesn't make sense since it's machine global, and gethostname(2) would always have returned the correct result if the hostname was changed anyway...

Note You need to log in before you can comment on or make changes to this bug.