Bug 467016 - Dead keys are not rcognized as such
Dead keys are not rcognized as such
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-15 03:35 EDT by Matěj Cepl
Modified: 2008-12-15 19:59 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-15 19:59:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of xev (7.20 KB, text/plain)
2008-10-15 03:35 EDT, Matěj Cepl
no flags Details
/var/log/Xorg.0.log (83.96 KB, text/plain)
2008-10-15 03:36 EDT, Matěj Cepl
no flags Details
xev log (5.90 KB, text/plain)
2008-10-16 01:26 EDT, Peter Hutterer
no flags Details
output of xkbcomp :0 - (60.96 KB, text/plain)
2008-10-24 16:02 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2008-10-15 03:35:33 EDT
Created attachment 320401 [details]
output of xev

Description of problem:
Having cs_CZ locale, I need dead-key working, because some of the letters in the Czech keyboard layout are not on the keyboard directly (e.g., ňóť). Unfortunately when entering these keys in the current Fedora Rawhide I get ˇn´oˇt instead.

Version-Release number of selected component (if applicable):
xorg-x11-drv-keyboard-1.3.0-3.fc9.i386
xorg-x11-drv-evdev-2.0.6-2.fc10.i386

How reproducible:
100%

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
see above

Expected results:
see above (used gnucharmap to get these)

Additional info:
Comment 1 Matěj Cepl 2008-10-15 03:36:37 EDT
Created attachment 320402 [details]
/var/log/Xorg.0.log

... and of course I have no /etc/X11/xorg.conf
Comment 2 Peter Hutterer 2008-10-16 01:26:48 EDT
Created attachment 320516 [details]
xev log

Another xev log that Matej gave me yesterday. Attaching it so it doesn't get lost.
Comment 3 Peter Hutterer 2008-10-16 01:48:17 EDT
I need some more info please:
how am I supposed to create ňóť? Hitting Shift and the +/= key, then n works 
fine to produce an ň. Likewise the others, AFAICT. Also, the xev output looks correct.

What are you gnome options again? Have you tried xterm or konsole as well?
Comment 4 Matěj Cepl 2008-10-16 19:42:54 EDT
Of course, silly me, should try xterm myself. Yes, there is works like a charm. Will reassign to Gnome folks.
Comment 5 Matthias Clasen 2008-10-17 10:49:57 EDT
Please try gtk2-2.14.4-1.fc10. 
It has some fixes in dead key handling.
Comment 6 Matěj Cepl 2008-10-17 16:43:56 EDT
Unfortunately, no change. Still getting ˇn ˇt ´o instead of ňťó even with gtk2-2.14.4-1.fc10.i386.
Comment 7 Matthias Clasen 2008-10-17 17:40:49 EDT
What keyboard layout is this with ?
Comment 8 Matthias Clasen 2008-10-17 17:42:11 EDT
And what applications are you trying it in ?
Comment 9 Matthias Clasen 2008-10-17 17:44:04 EDT
Using the Czech layout, typing S-=n works fine to produce a ň, in gnome-terminal, gedit and firefox.
Comment 10 Matěj Cepl 2008-10-19 18:41:34 EDT
firefox, gedit, pidgin, gnome-terminal.

[matej@viklef ~]$ setxkbmap -print
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwertz)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+cz(qwerty)+us:2+inet(evdev)+group(shifts_toggle)+level3(ralt_switch_multikey)+compose(rctrl)+nbsp(level3)"	};
	xkb_geometry  { include "pc(pc104)"	};
};
[matej@viklef ~]$
Comment 11 Matthias Clasen 2008-10-19 18:54:18 EDT
ň - still works, with those exact settings.
Are you using any input methods ?
Comment 12 Matěj Cepl 2008-10-19 19:09:37 EDT
Still reproducible with *scim* packages gone, and this in gconf:

[matej@viklef ~]$ gconftool-2 -R /desktop/gnome/interface |grep gtk-im-
 gtk-im-status-style = callback
 gtk-im-module = gtk-im-context-simple
 gtk-im-preedit-style = callback
[matej@viklef ~]$
Comment 13 Matthias Clasen 2008-10-19 20:10:30 EDT
Actually, I cannot fully reproduce your xkb configuration. I only ever get

 xkb_keycodes  { include "evdev+aliases(qwerty)" };

And my symbols only have "cz" instead of "cz(qwerty)"

Not convinced that makes any difference.
Comment 14 Matthias Clasen 2008-10-19 20:12:48 EDT
Peter, looking at the matejs xev log:

KeyPress event, serial 27, synthetic NO, window 0x4200001,
    root 0x7b, subw 0x0, time 16186204, (164,-13), root:(173,58),
    state 0x0, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 30, synthetic NO, window 0x4200001,
    root 0x7b, subw 0x0, time 16186425, (164,-13), root:(173,58),
    state 0x1, keycode 21 (keysym 0xfe5a, dead_caron), same_screen YES,
    XLookupString gives 2 bytes: (cb 87) "ˇ"
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: True

KeyRelease event, serial 30, synthetic NO, window 0x4200001,
    root 0x7b, subw 0x0, time 16186485, (164,-13), root:(173,58),
    state 0x1, keycode 21 (keysym 0xfe5a, dead_caron), same_screen YES,
    XLookupString gives 2 bytes: (cb 87) "ˇ"
    XFilterEvent returns: False

KeyRelease event, serial 30, synthetic NO, window 0x4200001,
    root 0x7b, subw 0x0, time 16186535, (164,-13), root:(173,58),
    state 0x1, keycode 50 (keysym 0xfe0a, ISO_Prev_Group), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

Notice how the shift press doesn't match up with the release. Why is that ?
I don't see that in my own xev log, which shows a matching shift release.
Comment 15 Matthias Clasen 2008-10-19 20:18:02 EDT
Matej, what is the sequence of key presses and releases that you are using to type a ň ? ie something like 

press shift
press =
release =
release shift
press n
release n
Comment 16 Matěj Cepl 2008-10-20 09:24:48 EDT
Exactly like that.
Comment 17 Matěj Cepl 2008-10-24 16:02:25 EDT
Created attachment 321462 [details]
output of xkbcomp :0 -

When creating a new user, everything works smoothly. Any ideas, what goo I accquired where?
Comment 18 Matthias Clasen 2008-10-24 18:10:56 EDT
no idea, sorry.
Comment 19 Matthias Clasen 2008-10-26 18:42:29 EDT
Lets close this for now, ok ?
Comment 20 Matěj Cepl 2008-10-27 06:09:16 EDT
(In reply to comment #19)
> Lets close this for now, ok ?

Please no, I don't insist to be fixed immediately (or even soon), but it is still broken, and it is gnome* problem (xterm still works like a charm). Removed fedora-x-target from blocking bugs, so that your conscience is soothened.
Comment 21 Matěj Cepl 2008-11-03 06:07:38 EST
OK, somewhere between removing scim (again) and doing zillion changes to gconf and couple of others things, it justed start to work. No idea, what fixed it, but I am not in the mood to play with it too much.

Blaming scim, but closing as INSUFFICIENT_DATA, because I am not able to say much about it.
Comment 22 Jens Petersen 2008-11-04 19:46:21 EST
Given comment 12 I don't know why you are blaming scim which hasn't really changed for f10: xorg-x11 or possibly imsettings sound more plausible suspects, but anyway...
Comment 23 Matěj Cepl 2008-11-04 19:57:12 EST
(In reply to comment #22)
> Given comment 12 I don't know why you are blaming scim which hasn't really
> changed for f10: xorg-x11 or possibly imsettings sound more plausible suspects,
> but anyway...

I have my reasons to believe that it is not xorg-x11* (with possible exception of XIM) but it might be imsettings -- difference between *im* tools is slightly blurry for me.
Comment 24 Vaclav "sHINOBI" Misek 2008-12-05 01:56:54 EST
Too bad I'm hit by the same error, it appeared two days ago. Probably after gnome update????? The system is Fedora 10 with the last updates+updates-testing.
I'm adding list what was updated since the last known working state (I'm sure it was working 2008-12-03 at 19:32:10).

Dec 03 18:36:42 Updated: libtdb-1.1.1-23.fc10.x86_64
Dec 03 18:36:43 Updated: libtalloc-1.2.0-23.fc10.x86_64
Dec 03 18:36:47 Updated: 1:qt-4.4.3-6.fc10.x86_64
Dec 03 18:37:03 Updated: 1:qt-x11-4.4.3-6.fc10.x86_64
Dec 03 18:37:29 Updated: 1:qt-devel-4.4.3-6.fc10.x86_64
Dec 03 18:37:29 Updated: 1:qt-mysql-4.4.3-6.fc10.x86_64
Dec 03 18:37:29 Updated: 1:xorg-x11-drv-nouveau-0.0.11-1.20081119git65b956f.fc10.x86_64
Dec 03 18:37:59 Updated: virt-manager-0.6.0-4.fc10.x86_64
Dec 03 18:38:01 Updated: xorg-x11-drv-ati-6.9.0-59.fc10.x86_64
Dec 03 18:38:02 Updated: docbook-utils-0.6.14-15.fc10.noarch
Dec 03 18:38:04 Installed: spin-kickstarts-0.10.3-1.fc10.noarch
Dec 03 18:38:04 Updated: docbook-utils-pdf-0.6.14-15.fc10.noarch
Dec 03 18:38:14 Updated: OmegaT-1.7.3_04-2.fc10.noarch
Dec 03 18:38:27 Updated: wine-core-1.1.9-2.fc10.i386
Dec 03 18:38:28 Updated: wine-cms-1.1.9-2.fc10.i386
Dec 03 18:38:29 Updated: wine-capi-1.1.9-2.fc10.i386
Dec 03 18:38:29 Updated: wine-ldap-1.1.9-2.fc10.i386
Dec 03 18:38:30 Updated: wine-twain-1.1.9-2.fc10.i386
Dec 03 18:38:31 Updated: wine-nas-1.1.9-2.fc10.i386
Dec 03 18:38:32 Updated: wine-tools-1.1.9-2.fc10.i386
Dec 03 18:38:33 Updated: wine-jack-1.1.9-2.fc10.i386
Dec 03 18:38:34 Updated: wine-esd-1.1.9-2.fc10.i386
Dec 03 18:38:35 Updated: wine-desktop-1.1.9-2.fc10.i386
Dec 03 18:38:35 Updated: wine-1.1.9-2.fc10.i386
Dec 03 18:38:38 Updated: samba-winbind-3.2.5-0.23.fc10.x86_64
Dec 03 18:38:43 Updated: samba-common-3.2.5-0.23.fc10.x86_64
Dec 03 18:38:45 Updated: revisor-cli-2.1.3-1.fc10.noarch
Dec 03 18:38:47 Updated: revisor-gui-2.1.3-1.fc10.noarch
Dec 03 18:38:47 Updated: revisor-2.1.3-1.fc10.noarch
Dec 03 18:38:49 Updated: libsmbclient-3.2.5-0.23.fc10.x86_64
Dec 03 18:38:54 Updated: revisor-comps-2.1.3-1.fc10.noarch
Dec 03 18:38:57 Updated: samba-3.2.5-0.23.fc10.x86_64
Dec 03 23:33:10 Updated: gtk2-2.14.5-2.fc10.x86_64
Dec 03 23:33:11 Updated: 2:gimp-libs-2.6.3-2.fc10.x86_64
Dec 03 23:33:41 Updated: libgnome-2.24.1-8.fc10.x86_64
Dec 03 23:33:45 Updated: shared-mime-info-0.51-5.fc10.x86_64
Dec 03 23:33:47 Updated: check-0.9.5-3.fc10.x86_64
Dec 03 23:33:49 Updated: 1:xmms-libs-1.2.11-3.20071117cvs.fc10.x86_64
Dec 03 23:34:30 Updated: 2:gimp-2.6.3-2.fc10.x86_64
Dec 03 23:34:33 Updated: sectool-0.9.2-2.x86_64
Dec 03 23:34:34 Updated: loudmouth-1.4.3-1.fc10.x86_64
Dec 03 23:34:37 Updated: system-config-printer-libs-1.0.12-1.fc10.x86_64
Dec 03 23:34:39 Updated: libdiscid-0.2.2-1.fc10.x86_64
Dec 03 23:34:42 Updated: gtk2-2.14.5-2.fc10.i386
Dec 03 23:35:01 Updated: libgnome-2.24.1-8.fc10.i386
Dec 03 23:35:02 Updated: 2:gimp-help-browser-2.6.3-2.fc10.x86_64
Dec 03 23:35:05 Updated: 1:xmms-1.2.11-3.20071117cvs.fc10.x86_64
Dec 03 23:35:12 Updated: 1:grip-3.2.0-25.fc10.x86_64
Dec 03 23:35:32 Updated: gtk2-devel-2.14.5-2.fc10.x86_64
Dec 03 23:35:44 Updated: freeciv-2.1.7-1.fc10.x86_64
Dec 03 23:35:46 Updated: dcraw-8.89-1.fc10.x86_64
Dec 03 23:35:46 Updated: 2:vim-minimal-7.2.060-1.fc10.x86_64
Dec 03 23:35:48 Updated: openvpn-2.1-0.29.rc15.fc10.x86_64
Dec 03 23:35:55 Updated: 1:nfs-utils-1.1.4-2.fc10.x86_64
Dec 03 23:36:01 Updated: netbeans-ide9-6.1-10.fc10.noarch
Dec 03 23:36:05 Updated: yum-3.2.20-4.fc10.noarch
Dec 03 23:36:08 Updated: netbeans-java2-6.1-10.fc10.noarch
Dec 03 23:36:09 Updated: netbeans-apisupport1-6.1-10.fc10.noarch
Dec 03 23:36:10 Updated: kernel-firmware-2.6.27.7-130.fc10.noarch
Dec 03 23:36:11 Updated: gnome-doc-utils-stylesheets-0.14.0-2.fc10.noarch
Dec 03 23:36:16 Updated: system-config-network-tui-1.5.94-2.fc10.noarch
Dec 03 23:36:18 Updated: system-config-network-1.5.94-2.fc10.noarch
Dec 03 23:36:20 Updated: gnome-doc-utils-0.14.0-2.fc10.noarch
Dec 03 23:36:21 Updated: netbeans-6.1-10.fc10.noarch
Dec 03 23:36:24 Updated: system-config-printer-1.0.12-1.fc10.x86_64
Dec 03 23:36:25 Updated: sectool-gui-0.9.2-2.x86_64
Dec 03 23:36:26 Updated: check-devel-0.9.5-3.fc10.x86_64
Dec 03 23:36:27 Updated: libgnome-devel-2.24.1-8.fc10.x86_64
Dec 03 23:36:27 Updated: cdlabelgen-4.1.0-1.fc10.noarch
Dec 03 23:36:28 Updated: etherboot-roms-kvm-5.4.4-5.fc10.x86_64
Dec 03 23:36:37 Updated: kernel-headers-2.6.27.7-130.fc10.x86_64
Dec 03 23:36:38 Updated: crontabs-1.10-25.fc10.noarch
Dec 03 23:39:15 Installed: kernel-devel-2.6.27.7-130.fc10.x86_64
Dec 03 23:40:07 Installed: kernel-2.6.27.7-130.fc10.x86_64
Dec 03 23:40:07 Updated: kmod-nvidia-177.82-1.fc10.5.x86_64
Dec 03 23:40:08 Installed: kmod-nvidia-2.6.27.7-130.fc10.x86_64-177.82-1.fc10.5.x86_64
Dec 03 23:40:10 Updated: PackageKit-yum-plugin-0.3.11-3.fc10.x86_64
Dec 03 23:40:11 Updated: PackageKit-glib-0.3.11-3.fc10.x86_64
Dec 03 23:40:11 Updated: PackageKit-udev-helper-0.3.11-3.fc10.x86_64
Dec 03 23:40:16 Updated: PackageKit-0.3.11-3.fc10.x86_64
Dec 03 23:40:47 Updated: gnome-packagekit-0.3.11-3.fc10.x86_64
Dec 03 23:40:47 Updated: PackageKit-yum-0.3.11-3.fc10.x86_64
Dec 03 23:41:10 Erased: kmod-nvidia-2.6.27.5-113.fc10.x86_64
Dec 03 23:42:12 Installed: kernel-2.6.27.7-130.fc10.x86_64
Comment 25 Jens Petersen 2008-12-05 02:28:11 EST
Is anyone here using scim? - I don't think this is a scim but happen to be proven otherwise...

Peter, do you have any light on this?
Comment 26 Vaclav "sHINOBI" Misek 2008-12-05 02:35:07 EST
No, and there are no scim packages installed on my machine.
Comment 27 Alexandre Oliva 2008-12-06 11:21:48 EST
Downgrading gtk2 and gtk2-devel to 2.14.4-3.fc10 restored dead keys to me.  I'm going to clone this bug for gtk2.
Comment 28 Matěj Cepl 2008-12-06 12:01:30 EST
This doesn't make sense to clone this bug -- if you blame Gtk, then let's go there, but don't make us unnecessary bugs.

Closing this as duplicate of bug 475008.

*** This bug has been marked as a duplicate of bug 475008 ***
Comment 29 Alexandre Oliva 2008-12-06 16:35:47 EST
It doesn't make sense to assume that a bug filed two months ago is in any way related with the new bug that appeared 72 hours ago, that happens to display similar symptoms under completely different circumstances.  That's why I created a separate bug, rather than reassign or close this one.

I know very little about the original bug reported here; all I know is that it can't be the same bug as the one I and Vaclav ran into.  So I'm reopening this, unless you, as the original reporter of this bug, can verify that it somehow is the same bug, or that it is fixed.
Comment 30 Peter Hutterer 2008-12-07 20:07:31 EST
I don't know what the issue is, but Comment #17 indicates that it's neither driver nor server (mind you, dead keys are processed in the client anyway). So one of you who sees the bug needs to be able to narrow down what causes the issue.

If you experience the bug create a new user and test this user to ensure there's no stale settings that may trigger it.
Comment 31 Jens Petersen 2008-12-11 19:14:42 EST
Matej, you still see this post F10 GA?
Comment 32 Jens Petersen 2008-12-11 19:17:13 EST
Given comment 21 and the new gtk2 bug 475008, I reckon this can be closed now, no?
Comment 33 Matěj Cepl 2008-12-15 09:30:30 EST
(In reply to comment #31)
> Matej, you still see this post F10 GA?

No, I don't.

Note You need to log in before you can comment on or make changes to this bug.