Bug 475008 - Dead keys are broken in gtk2 apps with gtk2-2.14.5-2.fc10
Dead keys are broken in gtk2 apps with gtk2-2.14.5-2.fc10
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
: 476225 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-06 11:31 EST by Alexandre Oliva
Modified: 2008-12-17 19:38 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-17 19:38:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2008-12-06 11:31:34 EST
+++ This bug was initially created as a clone of Bug #467016 +++

Description of problem:
gtk2-2.14.5-2.fc10, now in testing, breaks entry of characters with dead key combinations in gnome apps.  It works just fine with 2.14.4-3.fc10, as in F-10 GOLD.  Instead of the expected characters, you get nothing.  It still works on non-gtk2 apps such as GNU Emacs, xterm, and konsole, in the same gnome session.  I verified that it's specific to gtk2 by booting up rawhide (where the problem does not occur), sshing into the updated F-10 box, starting gedit there, duplicating the problem, downgrading to the GOLD gtk2, starting gedit again, and then having it all work again. 

Here's some information snipped from the original bug report:

Having cs_CZ locale, I need dead-key working, because some of the letters in the Czech keyboard layout are not on the keyboard directly (e.g., ňóť). Unfortunately when entering these keys in the current Fedora Rawhide I get ˇn´oˇt instead.

--- Additional comment from misek@tnet.cz on 2008-12-05 01:56:54 EDT ---

Too bad I'm hit by the same error, it appeared two days ago. Probably after gnome update????? The system is Fedora 10 with the last updates+updates-testing.
I'm adding list what was updated since the last known working state (I'm sure it was working 2008-12-03 at 19:32:10).

Dec 03 18:36:42 Updated: libtdb-1.1.1-23.fc10.x86_64
Dec 03 18:36:43 Updated: libtalloc-1.2.0-23.fc10.x86_64
Dec 03 18:36:47 Updated: 1:qt-4.4.3-6.fc10.x86_64
Dec 03 18:37:03 Updated: 1:qt-x11-4.4.3-6.fc10.x86_64
Dec 03 18:37:29 Updated: 1:qt-devel-4.4.3-6.fc10.x86_64
Dec 03 18:37:29 Updated: 1:qt-mysql-4.4.3-6.fc10.x86_64
Dec 03 18:37:29 Updated: 1:xorg-x11-drv-nouveau-0.0.11-1.20081119git65b956f.fc10.x86_64
Dec 03 18:37:59 Updated: virt-manager-0.6.0-4.fc10.x86_64
Dec 03 18:38:01 Updated: xorg-x11-drv-ati-6.9.0-59.fc10.x86_64
Dec 03 18:38:02 Updated: docbook-utils-0.6.14-15.fc10.noarch
Dec 03 18:38:04 Installed: spin-kickstarts-0.10.3-1.fc10.noarch
Dec 03 18:38:04 Updated: docbook-utils-pdf-0.6.14-15.fc10.noarch
Dec 03 18:38:14 Updated: OmegaT-1.7.3_04-2.fc10.noarch
Dec 03 18:38:27 Updated: wine-core-1.1.9-2.fc10.i386
Dec 03 18:38:28 Updated: wine-cms-1.1.9-2.fc10.i386
Dec 03 18:38:29 Updated: wine-capi-1.1.9-2.fc10.i386
Dec 03 18:38:29 Updated: wine-ldap-1.1.9-2.fc10.i386
Dec 03 18:38:30 Updated: wine-twain-1.1.9-2.fc10.i386
Dec 03 18:38:31 Updated: wine-nas-1.1.9-2.fc10.i386
Dec 03 18:38:32 Updated: wine-tools-1.1.9-2.fc10.i386
Dec 03 18:38:33 Updated: wine-jack-1.1.9-2.fc10.i386
Dec 03 18:38:34 Updated: wine-esd-1.1.9-2.fc10.i386
Dec 03 18:38:35 Updated: wine-desktop-1.1.9-2.fc10.i386
Dec 03 18:38:35 Updated: wine-1.1.9-2.fc10.i386
Dec 03 18:38:38 Updated: samba-winbind-3.2.5-0.23.fc10.x86_64
Dec 03 18:38:43 Updated: samba-common-3.2.5-0.23.fc10.x86_64
Dec 03 18:38:45 Updated: revisor-cli-2.1.3-1.fc10.noarch
Dec 03 18:38:47 Updated: revisor-gui-2.1.3-1.fc10.noarch
Dec 03 18:38:47 Updated: revisor-2.1.3-1.fc10.noarch
Dec 03 18:38:49 Updated: libsmbclient-3.2.5-0.23.fc10.x86_64
Dec 03 18:38:54 Updated: revisor-comps-2.1.3-1.fc10.noarch
Dec 03 18:38:57 Updated: samba-3.2.5-0.23.fc10.x86_64
Dec 03 23:33:10 Updated: gtk2-2.14.5-2.fc10.x86_64
Dec 03 23:33:11 Updated: 2:gimp-libs-2.6.3-2.fc10.x86_64
Dec 03 23:33:41 Updated: libgnome-2.24.1-8.fc10.x86_64
Dec 03 23:33:45 Updated: shared-mime-info-0.51-5.fc10.x86_64
Dec 03 23:33:47 Updated: check-0.9.5-3.fc10.x86_64
Dec 03 23:33:49 Updated: 1:xmms-libs-1.2.11-3.20071117cvs.fc10.x86_64
Dec 03 23:34:30 Updated: 2:gimp-2.6.3-2.fc10.x86_64
Dec 03 23:34:33 Updated: sectool-0.9.2-2.x86_64
Dec 03 23:34:34 Updated: loudmouth-1.4.3-1.fc10.x86_64
Dec 03 23:34:37 Updated: system-config-printer-libs-1.0.12-1.fc10.x86_64
Dec 03 23:34:39 Updated: libdiscid-0.2.2-1.fc10.x86_64
Dec 03 23:34:42 Updated: gtk2-2.14.5-2.fc10.i386
Dec 03 23:35:01 Updated: libgnome-2.24.1-8.fc10.i386
Dec 03 23:35:02 Updated: 2:gimp-help-browser-2.6.3-2.fc10.x86_64
Dec 03 23:35:05 Updated: 1:xmms-1.2.11-3.20071117cvs.fc10.x86_64
Dec 03 23:35:12 Updated: 1:grip-3.2.0-25.fc10.x86_64
Dec 03 23:35:32 Updated: gtk2-devel-2.14.5-2.fc10.x86_64
Dec 03 23:35:44 Updated: freeciv-2.1.7-1.fc10.x86_64
Dec 03 23:35:46 Updated: dcraw-8.89-1.fc10.x86_64
Dec 03 23:35:46 Updated: 2:vim-minimal-7.2.060-1.fc10.x86_64
Dec 03 23:35:48 Updated: openvpn-2.1-0.29.rc15.fc10.x86_64
Dec 03 23:35:55 Updated: 1:nfs-utils-1.1.4-2.fc10.x86_64
Dec 03 23:36:01 Updated: netbeans-ide9-6.1-10.fc10.noarch
Dec 03 23:36:05 Updated: yum-3.2.20-4.fc10.noarch
Dec 03 23:36:08 Updated: netbeans-java2-6.1-10.fc10.noarch
Dec 03 23:36:09 Updated: netbeans-apisupport1-6.1-10.fc10.noarch
Dec 03 23:36:10 Updated: kernel-firmware-2.6.27.7-130.fc10.noarch
Dec 03 23:36:11 Updated: gnome-doc-utils-stylesheets-0.14.0-2.fc10.noarch
Dec 03 23:36:16 Updated: system-config-network-tui-1.5.94-2.fc10.noarch
Dec 03 23:36:18 Updated: system-config-network-1.5.94-2.fc10.noarch
Dec 03 23:36:20 Updated: gnome-doc-utils-0.14.0-2.fc10.noarch
Dec 03 23:36:21 Updated: netbeans-6.1-10.fc10.noarch
Dec 03 23:36:24 Updated: system-config-printer-1.0.12-1.fc10.x86_64
Dec 03 23:36:25 Updated: sectool-gui-0.9.2-2.x86_64
Dec 03 23:36:26 Updated: check-devel-0.9.5-3.fc10.x86_64
Dec 03 23:36:27 Updated: libgnome-devel-2.24.1-8.fc10.x86_64
Dec 03 23:36:27 Updated: cdlabelgen-4.1.0-1.fc10.noarch
Dec 03 23:36:28 Updated: etherboot-roms-kvm-5.4.4-5.fc10.x86_64
Dec 03 23:36:37 Updated: kernel-headers-2.6.27.7-130.fc10.x86_64
Dec 03 23:36:38 Updated: crontabs-1.10-25.fc10.noarch
Dec 03 23:39:15 Installed: kernel-devel-2.6.27.7-130.fc10.x86_64
Dec 03 23:40:07 Installed: kernel-2.6.27.7-130.fc10.x86_64
Dec 03 23:40:07 Updated: kmod-nvidia-177.82-1.fc10.5.x86_64
Dec 03 23:40:08 Installed: kmod-nvidia-2.6.27.7-130.fc10.x86_64-177.82-1.fc10.5.x86_64
Dec 03 23:40:10 Updated: PackageKit-yum-plugin-0.3.11-3.fc10.x86_64
Dec 03 23:40:11 Updated: PackageKit-glib-0.3.11-3.fc10.x86_64
Dec 03 23:40:11 Updated: PackageKit-udev-helper-0.3.11-3.fc10.x86_64
Dec 03 23:40:16 Updated: PackageKit-0.3.11-3.fc10.x86_64
Dec 03 23:40:47 Updated: gnome-packagekit-0.3.11-3.fc10.x86_64
Dec 03 23:40:47 Updated: PackageKit-yum-0.3.11-3.fc10.x86_64
Dec 03 23:41:10 Erased: kmod-nvidia-2.6.27.5-113.fc10.x86_64
Dec 03 23:42:12 Installed: kernel-2.6.27.7-130.fc10.x86_64

--- Additional comment from petersen@redhat.com on 2008-12-05 02:28:11 EDT ---

Is anyone here using scim? - I don't think this is a scim but happen to be proven otherwise...

Peter, do you have any light on this?

--- Additional comment from misek@tnet.cz on 2008-12-05 02:35:07 EDT ---

No, and there are no scim packages installed on my machine.

--- Additional comment from oliva@lsd.ic.unicamp.br on 2008-12-06 11:21:48 EDT ---

Downgrading gtk2 and gtk2-devel to 2.14.4-3.fc10 restored dead keys to me.  I'm going to clone this bug for gtk2.
Comment 1 Matěj Cepl 2008-12-06 12:01:30 EST
*** Bug 467016 has been marked as a duplicate of this bug. ***
Comment 2 Pedro Matiello 2008-12-09 23:43:35 EST
Same issue here. Downgrading to 2.14.4-3 fixed it.

Using Brazilian keyboard.
Comment 3 Matthias Clasen 2008-12-09 23:52:52 EST
I need to know more details to do anything here. 

What exact keyboard layout are you using ? (setxkbmap -print output would be good)
What key combination does not work as expected ?
Comment 4 Vaclav "sHINOBI" Misek 2008-12-10 02:14:51 EST
$ setxkbmap -print
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+us+cz(qwerty):2+inet(evdev)+level3(ralt_switch_for_alts_toggle):1+group(alts_toggle)+group(alt_shift_toggle)"	};
	xkb_geometry  { include "pc(pc104)"	};
};

And it seem that no death key combination works (for all caron and acute characters).

For example:

for á I press "=" and "a" and the computer just beeps

the same for capital R with caron Ř I press "shift" + "=" key and "R"

The behaviour is exactly the same as in #467016
Comment 5 Pedro Matiello 2008-12-10 06:40:22 EST
setxkbmap -print
xkb_keymap {
	xkb_keycodes  { include "evdev(abnt2)+aliases(qwerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+br+inet(evdev)"	};
	xkb_geometry  { include "pc(abnt2)"	};
};

I couldn't do any of á é í ó ú â ê î ô û à è ì ò ù ã ẽ ĩ õ ũ ä ë ï ö ü (and their uppercase version) by typing the signal (' ^ ` ~ ") followed by the letter.
Comment 6 Eric Donkersloot 2008-12-11 04:01:09 EST
[ericd@vaiopro Desktop]$ setxkbmap -print
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+us(intl)+inet(evdev)+group(shift_caps_toggle)"	};
	xkb_geometry  { include "pc(pc102)"	};
};

I can confirm downgrading to gtk2-2.14.4-3.fc10.i386 fixes the issue.
Comment 7 Jóhann B. Guðmundsson 2008-12-12 12:09:32 EST
*** Bug 476225 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2008-12-12 18:24:31 EST
gtk2-2.14.5-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gtk2-2.14.5-3.fc10
Comment 9 Vaclav "sHINOBI" Misek 2008-12-13 04:52:37 EST
Great, that make the trick and everything works correctly for me after this update. Is it working for all so we should close it?
Comment 10 Matthias Clasen 2008-12-13 14:01:37 EST
Bodhi will close the bug automatically when the update is moved from updates-testing to updates. You can speed that up by giving a +1 in the bodhi request.

Go to 
https://admin.fedoraproject.org/updates/gtk2-2.14.5-3.fc10
and add a "works for me" comment.
Comment 11 Fedora Update System 2008-12-17 19:38:16 EST
gtk2-2.14.5-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.