Bug 467029 - please update the package version to 3.0.7
please update the package version to 3.0.7
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jna (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
Fedora Extras Quality Assurance
: FutureFeature, Reopened
Depends On:
Blocks: gstreamer-java 473451
  Show dependency treegraph
 
Reported: 2008-10-15 06:41 EDT by Levente Farkas
Modified: 2009-03-20 20:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-20 20:28:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2008-10-15 06:41:51 EDT
please update the package version to 3.0.7 since the current svn at least 3.0.7 (not 3.0.4).
thanks.
Comment 1 Levente Farkas 2008-10-15 06:42:13 EDT
and at the same time please build on epel too.
Comment 2 Levente Farkas 2008-10-23 11:35:58 EDT
no i check it again and it seems that f-9, f-10, f-11 (aka devel) and epel alse has older jna. unfortunately i need newer jna version in order to be able to push gstreamer-java into fedora and epel.
thanks.
Comment 3 Colin Walters 2008-10-23 12:56:25 EDT
The current version is actually an SVN snapshot.
Comment 4 Levente Farkas 2008-10-23 13:00:34 EDT
ok but that's svn is newer then 3.0.7!
anyway the version is just less important, the more important that this version get into the f-9 updates, f-10 and epel asap. since otherwise i can't submit gstreamer-java because it's not build on older version.
thanks.
Comment 5 Levente Farkas 2008-10-28 07:14:47 EDT
any change to a f-9 and epel jna push?
i know f-10 is less then a month now, but i still like to push f-9 and epel gstreamer-java packages...
Comment 6 Mamoru TASAKA 2008-10-30 12:36:57 EDT
Would you request the request on bodhi to push F-9 newest package to repository,
Colin?
Comment 7 Colin Walters 2008-10-30 13:05:17 EDT
Just for reference I'm fine if anyone makes modifications or updates for any of my packages, as long as you know what you're doing.

But I did just create a Bodhi update for f9:

https://admin.fedoraproject.org/updates/jna-3.0.4-9.svn729.fc9

As for EPEL, I don't have time right now to set up plague etc.  If someone else wants to do it please feel free.
Comment 8 Levente Farkas 2008-10-31 11:20:42 EDT
i don't really understand you since jna already has the EL-5 cvs branch you only need to do:
------------------------------
fedora-cvs jna
cd jna
./common/cvs-import.sh -b EL-5 jna-3.0.4-9.svn729.fc9.src.rpm 
cd EL-5
cvs up
make tag
make build
------------------------------
and it's do all the plague build.
but if you cam give me write access to the EL-5 branch i'm also willing to maintain it.
Comment 9 Levente Farkas 2008-11-10 12:49:54 EST
i've been build it and now in the needsign queue:
http://buildsys.fedoraproject.org/build-status/job.psp?email=lfarkas@lfarkas.org&uid=715
anyway the latest devel and F-10 brach the spec file contains a patch jna-callback-exception.patch which is not in the cvs.
could you commit it.
Comment 10 Colin Walters 2008-11-10 13:02:28 EST
Done; that was an in-progress patch, not yet intended for application.
Comment 11 Conrad Meyer 2008-11-29 02:27:25 EST
Jruby 1.1.5 (and soon, 1.1.6) need jna 3.0.9. So I'd request this be made available for at least rawhide and I'd like F-10 and F-9 as well. (I noticed the CVS jna/devel/jna.spec is version 3.0.9 so maybe this will be a really quick fix.)
Comment 12 Levente Farkas 2009-02-02 15:13:14 EST
from my part this bug can be closed. or 3.0.9 can be submitted to epel.
thanks.
Comment 13 Conrad Meyer 2009-03-20 20:28:49 EDT
This works for me also; closing.

Note You need to log in before you can comment on or make changes to this bug.