Bug 473451 - Update jruby to latest upstream ver 1.1.5
Update jruby to latest upstream ver 1.1.5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jruby (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Conrad Meyer
Fedora Extras Quality Assurance
:
Depends On: 467029 473530 473537
Blocks: 480653
  Show dependency treegraph
 
Reported: 2008-11-28 10:55 EST by Christian Nolte
Modified: 2009-04-30 19:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-30 19:34:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Nolte 2008-11-28 10:55:34 EST
On Nov. 3rd ver. 1.1.5 of jruby has been released. Please update the package to this version.
Comment 1 Conrad Meyer 2008-11-28 23:42:27 EST
It seems each release of jruby introduces new dependencies (sort of, half of them are just things that used to be part of jruby and have since split off as "independent" projects). This particular release at least one new dependency has been introduced, which is not yet in Fedora. So I'm depending this bug on the review request for that one.
Comment 2 Conrad Meyer 2008-11-29 02:14:20 EST
Another new dep: jcodings.
Comment 3 Conrad Meyer 2009-02-15 20:43:53 EST
Fedora 1.1.6 and dependencies are now in Rawhide. Want to test this and close it?
Comment 4 Fedora Update System 2009-03-09 19:09:02 EDT
jruby-1.1.6-1.fc10, joni-1.1.2-1.fc10, bytelist-1.0.1-0.1.svn9177.fc10, jcodings-1.0.1-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Christian Nolte 2009-03-16 08:49:55 EDT
Thanks for upgrading jruby! Any chance you can push this to F9 too? We would need joni-1.1.2 though, too.
Comment 6 Conrad Meyer 2009-03-16 10:37:29 EDT
My rationale for *not* pushing jruby-1.1.5+ to F-9 is that I'm fairly sure there are dependencies of jruby-1.1.5+ that F-9 doesn't have (and that are out of my control). (Dependencies jruby-1.1.3, the version in F-9, doesn't require.)
Comment 7 Conrad Meyer 2009-03-20 20:05:03 EDT
I think the original issue this bug report addressed has been resolved, is it ok with you if we close this? Thanks.
Comment 8 Conrad Meyer 2009-04-30 19:34:36 EDT
Closing, please reopen if you have more (related) concerns.

Note You need to log in before you can comment on or make changes to this bug.