Bug 467038 - libvirt needs a way to pass -std-vga to qemu
libvirt needs a way to pass -std-vga to qemu
Status: CLOSED NEXTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
: 431731 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-15 08:05 EDT by Tom Hughes
Modified: 2010-03-16 13:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-30 07:33:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add -std-vga when starting qemu (498 bytes, patch)
2008-10-21 06:40 EDT, Tom Hughes
no flags Details | Diff
Patch to allow a VGA card model to be specified (2.97 KB, patch)
2009-07-03 12:22 EDT, Tom Hughes
no flags Details | Diff
Patch for current libvirt CVS head (2.91 KB, patch)
2009-07-03 12:23 EDT, Tom Hughes
no flags Details | Diff

  None (edit)
Description Tom Hughes 2008-10-15 08:05:54 EDT
The -std-vga switch to qemu causes it to emulate a different graphics adaptor which supports larger screen modes. It would be nice if libvirt was able to pass this flag to qemu so that KVM based virtual machines could use large screen modes.
Comment 1 Tom Hughes 2008-10-21 06:40:09 EDT
Created attachment 321000 [details]
Patch to add -std-vga when starting qemu

This is a simple patch which unconditionally adds -std-vga to the command line, but I guess it should probably be optional really.

Given that it is specific to qemu based VMs I wasn't really sure whether the option should be in the features section or on the graphics adapter though?
Comment 2 Cole Robinson 2008-12-01 15:52:47 EST
*** Bug 431731 has been marked as a duplicate of this bug. ***
Comment 3 Tom Hughes 2009-07-03 12:22:08 EDT
Created attachment 350443 [details]
Patch to allow a VGA card model to be specified

Recent versions of qemu have replaced -std-vga with -vga which allows one of several models to be selected. This actually makes adding support to libvirt a bit easier in as much as it's more obvious where to add it in the XML syntax.

This patch (against the current 0.6.2 F11 package) adds a model attribute to the graphics card definition in the XML and passes it to the qemu -vga switch.
Comment 4 Tom Hughes 2009-07-03 12:23:53 EDT
Created attachment 350444 [details]
Patch for current libvirt CVS head

This is the same patch reworked for the current CVS head if that's more convenient...
Comment 5 Cole Robinson 2009-07-05 15:04:04 EDT
Just adding a 'model' attribute to the <graphics> tag has been rejected in the past. Dan Berrange posted an RFC patch back in May to add a <video> device which allows specifying a model:

http://www.mail-archive.com/libvir-list@redhat.com/msg13520.html

No movement since then though. Tom, if you wanted to fill out the qemu/kvm portion of the RFC and send to libvir-list, it would probably get the ball rolling again.
Comment 6 Daniel Berrange 2009-07-30 07:33:05 EDT
This is merged upstream and in forthcoming 0.7.0 release

http://libvirt.org/git/?p=libvirt.git;a=commit;h=ad6d5acb4228f0615bc3375817c85d0531f172e2

Note You need to log in before you can comment on or make changes to this bug.