Bug 467158 - Anaconda on Fedora 10 Beta Net install crashes (RuntimeError: could not open display)
Anaconda on Fedora 10 Beta Net install crashes (RuntimeError: could not open ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-16 00:38 EDT by Chris
Modified: 2008-10-24 11:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 11:55:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris 2008-10-16 00:38:06 EDT
Description of problem:
The Fedora 10 Beta installer crashes when trying to start an X server.

Version-Release number of selected component (if applicable):
"Running anaconda 11.4.1.40" i386 net install iso

How reproducible:
Everytime

Steps to Reproduce:
1. Select Install or Upgrade... at boot
2. Skip the media check (not skipping doesn't help but does add more steps)
3. Wait for it.
4. You're greeted with "you may safely reboot your system" (and other stuff)
  
Actual results:
Install gives up very early

Expected results:
Installer should let me install the OS and at least fall back to textmode.

Additional info:
Dell Inspiron 700m
>>
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 832, in <module>
    doStartupX11Actions(opts.runres)
  File "/usr/bin/anaconda", line 72, in doStartupX11Actions
    import gtk
  File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 79, in <
module>
    _init()
  File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 67, in _
init
    _gtk.init_check()
RuntimeError could not open display
install exited abnormally [1/1]
<<
then stuff about NetworkManager deactivating the network interface
kill signals
unmounting
reboot message.

On terminal F2 there's just he unusable shell prompt at this point
On term F4 at the end
>>
<6>[drm] Initialized i915 1.6.0 20080730 on minor 1
<3>[drm:i915_gem_object_bind_to_gtt] *ERROR* GTT full, but LRU list empty
<3>[drm:i915_gem_object_pin] *ERROR* Failure to bind: -12<3>[drm:i915_gem_idle]
*ERROR* hardware wedged
_
<<

On terminal F5
Build ID: xorg-x11-server 1.5.0-6.fc10
New driver is "intel"
Using defualt built in config
>>
(EE) open /dev/fb0: No such device
(EE) intel(0): Failed to pin front buffer: Cannot allocate memory

Fatal server error:
Couldn't bind memory for BO front buffer

_
<<
Comment 1 Chris 2008-10-16 02:52:59 EDT
My video is the Intel 855GM Chipset (according to dmesg)
Looks like this might be related: https://bugzilla.redhat.com/show_bug.cgi?id=461205
But still, anaconda shouldn't crash when text mode can still run.
Comment 2 John Poelstra 2008-10-23 18:21:17 EDT
talked this over with wwoods and he believes real bug is that anaconda should fail back to text mode.  changing component to 'anaconda'
Comment 3 Chris Lumens 2008-10-24 11:55:19 EDT
This should be fixed in the next build of anaconda, though the critical bug here is that X isn't starting up.  I believe that's already been filed though.

Note You need to log in before you can comment on or make changes to this bug.