Bug 461205 - X windows black screen Intel 82852/855GM Graphics
X windows black screen Intel 82852/855GM Graphics
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
high Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 467572 470541 470566 (view as bug list)
Depends On:
Blocks: F10KernelBlocker
  Show dependency treegraph
 
Reported: 2008-09-04 17:08 EDT by Jerry Williams
Modified: 2013-01-09 23:47 EST (History)
17 users (show)

See Also:
Fixed In Version: kernel-2.6.27.5-109.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-14 12:49:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Broken Xorg.0.log (24.03 KB, text/plain)
2008-09-04 17:08 EDT, Jerry Williams
no flags Details
Working Xorg.0.log (29.71 KB, text/plain)
2008-09-04 17:09 EDT, Jerry Williams
no flags Details
lspci output (1.82 KB, text/plain)
2008-09-04 17:10 EDT, Jerry Williams
no flags Details
Xorg 2.6.27-0.377.rc8.git1 (21.96 KB, text/plain)
2008-10-03 12:34 EDT, Jerry Williams
no flags Details
Broken X on kernel-2.6.27-0.398.rc9.fc10.i686 (21.17 KB, text/plain)
2008-10-08 15:58 EDT, Michal Nowak
no flags Details
Working X from kernel-2.6.26.5-45.fc9.i586 (22.59 KB, text/plain)
2008-10-08 16:00 EDT, Michal Nowak
no flags Details
lspci (1.76 KB, application/octet-stream)
2008-10-08 16:01 EDT, Michal Nowak
no flags Details
Tarball of lspci, lspci -v, and Xorg.0.log (8.56 KB, application/x-bzip)
2008-11-05 14:17 EST, Walter Francis
no flags Details

  None (edit)
Description Jerry Williams 2008-09-04 17:08:45 EDT
Created attachment 315808 [details]
Broken Xorg.0.log

Description of problem:  Installed system and then ran yum update and accepted all updates and get black screen when X windows starts, keys don't do anything.


Version-Release number of selected component (if applicable):
kernel-2.6.27-0.297.rc5.git2.fc10.i686
xorg-x11-server-Xorg-1.5.0-1.fc10.i386


How reproducible: not sure


Steps to Reproduce:
1. Install F10A
2. yum update, accept updates
3.
  
Actual results: Black X windows screen


Expected results: Should show login screen


Additional info:  Have same code on vbox and now issues.
kernel-2.6.27-0.166.rc0.git8.fc10.i686 works fine.
Comment 1 Jerry Williams 2008-09-04 17:09:38 EDT
Created attachment 315809 [details]
Working Xorg.0.log

Using kernel-2.6.27-0.166.rc0.git8.fc10.i686
Comment 2 Jerry Williams 2008-09-04 17:10:03 EDT
Created attachment 315810 [details]
lspci output
Comment 3 Jerry Williams 2008-09-05 17:49:26 EDT
Tried new kernel 2.6.27-0.305.rc5.git6.fc10.i686 and it doesn't work either.
And on vbox it breaks X Windows to, but at least I can login.
It says Fatal server error: no screens found on vbox with 305 kernel.
Comment 4 Jerry Williams 2008-09-05 23:29:13 EDT
vbox issue was caused by /etc/X11/xorg.conf being changed, put original back and it is fine.
Laptop with Intel Corporation 82852/855GM still broken with today's updates and new kernel-2.6.27-0.305.rc5.git6.fc10.i686

root      2459     1  0 21:15 ?        00:00:00 /usr/sbin/gdm-binary -nodaemon
root      2621  2459  0 21:21 ?        00:00:00 /usr/libexec/gdm-simple-slave --display-id /org/gnome/DisplayManager/Display2
root      2622  2621  0 21:21 ?        00:00:00 /usr/bin/Xorg :1 -br -verbose -auth /var/run/gdm/auth-for-gdm-aIa1MY/database -nolisten tcp

When I kill -9 2622 it just make the display have a bunch of garbage on it.
It never comes back, only option is reboot once it is messed up.
Comment 5 Jerry Williams 2008-09-07 21:33:29 EDT
kernel-2.6.27-0.312.rc5.git7.fc10.i686 doesn't seem to work either.
Comment 6 Jerry Williams 2008-09-08 19:25:48 EDT
kernel-2.6.27-0.314.rc5.git9.fc10.i686 doesn't work either.
Comment 7 Jerry Williams 2008-09-11 12:22:58 EDT
From: /var/log/Xorg.setup.log
I tried to run:
system-config-display

(EE) intel(0): [drm] failure adding irq handler
expected keysym, got XF86Info: line 914 of inet
(EE) intel(0): underrun on pipe B!
expected keysym, got XF86Info: line 914 of inet
expected keysym, got XF86Info: line 914 of inet
[mi] EQ overflowing. The server is probably stuck in an infinite loop.


Looking at change log on kernel-2.6.27-0.297.rc5.git2.fc10

maybe?:
* Thu Aug 28 2008 Dave Airlie <airlied@redhat.com>
- rebase modesetting patches - add DRI2 for intel patches from krh
- no intel modesetting yet didn't have time

* Wed Aug 27 2008 Dave Airlie <airlied@redhat.com>
- drm update - add opregion support - fix some bugs in radeon modesetting
Comment 8 Jerry Williams 2008-09-11 13:36:41 EDT
kernel 2.6.27-0.322.rc6.fc10.i686 not working either.
Comment 9 Jerry Williams 2008-09-18 23:41:24 EDT
kernel-2.6.27-0.329.rc6.git2.fc10.i686 doesn't work either.
I hope this gets fixed before the beta!
Comment 10 Jerry Williams 2008-09-26 00:44:44 EDT
Loaded QA Test F10-Beta-i686-Live.iso on a USB and tried it on the same broken Compaq nx5000 laptop and it still doesn't work.

Tried it on another laptop Compaq nx6400 and it works:
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 43/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

kernel-2.6.27-0.352.rc7.git1.fc10.i686

So it only looks like it causes problems with some Intel display adapters.
Someone else on #fedora-qa was having an issue, but not sure if the older kernel fixed it or not.
Comment 11 Hedayat Vatankhah 2008-09-27 15:43:41 EDT
Yes, I've tried F10-Beta-x86_64-Live-Developer.iso on a system with Intel 965 chipset and X doesn't start at all but text mode works fine. It prints the same errors as above.
I've tried using kernel-2.6.27-0.166.rc0.git8.fc10.x86_64 and I was able to see some signs of plymouth but since I didn't create proper initrd for the live image it wasn't able to mount root partition. But at least I can see some signs of graphical mode in the system and I guess that with correct initrd I should be able to start X.
Comment 12 Frederic Descamps 2008-10-02 04:35:34 EDT
Since yesterday it was working fine on F10 Beta (Intel Mobile 915GM/GMS/910GML Express) but after the last update : xorg-x11-server-Xorg-1.5.1-4.fc10.i386 I have also that black screen :-(
Comment 13 Frederic Descamps 2008-10-02 06:12:55 EDT
some more info, when I start Xorg from the command line :

X.Org X Server 1.5.1
Release Date: 23 September 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-92.1.10.el5 i686
Current Operating System: Linux blablabla 2.6.27-0.352.rc7.git1.fc10.i686 #1 SMP Tue Sep 23 21:26:04 EDT 2008 i686
Build Date: 30 September 2008  05:38:19PM
Build ID: xorg-x11-server 1.5.1-4.fc10
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Oct  2 12:10:58 2008
(EE) Unable to locate/open config file
New driver is "intel"
(==) Using default built-in configuration (30 lines)
(EE) open /dev/fb0: No such device
Xorg: symbol lookup error: /usr/lib/xorg/modules/drivers//intel_drv.so: undefined symbol: intel_bufmgr_gem_init

xorg-x11-drv-i810.i386 0:2.4.2-8.fc10 is installed
Comment 14 Frederic Descamps 2008-10-02 07:59:21 EDT
again some more info from dmesg :

[drm] Initialized drm 1.1.0 20060810
pci 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
pci 0000:00:02.0: setting latency timer to 64
[drm:i915_gem_detect_bit_6_swizzle] *ERROR* Couldn't read from MCHBAR.  Disabling tiling.
[drm] Initialized i915 1.6.0 20080730 on minor 0

I'm running 2.6.27-0.352.rc7.git1.fc10.i686 or 2.6.27-0.372.rc8.fc10.i686 but same problem.
Comment 15 Troy Dawson 2008-10-02 11:15:17 EDT
I hate to be a "me too" person, but me too.  I get the same errors as #13 using the kernel ...-0.372. and 0.352.
I have also tried using the xorg.conf file from a RHEL5 partition on the same machine with no success.  That wanted to use the i810 driver, which didn't work because it wasn't for this chipset.  When I switched it to the intel driver, I got the same errors as before.
Any ideas?  Or anything you want tested and sent to help?
Comment 16 Frederic Descamps 2008-10-03 05:02:07 EDT
After the update of this morning, everything is working back :-)

new kernel is : 2.6.27-0.377.rc8.git1.fc10.i686

Good job !
Comment 17 Jerry Williams 2008-10-03 12:34:30 EDT
Created attachment 319391 [details]
Xorg 2.6.27-0.377.rc8.git1

More information
Gets to:
SynPS/2 Synaptics TouchPad touchpad found
Comment 18 Jerry Williams 2008-10-03 12:35:54 EDT
2.6.27-0.377.rc8.git1.fc10.i686 doesn't work for me. :(
Comment 19 Troy Dawson 2008-10-03 13:00:01 EDT
I tried updating the kernel, I was only able to get 2.6.27-0.382.rc2.git4.fc10.i686
This kernel begins to start X, and get's to where you see the hash screen right before you get graphics and then it completely locks up.  I tried it twice, with the same result, letting it sit for 30 minutes the second time.  I'm not sure what the error was.

I did find a work around so that I can use my machine though.
I got the xorg.conf file from the RHEL5 it's dual booted with.  I copied it over to /etc/X11/xorg.conf on my fedora.  I then edit it and change the driver from "i810" to "vesa" and now it is working.

But it would be nice if it worked with the real intel driver, or whichever driver it is supposed to have.
Comment 20 Michal Nowak 2008-10-05 16:13:52 EDT
The problem persists for me with kernel-2.6.27-0.391.rc8.git7.fc10.i686, I am using kernel-2.6.26.5-45.fc9.i586 as a workaround (it has it's limitations, I know).
Comment 21 Michal Nowak 2008-10-06 17:18:39 EDT
kernel-2.6.27-0.392.rc8.git7.fc10.i686 is affected too.

The worst on this is that Fedora 10 Beta is not able to be installed, due to this kernel-side problem.
Comment 22 Troy Dawson 2008-10-07 10:08:45 EDT
Sure it Fedora 10 Beta can be installed.  Just do it in text mode.
Put "text" at the end of the installer line.
But then you have to watch out for firstboot failling in text mode, which causes the whole thing to look like it's completely hung, when in reality, firstboot just died and there are no consoles to log into.  But that's a different bug.
Comment 23 Jerry Williams 2008-10-07 23:03:24 EDT
Well kernel 2.6.27-0.398.rc9.fc10.i686 works for me! :)
Comment 24 Michal Nowak 2008-10-08 15:58:50 EDT
Created attachment 319790 [details]
Broken X on kernel-2.6.27-0.398.rc9.fc10.i686

Still not working for me.
Comment 25 Michal Nowak 2008-10-08 16:00:50 EDT
Created attachment 319791 [details]
Working X from kernel-2.6.26.5-45.fc9.i586

It's only from 2.6.26, but might be useful though.
Comment 26 Michal Nowak 2008-10-08 16:01:49 EDT
Created attachment 319792 [details]
lspci
Comment 27 Hedayat Vatankhah 2008-10-11 03:26:40 EDT
Sorry, I've tried Fedora 10 Beta Desktop edition (32 bit), and it works fine on my system. I don't know what was the problem with my previous test, maybe that's a problem on x86_64 systems, or with the Developer live edition, or with my download. Hopefully I'll try the Desktop edition x86_64 soon.
Comment 28 Hedayat Vatankhah 2008-10-14 13:40:07 EDT
Fedora 10 Snapshot (x86_64) works fine.
Comment 29 Michal Nowak 2008-10-18 16:12:53 EDT
kernel-2.6.27.2-23.rc1.fc10.i686 still failing for me.
Comment 30 Christopher D. Stover 2008-10-22 15:15:04 EDT
Is your problem fixed with the most recent kernel-2.6.27.3-34.rc1.fc10 now Michal?  You're using the same 855GM chip set as the rest of them so I'd think yours should be working now as well.
Comment 31 Michal Nowak 2008-10-23 15:11:17 EDT
Christopher, thanks for asking, no, it's not.

In today's rawhide I found the new kernel + Intel's Xorg driver v2.5.0, the one released recently, with this combination it's a bit worse. Now the screen is not only still dark, line on pre -34 kernel, but when I press power button, it seems that the machine's shutting down, but then it stops and the Caps Lock light is blicking like on kernel panic. Warm power off is necessary.

Oct 23 20:27:10 assam kernel: [drm:i915_driver_load] *ERROR* failed to enable MSI
Oct 23 20:27:10 assam kernel: [drm:i915_driver_load] *ERROR* failed to enable MSI


xorg log is blank, nothing inside.
Comment 32 Pavel Lisý 2008-11-02 17:21:40 EST
I've just installed F10Beta by yum update from Fedora8 and I have the same experience. 

My HW is IBM ThinkPad X40:
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

version of rpm:
xorg-x11-drv-i810-2.5.0-1.fc10.i386

When I boot to init 3 (text) then I run starx. I cannot see desktop but computer is working yet. When I "kill -9" pidof X than I get kernel panic.
Comment 33 Will Woods 2008-11-04 15:39:23 EST
*** Bug 467572 has been marked as a duplicate of this bug. ***
Comment 34 Walter Francis 2008-11-05 14:15:01 EST
GUI Install and post-install startx both fail the same way for me on a Dell Inspiron 1150, 855GM video.  I am attaching lspci/lspci -v, Xorg.0.log.  No xorg.conf was generated by the install.

Both failures show what appear to be a few mode changes (screen and backlight seem to flicker a bit) then the screen either turns black and seems to freeze (can't reboot, switch VTs, etc) or sometimes with startx I'll get the checkerboard background but it immediately freezes after.
Comment 35 Walter Francis 2008-11-05 14:17:06 EST
Created attachment 322631 [details]
Tarball of lspci, lspci -v, and Xorg.0.log

Logs from Inspiron 1150 from Fedora 10 Pre-release (from 11/04/08).
Comment 36 Dave Russell 2008-11-05 16:26:25 EST
Just to add to this, if I boot F10 Beta, fully updated from rawhide as of tonight I just get a few brief flashes of the screen, followed by kernel panic (caps lock light flashing).

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

IBM x61 here... pretty standard.

There's nothing worthwhile in the dmesg.old log and this is with no xorg.conf.

uname -a reports 2.6.27.4-68.fc10.i686.PAE

I *can* get a display if I write a basic xorg.conf and specify vesa as the driver.

This particular hardware worked just fine in F8/9, RHEL4/5 etc
Comment 37 Will Woods 2008-11-07 13:24:45 EST
(In reply to comment #36)

> 00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960
> Integrated Graphics Controller (rev 0c)

This bug is for black-screen problems with i855GM. You've got a different problem.
Comment 38 Will Woods 2008-11-07 13:25:35 EST
*** Bug 470566 has been marked as a duplicate of this bug. ***
Comment 39 Dave Russell 2008-11-10 08:49:21 EST
(In reply to comment #37)

> > 00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960
> > Integrated Graphics Controller (rev 0c)
> 
> This bug is for black-screen problems with i855GM. You've got a different
> problem.

So there's absolutely no chance that the same bug could be affecting two different gfx chipsets?
Comment 40 Will Woods 2008-11-10 11:40:53 EST
From a quick discussion with ajax, our fearless X maintainer:

"broadly speaking the intel graphics classes are (i810, i815), (i830, i845, i855, i865), (i915, i945), (965 and newer). i tend to assume bugs against one class are not bugs against another until proven otherwise."

You have different symptoms and different hardware. As far as I know it's not the same bug; it's a different codepath and a different fix will be required. 

So, please, file a different bug - or search bugzilla a bit. Chances are it's already been filed.
Comment 41 Will Woods 2008-11-10 11:49:27 EST
*** Bug 470541 has been marked as a duplicate of this bug. ***
Comment 42 Jesse Keating 2008-11-10 17:26:35 EST
This may be resolved by making this driver not use GEM.  Work is underway to attempt that, please stay tuned for test packages.
Comment 43 Dave Airlie 2008-11-13 04:04:23 EST
okay I'm building a kernel in koji 2.6.27.5-105

I suspect it might help however 3D might not work, if the kernel boots and X starts, try adding Option "Legacy3d" "true" to the xorg.conf and see if DRI works.
Comment 44 Charles R. Anderson 2008-11-13 19:09:03 EST
Same here on Dell Optiplex GX260:

Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device
(rev 01)

kernel-2.6.27.5-101.fc10.i686
xorg-x11-drv-i810-2.5.0-3.fc10.i386

I'll try -105 or newer kernel when its ready.
Comment 45 Pavel Lisý 2008-11-14 01:24:47 EST
I just tried kernel-2.6.27.5-109.fc10.i686 with xorg-x11-drv-i810-2.5.0-3.fc10.i386 and it is working now. I can start and stop Xorg. 

There is another problem with fonts rendering still. I'll fill new bug report.
Comment 46 Charles R. Anderson 2008-11-14 10:50:08 EST
I just tried 2.6.27.5-109.fc10.i686 and it makes no difference, I still get a gdm screen with a blank grey login window.  Hitting "ctrl" all by itself causes a beep.  I can't change ttys with either Alt-F2 or Ctrl-Alt-F2 (the latter just causing a series of repeating beeps).

excerpt from Xorg.0.log:

[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x3b) [0x812b9ab]
1: /usr/bin/Xorg(mieqEnqueue+0x289) [0x810b0c9]
2: /usr/bin/Xorg(xf86PostKeyboardEvent+0xa7) [0x80d3b27]
3: /usr/lib/xorg/modules/input//evdev_drv.so [0x560ae0]
4: /usr/bin/Xorg [0x80bcb17]
5: /usr/bin/Xorg [0x80ac67e]
6: [0x110400]
7: [0x110416]
8: /lib/libc.so.6(ioctl+0x19) [0xa66929]
9: /usr/lib/libdrm.so.2 [0x642b6cf]
10: /usr/lib/libdrm.so.2(drmCommandWrite+0x34) [0x642b984]
11: /usr/lib/libdrm_intel.so.1 [0x1b3cfb]
12: /usr/lib/libdrm_intel.so.1 [0x1b4b48]
13: /usr/lib/libdrm_intel.so.1 [0x1b4e75]
14: /usr/lib/libdrm_intel.so.1(dri_bo_exec+0x2e) [0x1b305e]
15: /usr/lib/xorg/modules/drivers//intel_drv.so(intel_batch_flush+0xa4) [0x2d53d4]
16: /usr/lib/xorg/modules/drivers//intel_drv.so(I830Sync+0x64) [0x2d4bd4]
17: /usr/lib/xorg/modules/drivers//intel_drv.so [0x2fe95a]
18: /usr/lib/xorg/modules//libexa.so(exaWaitSync+0x65) [0x208095]
19: /usr/lib/xorg/modules//libexa.so(ExaDoPrepareAccess+0x7e) [0x2093ae]
20: /usr/lib/xorg/modules//libexa.so [0x20e352]
21: /usr/lib/xorg/modules//libexa.so [0x20e8a5]
22: /usr/lib/xorg/modules//libexa.so(exaDoMigration+0x64a) [0x20f05a]
23: /usr/lib/xorg/modules//libexa.so [0x2106db]
24: /usr/lib/xorg/modules//libexa.so(exaComposite+0xb97) [0x2116f7]
25: /usr/bin/Xorg [0x816f27a]
26: /usr/bin/Xorg(CompositePicture+0x19a) [0x8157eda]
27: /usr/bin/Xorg [0x815dda5]
28: /usr/bin/Xorg [0x815aac5]
29: /usr/bin/Xorg(Dispatch+0x34f) [0x8085e6f]
30: /usr/bin/Xorg(main+0x47d) [0x806b6ed]
31: /lib/libc.so.6(__libc_start_main+0xe5) [0x9a16d5]
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
...
etc.
Comment 47 Troy Dawson 2008-11-14 11:12:33 EST
It is now working for me
Kernel - 2.6.27.5-101.fc10
xorg-x11-drv-i810-2.5.0-3.fc10.i386
I am also seeing the font problems, but yes, that is a separate ticket.
This is an Intel 82852/855GM rev 02
Comment 48 Will Woods 2008-11-14 12:49:34 EST
(In reply to comment #46)
> I just tried 2.6.27.5-109.fc10.i686 and it makes no difference, I still get a
> gdm screen with a blank grey login window.  Hitting "ctrl" all by itself causes 
> a beep.  I can't change ttys with either Alt-F2 or Ctrl-Alt-F2 (the latter just
> causing a series of repeating beeps).

X started up and displayed something other than a black screen, so *this* problem is gone. You now have a different problem, unfortunately. Please file another bug, or see if you can find an open report to CC yourself on. I'll add a comment here if I find a report for that bug.

This one, however, is closed as of kernel-2.6.27.5-109.fc10. Reopen *only* if you have a system with an Intel i8xx graphics chip that only shows a black screen when you try to start X.
Comment 49 Pavel Lisý 2008-11-14 12:56:05 EST
last comment

problem with fonts is reported here, you can connect there :-)
Bug 471537 -  Serious problem with rendering

Note You need to log in before you can comment on or make changes to this bug.