Bug 467364 - Build breaks with libtool 2.2.x
Build breaks with libtool 2.2.x
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: cracklib (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 435737
  Show dependency treegraph
 
Reported: 2008-10-17 00:38 EDT by Braden McDaniel
Modified: 2008-10-28 13:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 13:49:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Braden McDaniel 2008-10-17 00:38:43 EDT
Because it is invoking autoreconf, cracklib's build breaks with libtool 2.2.x.  There are a couple of different ways to fix this:

  * Patch configure instead of patching configure.in.  That way you don't need
    to run the autotools at all and the package is insulated from any changes in
    whatever happen to be Fedora's current autotools.

  * Run autoconf instead of running autoreconf.  I don't see any patches here
    modifying Makfile.am (that would introduce a need to run automake) and I
    don't see any new autoconf macros being introduced/run (that would introduce
    a need to run aclocal).  There is certainly no need to run libtoolize (which
    is what autoreconf is doing and why this build is busted).
Comment 1 Nalin Dahyabhai 2008-10-27 19:01:22 EDT
Where might I find libtool 2.2 packages to test with locally?
Comment 2 Karsten Hopp 2008-10-28 11:39:45 EDT
A very unoffical (not in CVS) SRPM is available at http://people.redhat.com/karsten/libtool-2.2.6-1.fc10.src.rpm
Comment 3 Nalin Dahyabhai 2008-10-28 13:49:08 EDT
Fixed in CVS, if it gets pulled in to F10, it'll be by chance, which is fine.

Note You need to log in before you can comment on or make changes to this bug.