Bug 435737 - update rawhide to latest release 2.2.6a (for fedora 11)
Summary: update rawhide to latest release 2.2.6a (for fedora 11)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libtool (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Fedora Extras Quality Assurance
URL: http://www.gnu.org/software/libtool/
Whiteboard:
Keywords: FutureFeature
Depends On: 467270 467364 467367
Blocks: 457094
TreeView+ depends on / blocked
 
Reported: 2008-03-03 16:45 UTC by acount closed by user
Modified: 2008-12-04 16:51 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 16:51:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description acount closed by user 2008-03-03 16:45:04 UTC
new stable 2.2 branch has been almost entirely rewritten

-thanks

Comment 1 Karsten Hopp 2008-03-04 09:39:43 UTC
I'm following upstream discussions about this, but won't put it in Rawhide until
we freeze for F9 as it might break quite a few packages.
Same for libtool-1.5.26 even though I don't expect any major breakages caused by it.

Comment 2 Bug Zapper 2008-05-14 05:44:12 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Stepan Kasal 2008-05-20 13:53:57 UTC
BuZapp wrote:
> Changing version to '9'...
Just don't do that.

Comment 4 Stepan Kasal 2008-05-20 13:55:09 UTC
(Adding keyword FutureFeature to denote this.)

Comment 5 John Poelstra 2008-07-04 04:31:04 UTC
changing back to rawhide as that's where futurefeatures live

Comment 6 Matthias Clasen 2008-07-06 02:31:34 UTC
Are we still planning to do this for F10 ? 
If yes, please don't wait until shortly before beta...

Comment 7 Karsten Hopp 2008-07-07 09:31:42 UTC
Re: comment #6: not very likely. I've started a mass rebuild on my system and
got a huge amount of build failures caused by the new libtool. Not because of
real bugs in libtool, but because of minor incompabilities, obsoleted functions
and so on. I think I'd rather build a libtool2 package than replace libtool-1.5
with this new version.

Comment 8 Matthias Clasen 2008-07-19 00:12:03 UTC
Thats fine with me too. Will _that_ happen sometime soon, then ?

Comment 9 Vasile Gaburici 2008-07-29 13:33:58 UTC
Libtool 2.2.4 is required to build freetype (2.3.8pre) from CVS. But not for
releases as far as I can tell.

One incompatibility is that --install flag needs to be passed to obtain some of
the behavior of the old tool.


Comment 10 Matthias Clasen 2008-08-08 17:05:15 UTC
Karsten, any motion on this ?
 
It is getting increasingly complicated to handle e.g. doing upstream releases on Fedora systems without running into gotchas due to libtool version differences with other distros...

Comment 11 Vasile Gaburici 2008-08-11 11:12:25 UTC
(In reply to comment #10)
> Karsten, any motion on this ?
> 
> It is getting increasingly complicated to handle e.g. doing upstream releases
> on Fedora systems without running into gotchas due to libtool version
> differences with other distros...

Perhaps a wiki page listing the packages that don't work with libtool 2.x would get the cooperation of the maintainers of those packages?

Comment 12 Matthias Clasen 2008-08-11 16:51:23 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > Karsten, any motion on this ?
> > 
> > It is getting increasingly complicated to handle e.g. doing upstream releases
> > on Fedora systems without running into gotchas due to libtool version
> > differences with other distros...
> 
> Perhaps a wiki page listing the packages that don't work with libtool 2.x would
> get the cooperation of the maintainers of those packages?

I am the maintainer of some packages like that. But I have a hard time fixing them up for libtool 2.x until that libtool version becomes available in Fedora.

Unless you want me to switch to some other distro for my upstream development needs, that is...

Comment 13 Karsten Hopp 2008-08-18 11:06:45 UTC
anyone up for a package review ? bugzilla #459387

Comment 14 Behdad Esfahbod 2008-09-17 22:15:54 UTC
There are at least a couple popular distros that have ported to libtool 2.2.  Maybe we can borrow their patches en masse?

Comment 15 Karsten Hopp 2008-10-17 09:25:47 UTC
Things didn't look too bad in my latest mass rebuilds. There were ~100 new build failures introduced by switching from libtool-1.5 to libtool-2.2.6a, this looks
quite doable. I've put the build logs of those build attempts on http://karsten.fedorapeople.org/libtool2-failures/


Note You need to log in before you can comment on or make changes to this bug.