Bug 467367 - Build breaks with libtool 2.2.x
Build breaks with libtool 2.2.x
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: apr (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 435737
  Show dependency treegraph
 
Reported: 2008-10-17 01:06 EDT by Braden McDaniel
Modified: 2009-02-05 12:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-05 12:10:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Braden McDaniel 2008-10-17 01:06:10 EDT
apr's build is breaking with libtool 2.2.x because it is calling apr's "buildconf" script to regenerate apr's build scripts.  Why is it doing this?  I don't see any of the autotools input files getting patched (which would be the normal reason to do such a thing).

Unless I've missed something, the problem can be fixed simply by eliminating the call to buildconf.
Comment 1 Joe Orton 2008-10-17 06:47:31 EDT
1) because APR ships a copy of the generated libtool script, which should be in sync with the system copy

2) otherwise the generated (upstream vanilla) libtool script does correctly support multilib systems, and e.g. might start hard-coding RPATHS of /usr/lib64 everywhere, which is a Major Nightmare
Comment 2 Joe Orton 2008-10-17 06:48:03 EDT
^ does **not** correctly support! :)
Comment 3 Braden McDaniel 2008-10-18 00:06:12 EDT
1) Generally speaking, there is no need for such synchronization.  (Actually, configure generates the libtool script from the included ltmain.sh.)

2) You could instead patch ltmain.sh to address this.  That would be more resilient to changes in the autotools.  Another alternative would be to build with "make LIBTOOL=/usr/bin/libtool".  While that also exposes the package to changes in the system libtool (for better or for worse), it doesn't have the side-effects running libtoolize has.
Comment 4 Bug Zapper 2008-11-25 22:56:57 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Pedro Lamarão 2008-11-27 19:14:46 EST
Is this the same bug as 467270 ?
Comment 6 Braden McDaniel 2008-11-27 22:36:58 EST
No. This isn't F10, either.
Comment 7 Joe Orton 2009-02-05 12:10:49 EST
This is fixed in Raw Hide.

Note You need to log in before you can comment on or make changes to this bug.