Bug 467390 - iscsistart gives various errors when mounting iscsi based root partition
iscsistart gives various errors when mounting iscsi based root partition
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-17 05:33 EDT by Hans de Goede
Modified: 2008-10-27 11:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 11:57:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2008-10-17 05:33:04 EDT
Description of problem:
I'm working on getting / on iscsi to work for Fedora 10, this requires an initrd fix, see bug 467379. With this initrd fix, / on iscsi works (as long as NetworkManager is disabled), but the following messages are produced by iscsistart during boot:

add: failed - 17: Netlink Error (errno = File exists)
iscsistart: transport class version 2.0-870. iscsid version 2.0-870
iscsistart: version 2.0-870
iscsistart: Logging into iqn.2005-03.com.max:testdisk
192.168.1.100:3260,1
iscsistart: connection1:0 is operational now
iscsistart: transport class version 2.0-870. iscsid version 2.0-870
iscsistart: Can not bind IPC socket
iscsistart: Could not setup mgmt ipc

iscsistart: Logging into iqn.2005-03.com.max:testdisk
192.168.1.100:3260,1
iscsistart: got read error (-1/104), daemon died?
iscsistart: initiator reported error (18 - could not communicate to
iscsid)
iscsistart: can not connect to iSCSI daemon (111)!
iscsistart: initiator reported error (18 - could not communicate to
iscsid)
iscsistart: Could not stop event_loop

I think the first message is not from iscsistart but from nash, but I included it for completeness.

The cause of the iscsistart errors is that iscsistart is being called twice and twice for the same target. I'll investigate this further and come up with a fix, so I'm assigning this to me. Peter I've put you in the CC to keep you in the loop.

Also I've applied for mkinitrd git access, I noticed katzj manages this, but I would like to have your ok (and I assume Jeremy will ask you) for getting mkinitrd access so that I can directly commit patches like the one in bug 467379.
Comment 1 Hans de Goede 2008-10-27 11:57:07 EDT
This is fixed in mkinitrd-6.0.68-1 which will be in tomorrows rawhide, closing.

Note You need to log in before you can comment on or make changes to this bug.