Bug 46745 - signal 11 during HTTP install
signal 11 during HTTP install
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-30 00:32 EDT by Brent Nordquist
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-02 15:06:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brent Nordquist 2001-06-30 00:32:02 EDT
Description of Problem:
While TUI-installing Fairfax beta1 on a Dell OptiPlex GXM 5100 (P100 with
96MB RAM and Etherlink III-compatible), received a signal 11 when trying to
retrieve stage 1 from the network.

How Reproducible:
Didn't try; switched to FTP install method.

Steps to Reproduce:
1. When asked about network card, use F2 to get drivers diskette; select
Etherlink-III
[F3 shows:
* extracting pattern 2.4.5-10*/3c509.o
* going to insmod 3c509.o (path is /tmp/modules/3c509)
* reverse name lookup worked
* copying file to fd 12
* wrote 7340032 bytes]
2. Enter network information:  not DHCP, fill in static IP, netmask, etc.
3. Select download type as HTTP.
4. Enter server (www.example.com) and directory (redhat/fairfax/beta1)
[F3 shows:
* transferring
http://www.example.com/redhat/fairfax/beta1/RedHat/base/netstg1.img to a fd]

Actual Results:
[On F1:]
install exited abnormally -- recieved [sic] signal 11
sending termination signals...done
[etc. etc.]

Expected Results:
Continue the network download and install.

Additional Information:
I double-checked that the netstg1.img file is available from the web server
at the path shown in F3 by downloading it with a web browser on another
machine (though even that shouldn't cause a signal 11).

Note that "received" is still misspelled as it has been in past betas.
Comment 1 Matt Wilson 2001-07-02 11:45:44 EDT
fixed typo in message, will try to reproduce HTTP segv (but have not seen it yet)

If you could try to reproduce as well, that would be helpful.
Comment 2 Matt Wilson 2001-07-02 14:12:14 EDT
did you pass any extra kernel parameters at the boot: prompt?  I can't reproduce
this.
Comment 3 Brent Nordquist 2001-07-02 15:06:23 EDT
No, not passing any kernel parameters; just hitting Enter at the bootnet.img
LILO prompt.

I've been working with this one for the past hour; it is happening consistently
here.  I have discovered that if I switch the "Web site name" from a DNS name to
an IP address, it avoids the SEGV.  I'm not convinced the DNS resolution in
anaconda is working here, because it asks me later for the host name even though
the IP address I entered is in DNS.  Perhaps that's germane to reproducing it.

So here are more detailed "Steps to reproduce":
1. Answer questions about language and keyboard type.
2. For [Installation Method] dialog, choose HTTP.
3. For [Configure TCP/IP] dialog, choose:
   [ ] Use dynamic...
       IP address:            172.18.34.16
       Netmask:               255.255.192.0
       Default gateway (IP):  172.18.1.15
       Primary nameserver:    172.18.14.1
4. For [HTTP Setup] dialog, choose:
   Web site name:      server.subdom.example.com
   Red Hat directory:  fairfax/beta1/i386

Note how my netmask is a little unusual.  The Apache documents directory is set
so that "/fairfax/beta1/i386/RedHat/..." is a valid URI.  Also note bug 47039
which I just filed about the directory needing a leading slash.

Let me know if there's more that would be helpful.
Comment 4 Matt Wilson 2001-07-02 15:32:43 EDT
very helpful.  I still have not reproduced, but I believe I've fixed this. 
Please retest this case in beta2.


Note You need to log in before you can comment on or make changes to this bug.