Bug 467494 - freenx-server must depend on xorg-x11-fonts-misc
Summary: freenx-server must depend on xorg-x11-fonts-misc
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freenx-server
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 494943 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-10-17 18:52 UTC by Dawid Zamirski
Modified: 2009-08-10 21:52 UTC (History)
3 users (show)

Fixed In Version: 0.7.3-15.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-10 21:40:15 UTC


Attachments (Terms of Use)
session log (1.40 KB, text/plain)
2008-10-17 18:53 UTC, Dawid Zamirski
no flags Details

Description Dawid Zamirski 2008-10-17 18:52:19 UTC
Description of problem:
This applies only to rawhide as freenx-server was working ok in Fedora 9.
After installing the nomachine client and importing the SSH key, the connection is established and authenticated successfully. When it's about to open the display the NX sessstion self-terminates without stating exact reason. After I've enabled logging on my server, I found that it fails due to:  Aborting session with 'Could not open default font 'fixed''.

Version-Release number of selected component (if applicable):
freenx-server-0.7.3-11.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. yum install freenx-server
2. download and install nomachine client on Windows system.
3. connect to the NX server and seesion start fails after sucessfullt authentication. 
  
Actual results:
Logs on the server show:
Error: Aborting session with 'Could not open default font 'fixed''.

Expected results:
Open the remote desktop session.

Additional info:
Attched full session log with the error mesage in it.

Comment 1 Dawid Zamirski 2008-10-17 18:53:22 UTC
Created attachment 320708 [details]
session log

Comment 2 Dawid Zamirski 2008-10-20 17:02:38 UTC
I have managed to solve the problem by:

yum install xorg-x11-fonts-misc

I did not have any xorg fonts installed.

Comment 3 Bug Zapper 2008-11-26 03:57:57 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Fedora Update System 2009-03-01 07:40:25 UTC
nx-3.3.0-33.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/nx-3.3.0-33.fc10

Comment 5 Fedora Update System 2009-03-01 07:40:31 UTC
nx-3.3.0-33.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/nx-3.3.0-33.fc9

Comment 6 Fedora Update System 2009-03-02 16:56:19 UTC
nx-3.3.0-33.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nx'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2208

Comment 7 Fedora Update System 2009-03-02 17:03:05 UTC
nx-3.3.0-33.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update nx'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-2240

Comment 8 Fedora Update System 2009-03-26 14:54:14 UTC
nx-3.3.0-33.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2009-03-26 14:55:36 UTC
nx-3.3.0-33.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Dawid Zamirski 2009-04-07 13:49:50 UTC
I have just ran on this issue again today after fresh Fedora 10 install (from LiveCD). Of course, I have ran yum update to get all the latest updates including the new nx package. Installing xorg-x11-fonts-misc solved the problem again. I guess the nx (or freenx-server?) package should have this font package as dependency so that when it's installed the required fonts are installed as well.

Comment 11 Dawid Zamirski 2009-04-22 13:41:21 UTC
The issue is  still present in rawhide and also fixable by installing xorg-x11-fonts-misc package.

Comment 12 Jonathan Haskins 2009-05-30 14:01:43 UTC
Confirmed on Fedora 11 Preview using (pre) Fedora 11 repo. freenx-server fails silently without xorg-x11-fonts-misc package installed.

Comment 13 Bug Zapper 2009-06-09 09:47:41 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 14 Axel Thimm 2009-07-25 16:10:50 UTC
*** Bug 494943 has been marked as a duplicate of this bug. ***

Comment 15 Itamar Reis Peixoto 2009-07-25 16:15:03 UTC
will you fix this ?

Comment 16 Axel Thimm 2009-07-25 19:12:00 UTC
(In reply to comment #15)
> will you fix this ?  

Yes, a new package with other fixes as well will soon hit updates-testing. This bugzilla will be automatically notified once the package lands there.

Comment 17 Fedora Update System 2009-07-25 23:10:56 UTC
freenx-server-0.7.3-14.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/freenx-server-0.7.3-14.fc10

Comment 18 Fedora Update System 2009-07-25 23:11:39 UTC
freenx-server-0.7.3-14.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/freenx-server-0.7.3-14.fc11

Comment 19 Fedora Update System 2009-07-27 21:29:54 UTC
freenx-server-0.7.3-14.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update freenx-server'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8023

Comment 20 Fedora Update System 2009-07-27 21:30:52 UTC
freenx-server-0.7.3-14.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update freenx-server'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8022

Comment 21 Fedora Update System 2009-08-01 23:53:47 UTC
freenx-server-0.7.3-15.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update freenx-server'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8022

Comment 22 Fedora Update System 2009-08-01 23:57:43 UTC
freenx-server-0.7.3-15.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update freenx-server'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8023

Comment 23 Fedora Update System 2009-08-10 21:39:30 UTC
freenx-server-0.7.3-15.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2009-08-10 21:51:56 UTC
freenx-server-0.7.3-15.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.