This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 467554 - F-10 snap2 X server fails to start on Intel 845G chipset
F-10 snap2 X server fails to start on Intel 845G chipset
Status: CLOSED DUPLICATE of bug 461829
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-18 10:11 EDT by Robert Nichols
Modified: 2008-10-18 12:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-18 12:52:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Nichols 2008-10-18 10:11:19 EDT
Description of problem:
The X server fails to start on a Compaq EVO D510 (Intel 845G video chipset)

Version-Release number of selected component (if applicable):
rawhide

How reproducible:
always

Steps to Reproduce:
1. Boot the system
2.
3.
  
Actual results:
Falls back to text mode.

Expected results:
X server should start.

Additional info:
Results from text-mode login and running 'startx':

X.Org X Server 1.5.2
Release Date: 10 October 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-92.1.10.el5 i686 
Current Operating System: Linux omega-3b.local 2.6.27.2-23.rc1.fc10.i686 #1 SMP Fri Oct 17 00:07:31 EDT 2008 i686
Build Date: 16 October 2008  02:54:17AM
Build ID: xorg-x11-server 1.5.2-5.fc10 
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Oct 18 08:29:22 2008
(EE) Unable to locate/open config file

New driver is "intel"
(==) Using default built-in configuration (30 lines)
(EE) open /dev/fb0: No such file or directory
(EE) intel(0): Failed to pin front buffer: Cannot allocate memory

Fatal server error:
Couldn't bind memory for BO front buffer

giving up.
xinit:  Connection refused (errno 111):  unable to connect to X server
xinit:  No such process (errno 3):  Server error.
Comment 1 Robert Nichols 2008-10-18 12:52:26 EDT

*** This bug has been marked as a duplicate of bug 461829 ***

Note You need to log in before you can comment on or make changes to this bug.