Bug 467558 - Netbeans cannot display Chinese character
Netbeans cannot display Chinese character
Status: CLOSED DUPLICATE of bug 468193
Product: Fedora
Classification: Fedora
Component: netbeans (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Victor G. Vasilyev
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target F10DesktopTarget
  Show dependency treegraph
 
Reported: 2008-10-18 12:07 EDT by Qiao
Modified: 2008-10-23 12:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 12:59:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Netbeans example GUI form cannot display Chinese (189.66 KB, image/png)
2008-10-18 12:07 EDT, Qiao
no flags Details

  None (edit)
Description Qiao 2008-10-18 12:07:43 EDT
Created attachment 320750 [details]
Netbeans example GUI form cannot display Chinese

Description of problem:
Netbeans and Gui application create by Netbeans cannot display Chinese character.



Version-Release number of selected component (if applicable):
6.1-8.fc10


How reproducible:



Steps to Reproduce:
1.Install Chinese fonts(install fonts command: yum install cjkunifonts-uming), ensure system can display Chinese character.
2.Open Netbeans, open any source file in Netbeans, input or paste some Chinese character.
  
Actual results:
Chinese character display as a box or display blank.


Expected results:


Additional info:
Comment 1 John Poelstra 2008-10-22 11:58:44 EDT
Adding to F10Target... it is a "new feature"
Comment 2 Qiao 2008-10-23 01:02:33 EDT
It must be java open jdk problem, if I use Sun's jdk with --jdk-home switch, Chinese display correctly.

And I think file /etc/java/font.properties maybe missing Chinese fonts config.
Comment 3 Victor G. Vasilyev 2008-10-23 11:47:37 EDT
Qiao, I agree with you - It is not an issue of the NetBeans. 
Because, both the NetBeans itself and the GUI Form examples use Swing components that are completely responsible for displaying glyphs. If some glyphs can't be displayed then it means either
 the Java platform hasn't correct info about an installed system font
or
 the font itself has a bug.

I've tried to reproduce the described bug, but I needed have an input method and I've followed the instructions described here:
http://fedoraproject.org/wiki/Docs/Beats/I18n#Language_Support_Installation
After installation of the Chinese Language Support via the command
$ su -c 'yum groupinstall chinese-support'
I can input and see hieroglyphs in the editable Swing components in both editor window of the NetBeans and the GUI Form examples application.
I think, such test is enough to be sure that the issue in the underlying components (i.e OpenJDK, the cjkunifonts-uming font, or Fedora configuration), but not in the NetBeans or its examples. 

Also, please note, the examples are only simplest Java Swing applications not more and their functionality doesn't have any impact on I18N features provided by underlaid Java and Fedora platforms.

John, I suggest to reassign this bug sequentially to responsible persons for the underlying components (and begin this with  OpenJDK) to find both a source of the bug and a way to fix it.
Comment 4 Qiao 2008-10-23 12:58:24 EDT
this problem have resolved, please see https://bugzilla.redhat.com/show_bug.cgi?id=468193
Comment 5 Qiao 2008-10-23 12:59:57 EDT

*** This bug has been marked as a duplicate of bug 468193 ***

Note You need to log in before you can comment on or make changes to this bug.