Bug 468193 - Chinese fonts have changed file name
Chinese fonts have changed file name
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cjkuni-fonts (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
: i18n, Reopened
: 467558 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-23 10:58 EDT by Qiao
Modified: 2009-07-19 06:07 EDT (History)
8 users (show)

See Also:
Fixed In Version: 0.2.20080216.1-26.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-19 06:07:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Chinese fonts file name change patch (816 bytes, patch)
2008-10-23 11:00 EDT, Qiao
no flags Details | Diff

  None (edit)
Description Qiao 2008-10-23 10:58:50 EDT
file /usr/share/fonts/cjkunifonts-uming/uming.ttf in package cjkunifonts-uming have changed to /usr/share/fonts/cjkunifonts-uming/uming.ttc
file /usr/share/fonts/cjkunifonts-ukai/ukai.ttf in package cjkunifonts-ukai have changed to /usr/share/fonts/cjkunifonts-ukai/ukai.ttc
Comment 1 Qiao 2008-10-23 11:00:10 EDT
Created attachment 321297 [details]
Chinese fonts file name change patch
Comment 2 Lillian Angel 2008-10-23 12:18:30 EDT
I have fixed this upstream. It will be in the next release.
Comment 3 Qiao 2008-10-23 12:59:57 EDT
*** Bug 467558 has been marked as a duplicate of this bug. ***
Comment 4 Qiao 2008-10-24 00:55:50 EDT
this bug will cause lots of Java application cannot display Chinese(like bug 467558), and I think it is necessary to add a patch to this package if icedtea6 1.4 won't be include in Fedora 10
Comment 5 Lillian Angel 2008-10-24 08:24:18 EDT
It will be in F-10.
Comment 6 Jens Petersen 2008-11-03 00:28:23 EST
So is it fixed in current rawhide now?
Comment 7 Qiao 2008-11-03 02:50:34 EST
Yes, it have fixed and I test OK.
Comment 8 Qiao 2009-05-27 08:49:18 EDT
Java application like Netbeans cannot display Chinese character because chinese fonts package changed

file /usr/share/fonts/cjkunifonts-uming/uming.ttc in package cjkuni-uming-fonts
have moved to /usr/share/fonts/cjkuni/uming.ttc
file /usr/share/fonts/cjkunifonts-ukai/ukai.ttc in package cjkuni-ukai-fonts
have moved to /usr/share/fonts/cjkuni/ukai.ttc
Comment 9 Thomas Fitzsimmons 2009-06-18 20:53:01 EDT
I noticed the same behaviour in Emacs 23.  It couldn't display some Chinese
characters (specifically:

BIG5(元氣,開發)

and

Cantonese (粵語,廣東話)	早晨, 你好

in the HELLO file).

I also noticed the line:

FreeType: couldn't open face /usr/share/fonts/cjkuni/ukai.ttc: 1

repeated a bunch of times in /var/log/Xorg.0.log.

yum install /usr/share/fonts/cjkuni/ukai.ttc

fixed both problems.
Comment 10 Jens Petersen 2009-06-18 21:14:18 EDT
But uming should be used by default for Chinese IMHO and that is what we install by default in Fedora.
Comment 11 Jens Petersen 2009-06-18 21:17:47 EDT
(In reply to comment #8)
> Java application like Netbeans cannot display Chinese character because chinese
> fonts package changed

You need to file a bug against netbeans or cjkuni-fonts to get this fixed.  I think for F10 maybe we need a compat symlink in cjkuni, Caius?  If not already?

(In reply to comment #9)
> I noticed the same behaviour in Emacs 23.  It couldn't display some Chinese
> characters (specifically:

Well missing font and changed font path are different issues. :)
Comment 12 Jens Petersen 2009-06-18 21:21:03 EDT
(In reply to comment #11)
> (In reply to comment #8)
> > Java application like Netbeans cannot display Chinese character because chinese
> > fonts package changed
> 
> You need to file a bug against netbeans or cjkuni-fonts to get this fixed.  I
> think for F10 maybe we need a compat symlink in cjkuni, Caius?  If not already?

Actually not F10, but for rawhide and f11?
Comment 13 Caius Chance 2009-06-18 21:33:42 EDT
AFAIK according to Mailhot, this is planned to let all packagers to aware the latest Font Packaging Changes (i.e. package name and path change in this case). 

I could always create such symlinks to cjkuni-fonts-compat quickly. However, if packagers are not aware that cjkuni-fonts-compat is needed for symlinks, situation will not be resolved still.
Comment 14 Fedora Update System 2009-06-19 02:27:54 EDT
cjkuni-fonts-0.2.20080216.1-24.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/cjkuni-fonts-0.2.20080216.1-24.fc11
Comment 15 Caius Chance 2009-06-19 02:34:47 EDT
To test:

http://koji.fedoraproject.org/koji/buildinfo?buildID=107011
Comment 16 Nicolas Mailhot 2009-06-19 03:47:46 EDT
Actually, this kind of symlink does not belong in the font package IMHO, it's apps that do not use fontconfig that should carry the burden of pointing to the actual file on the filesystem. That will hopefully motivate them to move to our primary font stack.

I'll release soonish a repo audit script that detects when such symlinks are broken (I've been tweaking it those past two weeks)
Comment 17 Fedora Update System 2009-06-24 15:39:53 EDT
cjkuni-fonts-0.2.20080216.1-24.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cjkuni-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6832
Comment 18 Fedora Update System 2009-07-06 00:36:42 EDT
cjkuni-fonts-0.2.20080216.1-26.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/cjkuni-fonts-0.2.20080216.1-26.fc11
Comment 19 Fedora Update System 2009-07-11 13:29:56 EDT
cjkuni-fonts-0.2.20080216.1-26.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cjkuni-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7515
Comment 20 Fedora Update System 2009-07-19 06:07:28 EDT
cjkuni-fonts-0.2.20080216.1-26.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.