Bug 467573 - Typing any key causes it to be typed three times
Typing any key causes it to be typed three times
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
: Reopened
: 467853 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-18 16:07 EDT by Peter Gückel
Modified: 2009-10-22 09:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.0.7-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-21 00:24:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/etc/X11/xorg.conf (65 bytes, application/octet-stream)
2008-10-19 11:56 EDT, Peter Gückel
no flags Details
/var/log/Xorg.0.log (49.09 KB, application/octet-stream)
2008-10-19 11:59 EDT, Peter Gückel
no flags Details
/var/log/Xorg.0.log (17.06 KB, text/plain)
2008-10-21 11:09 EDT, sangu
no flags Details

  None (edit)
Description Peter Gückel 2008-10-18 16:07:01 EDT
Description of problem:
When a key is typed, it is entered thrice. It is not possible to backspace twice, as each backspace is also entered in triplicate. Hence, it is impossible to make any meaningful keyboard entry while in run level 5. It is also not possible to shift to a textual run level without rebooting and editing the grub kernel boot line (likely because of the erroneous key input while running X).

Version-Release number of selected component (if applicable):
2.0.7-1

How reproducible:
Update from the latest functioning evdev driver (2.0.6-2; don't know about 2.0.6-3) to the newly available version, 2.0.7-1; reboot or restart the X Server; and attempt to enter a command.

Steps to Reproduce:
1. Update;
2. Restart X Server; and
3. Attempt to enter a command or write a text.
  
Actual results:
Each keystroke will be effected three times for each time the key is pressed.

Expected results:
Each keystroke should only occur once, or as often as the key is actually pressed.

Additional info:
Comment 1 Peter Hutterer 2008-10-19 02:55:47 EDT
I'd need your xorg.conf and your Xorg.log please.
You need xorg-x11-server-Xorg-1.5.2-5 or later.

As a quickfix: if you have any devices in your xorg.conf that use the kbd or mouse driver, remove them from your ServerLayout.

See also a lengthy version of why that happens at:
http://who-t.blogspot.com/2008/10/new-keyboard-configuration-handling.html
Comment 2 Peter Gückel 2008-10-19 11:56:34 EDT
Created attachment 320807 [details]
/etc/X11/xorg.conf

This is the xorg.conf I am using. Previously, instructions had been not to use an xorg.conf, but this prevented any keyboard or mouse input. Then, talk on the fedora lists said one should use a 'minimal' xorg.conf, exactly as I have here. It has worked flawlessly until this 2.0.7-1 update.
Comment 3 Peter Gückel 2008-10-19 11:59:38 EDT
Created attachment 320808 [details]
/var/log/Xorg.0.log

This is the current log, using the xorg.conf I previously attached (everything works just fine with this setup, but I am not using 2.0.7-1, of course).
Comment 4 Peter Gückel 2008-10-19 12:43:25 EDT
I read your blog entry. As a result, I deleted xorg.conf from the laptop, applied the new 2.0.7-1 update, rebooted, held my breath... and it works fine, as far as I can presently tell. I will now risk it on my main (desktop) machine, but I have no doubt that all will be fine. I appreciate the dedication of all of the Red Hat and Fedora programmers and am enamoured of this operating system, and particularly, of the Fedora distro that I have come to understand.
.
If there is a lesson to be learned here, and I must add that I am a devoté of Fedora/Red Hat since 1997 and would not consider switching to another OS or distro, it is this: would it not be useful to publicize changes a user needs to make before applying a new update (perhaps PackageKit could send out a little message stating, do this or that before applying the following update)?
.
This is not the first time I have experienced this type of problem. The last time, a few weeks back, I did the daily update, got a new X server, evdev, Intel graphic driver etc, didn't think a thing of it, rebooted my computer the following morning, and was unable to enter any text whatsoever (the laptop would not even log in). Fortunately, I had F9 on another partition, so I was able to check the Fedora lists, but there was nothing but hushed silence. After doing a lot of reading, googling, sweating, cursing (because I had updated both of my computers)... I learned - not from the Fedora lists, but from a gentoo tutorial! - that the previous system of having no xorg.conf would no longer work and one would have to have a minimal xorg.conf, namely the one I just attached.
.
There have been a number of similar incidents where a user was expected to make a change before applying an update, otherwise the computer would either not be able to start X, or some other function would not work, but no notice, no direction, no indication whatsoever was publicized in any medium whatsoever. There was not even discussion on the Fedora lists! How should an end user know what changes are to be made to keep the system working? Countless times, I have spent hours, days even (ungelogen!), trying to solve a problem and there was not a word mentioned anywhere (and a good number to times, I found the answer in a gentoo tutorial that I discovered after spending countless hours fretting, configuring, rebooting). Am I the only one using Fedora as a sole OS? Unlikely. So, how do the others learn of the necessary changes (since they apparently have absolutely no need to even ask about problems on the lists)? Where is the source to this 'insider' knowledge to get everything set up correctly so that updates, advancements and changes all work without a hitch? I couldn't possibly read each and every developer's blog before every update, nor would I even know who and where they are.
Comment 5 Peter Gückel 2008-10-19 15:50:28 EDT
Sorry, I forgot to mention that the problem is now resolved on both of my computers (I have removed xorg.conf, rebooted and, after a few hours of use, have found no sign of any problem or deficiency with the 2.0.7-1 driver).
Comment 6 Matěj Cepl 2008-10-19 18:12:46 EDT

*** This bug has been marked as a duplicate of bug 467636 ***
Comment 7 Matěj Cepl 2008-10-19 18:14:25 EDT
sorry, it is not duplicate -- unfortunately, it would be fixed now.
Comment 8 sangu 2008-10-20 12:20:01 EDT
When adding below option in xorg.conf, this issue happens.

Section "ServerFlags"
	Option "AllowEmptyInput" "off"
EndSection
Comment 9 Peter Gückel 2008-10-20 20:51:52 EDT
I have removed the said xorg.conf, as quoted above, and the problem has entirely vanished.
Comment 10 Peter Hutterer 2008-10-21 00:24:23 EDT
Fixed with evdev 2.0.7-2 -> CLOSED NEXTRELEASE

2.0.7-2 caches the device minor/major numbers and compares them against the devices being added. Hence if you add a device twice, the second one will be refused. This resembles the behaviour we had before.

(In reply to comment #4)
> This is not the first time I have experienced this type of problem. The last
> time, a few weeks back, I did the daily update, got a new X server, evdev,
> Intel graphic driver etc, didn't think a thing of it, rebooted my computer the
> following morning, and was unable to enter any text whatsoever (the laptop
> would not even log in). Fortunately, I had F9 on another partition, so I was
> able to check the Fedora lists, but there was nothing but hushed silence. 

I agree that I should have announced the change better, but you are running a beta version of Fedora. Things break from time to time. And now they're (mostly) back to what they were before (also thanks to your bug report). So in summary, the process works ;)

FWIW, my posts end up on http://planet.fedoraproject.org, that may be a site worth tracking.
Comment 11 sangu 2008-10-21 11:09:16 EDT
Created attachment 321020 [details]
/var/log/Xorg.0.log

This issue still happens with xorg-x11-drv-evdev-2.0.7-2.fc10.
$cat /etc/X11/xorg.conf
[skip]
Section "ServerFlags"
	Option "AllowEmptyInput" "off"
EndSection
Comment 12 Peter Hutterer 2008-10-21 19:48:59 EDT
Just remove this section.

with AEI off, you're basically telling the server to create mouse/kbd devices on the default devices (/dev/console and /dev/input/mice).
At the same time, you're also asking the server to add all devices that are listed by HAL.

so you get the same device twice with two different drivers - causing duplicate events (the three characters come from key-repeat kicking in if that happens).
Comment 13 Peter Hutterer 2008-10-21 23:26:56 EDT
*** Bug 467853 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.