Bug 467853 - Cannot log on due to password not being processed correctly.
Cannot log on due to password not being processed correctly.
Status: CLOSED DUPLICATE of bug 467573
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker F10DesktopBlocker
  Show dependency treegraph
 
Reported: 2008-10-21 07:16 EDT by eric@christensenplace.us
Modified: 2008-10-21 23:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-21 23:26:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
List of packages update on Oct 20 (6.75 KB, text/plain)
2008-10-21 18:01 EDT, eric@christensenplace.us
no flags Details

  None (edit)
Description eric@christensenplace.us 2008-10-21 07:16:59 EDT
Description of problem: At the login screen, when entering password three characters are generated for every one I type.  This just started this morning (ran updates last night).  I cannot login now.


Version-Release number of selected component (if applicable): Not sure what component is responsible for this part of GNOME.


How reproducible: Very


Steps to Reproduce:
1. Boot computer.
2. Click on name at the login prompt of GNOME.
3. Enter password.
  
Actual results: When entering password, three dots show up for every character I enter.  GNOME will not log me in.


Expected results: GNOME would log me in based on a correct password.


Additional info: Sorry, I don't know what package the login screen comes from.  Please reassign it to the proper package if this isn't it.  Thanks!
Comment 1 eric@christensenplace.us 2008-10-21 18:01:00 EDT
Created attachment 321092 [details]
List of packages update on Oct 20

Not sure if this helps but this is a list of packages that were updated the day before the problem occurred.
Comment 2 eric@christensenplace.us 2008-10-21 18:08:51 EDT
Okay, this has to be the weirdest problem I've ever encountered.  If I am at the GNOME login screen and go to a TTY and then jump back I can successfully enter a single character and it will show up with a single dot.  All subsequent entries now show up as two dots.  All I have to do is jump into a TTY and then back again and I can get the one character, again.

Also, not sure this is related but TTY1 is the GUI vice TTY7(?).
Comment 3 Matthias Clasen 2008-10-21 22:06:52 EDT
> Also, not sure this is related but TTY1 is the GUI vice TTY7(?).

Yes, this has been changed.

Regarding your other problem, do you have an xorg.conf that mentions input devices ? It sounds like you are having evdev problems.
Comment 4 Peter Hutterer 2008-10-21 23:26:56 EDT
Please update to xorg-x11-drv-evdev-2.0.7-2 and xorg-x11-server-1.5.2-7 or higher.

Aside from that, removing the input devices from your xorg.conf is generally a good idea.

*** This bug has been marked as a duplicate of bug 467573 ***

Note You need to log in before you can comment on or make changes to this bug.