Bug 467624 - unable to boot new kernels from encrypted disk
unable to boot new kernels from encrypted disk
Status: CLOSED DUPLICATE of bug 468856
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-19 11:55 EDT by Patrick Wessa
Modified: 2008-10-29 16:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 16:49:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Wessa 2008-10-19 11:55:19 EDT
Description of problem:
Unable to boot the latest kernels when harddisk is encrypted. The system does not ask for a password.


Version-Release number of selected component (if applicable):
kernel 2.6.27.2-23.rc1.fc10.i686
kernel 2.6.27.3-27.rc1.fc10.i686

How reproducible:
Boot the system on a machine that has an encrypted harddisk.

Steps to Reproduce:
1. install rawhide 10 with encryption
2. install the new kernel
3. boot
  
Actual results:
It looks like the boot process is going well (the progress bar goes to 100%). The login screen for the user account is not shown - the system gets stuck because the user was never prompted to enter the password to decrypt the disk.

Expected results:


Additional info:
Comment 1 Patrick Wessa 2008-10-29 16:43:12 EDT
I just tried the newest kernel that was released in rawhide (version 2.6.27.4-58.fc10.i686) and it has the same problem. I can only boot from 2.6.27-13.fc10.i686.
Comment 2 Dave Jones 2008-10-29 16:49:50 EDT

*** This bug has been marked as a duplicate of bug 468856 ***

Note You need to log in before you can comment on or make changes to this bug.