This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 468856 - plymouth-0.6.0-0.2008.10.27.5.fc10.x86_64, Solar, encrypted root black screens; does not prompt for password
plymouth-0.6.0-0.2008.10.27.5.fc10.x86_64, Solar, encrypted root black screen...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
: 467624 468998 469168 469267 469272 469510 (view as bug list)
Depends On:
Blocks: F10Preview
  Show dependency treegraph
 
Reported: 2008-10-28 09:36 EDT by Tom London
Modified: 2013-01-09 23:52 EST (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 18:49:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom London 2008-10-28 09:36:47 EDT
Description of problem:
Booting with plymouth-0.6.0-0.2008.10.27.5.fc10.x86_64 (and kernel-2.6.27.4-58.fc10.x86_64), I don't get the nice "unlock screen" for my encrypted partition.

I just get the "Black Screen of Indifference"......

Version-Release number of selected component (if applicable):
plymouth-0.6.0-0.2008.10.27.5.fc10.x86_64

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ray Strode [halfline] 2008-10-28 10:53:58 EDT
Looks like mkinitrd isn't calling 

cryptsetup luksOpen

anymore.
Comment 2 Ray Strode [halfline] 2008-10-28 10:57:28 EDT
just to be sure you're seeing the same thing as me, does downgrading mkinitrd and rebuilding your initrd fix your issue?
Comment 3 Tom London 2008-10-28 12:54:12 EDT
Yes.

I reverted to mkinitrd-6.0.67-1.fc10.x86_64 (w/ nash, libbdevid-python) and installed kernel-2.6.27.4-61.fc10.x86_64 from koji.

Boots/prompts for password just fine.
Comment 4 Bruno Wolff III 2008-10-29 00:45:27 EDT
People who are effected by this and who are using encrypted raid partitions may want to look at bug 468955 for some other stuff that they will need to fix in the short run.
Comment 5 Bruno Wolff III 2008-10-29 09:44:49 EDT
I have a question about the effects of reverting. I still see mkinitrd-6.0.68-1.fc10 tagged as dist-f10 and f10-final in koji. While mkinitrd-6.0.67-1.fc10 is tagged dist-f10. So it doesn't appear there is any information in koji that can be used to detect that the mkinitrd-6.0.68-1.fc10 version shouldn't be used. Is there some way I have missed?
Comment 6 Ray Strode [halfline] 2008-10-29 10:04:04 EDT
I don't think we are planning to revert mkinitrd.  I believe the current plan is to fix mkinitrd and push a new build.
Comment 7 Bruno Wolff III 2008-10-29 10:13:35 EDT
OK, that makes more sense. Between misreading this bug and perhaps misremembering a message on one of the Fedora lists, I thought something had already been done and was wondering why I didn't see a change.
Comment 8 Dave Jones 2008-10-29 10:38:19 EDT
*** Bug 468998 has been marked as a duplicate of this bug. ***
Comment 9 Dave Jones 2008-10-29 16:49:50 EDT
*** Bug 467624 has been marked as a duplicate of this bug. ***
Comment 10 David Lehman 2008-10-30 09:27:06 EDT
This should be fixed in mkinitrd-6.0.69.
Comment 11 Bruno Wolff III 2008-10-30 11:52:38 EDT
I don't see it in Koji yet. Did something get missed or is there just some lag?
Comment 12 Charles R. Anderson 2008-10-30 12:46:28 EDT
I just tried a rawhide install today to an existing encrypted PV/VG into a new LV, no RAID involved, and I'm also missing the "cryptsetup" call in my initrd.
I'll test mkinitrd-6.0.69 as soon as a build is available.
Comment 13 Tom London 2008-10-30 14:24:45 EDT
I can verify that mkinitrd-6.0.69-1.fc10.x86_64 (from koji) fixes this.
Comment 14 Charles R. Anderson 2008-10-30 15:01:49 EDT
Verified copy of 6.0.69 from git works.
Comment 15 Bruno Wolff III 2008-10-30 16:31:13 EDT
I tested this as well and it works for me.
Comment 16 Dave Jones 2008-10-30 18:30:29 EDT
*** Bug 469267 has been marked as a duplicate of this bug. ***
Comment 17 Jesse Keating 2008-10-30 18:49:28 EDT
This has been tagged, and proven to work well.  Closing.
Comment 18 Dave Jones 2008-10-30 20:25:55 EDT
*** Bug 469272 has been marked as a duplicate of this bug. ***
Comment 19 Dave Jones 2008-10-30 23:58:07 EDT
*** Bug 469168 has been marked as a duplicate of this bug. ***
Comment 20 Alexandre Oliva 2008-11-01 15:04:10 EDT
*** Bug 469510 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.