Bug 467753 - stage2= does not work for FTP method
stage2= does not work for FTP method
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-20 14:05 EDT by Patrick C. F. Ernzer
Modified: 2008-11-04 08:34 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 13:14:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/root/anaconda-ks.cfg as picked up after an interactive install (1.47 KB, text/plain)
2008-10-22 15:26 EDT, Patrick C. F. Ernzer
no flags Details
/var/log/anaconda.log picked up after an interactive install (26.20 KB, text/plain)
2008-10-22 15:26 EDT, Patrick C. F. Ernzer
no flags Details
/root/anaconda-ks.cfg as picked up after an interactive install (anaconda-11.4.1.52-1) (1.58 KB, text/plain)
2008-10-29 13:48 EDT, Patrick C. F. Ernzer
no flags Details
/var/log/anaconda.log picked up after an interactive install (anaconda-11.4.1.52-1) (43.07 KB, text/plain)
2008-10-29 13:49 EDT, Patrick C. F. Ernzer
no flags Details

  None (edit)
Description Patrick C. F. Ernzer 2008-10-20 14:05:15 EDT
Description of problem:
anaconda 11.4.1.50 does not parse it's own anaconda-ks.cfg, I get multiple failures

Version-Release number of selected component (if applicable):
anaconda 11.4.1.50

How reproducible:
always

Steps to Reproduce:
1. install rawhide interactively
2. retrieve anaconda-ks.cfg from the box
3. try to kickstart with this file
  
Actual results:
multiple failures:
 1) anaconda asks for installation method, even though the ks file in question has a clear
repo --name="Installation Repo"  --baseurl=ftp://192.10.10.250/pub/Fedora/development/x86_64/os/

 2) giving anaconda that URL when it asks it will then bail out with 
Error Parsing Kickstart Config
The following error was found while parsing your kickstart configuration: 
The following problem occurred on line 0 of the kickstart file:      
no such option: --service

 3) commenting out the line "firewall --service=ssh", rebooting, feeding it again the URL manually, gets me to the partition screen as expected (as we child-lock partitioning), so next step is removing the comments.

Expected results:
a) anaconda should not ask for install method if it wrote a ks file itself which contains the information. It was always the case that saying ks=... on the boot line would get it all running, it would seem that post F10 beta I need to give ks=... _and_ method=... on the kernel boot line. Is this a bug or is this intended? 

b) anaconda should not choke on a "firewall --service=ssh" line, especially not with such a cryptic message if it wrote the ks file itself.
changing the line to "firewall --ssh" (as per anaconda 11.4.1.50 docs) makes install work.

Additional info:
the machines get booted with the following PXE entry
label fc-devel-x86_64ks
  MENU LABEL Fedora development (aka rawhide) x86_64 kickstart installer
  TEXT HELP
  This entry will erase all your HDs
  Only use if you want to install a system for testing
  ENDTEXT
  IPAPPEND 2
  kernel fc-devel-x86_64/vmlinuz
  append initrd=fc-devel-x86_64/initrd.img ks=http://192.10.10.250/kickstart/pcfe/F-rawhide-minimaltesting-x86_64-ks.cfg ksdevice=bootif

(obviously all from append through bootif is one line)

This broke at some point after F10 beta,
Comment 1 Patrick C. F. Ernzer 2008-10-22 15:26:01 EDT
Created attachment 321203 [details]
/root/anaconda-ks.cfg as picked up after an interactive install
Comment 2 Patrick C. F. Ernzer 2008-10-22 15:26:52 EDT
Created attachment 321204 [details]
/var/log/anaconda.log picked up after an interactive install
Comment 3 Patrick C. F. Ernzer 2008-10-22 15:28:22 EDT
to be complete; the interactive install from which the files in Comment #1 and Comment #2 were taken was started with the following PXE entry:

label fc-devel-x86_64
  MENU LABEL Fedora development (aka rawhide) x86_64 installer
  TEXT HELP
  Fedora development may not be installable.
  If it fails either try again tomorrow (we sync every night)
  or install Fedora 8 x86_64 and then update to Fedora devel
  ENDTEXT
  kernel fc-devel-x86_64/vmlinuz
  append initrd=fc-devel-x86_64/initrd.img repo=ftp://192.10.10.250/pub/Fedora/development/x86_64/os/
Comment 4 Chris Lumens 2008-10-22 16:18:45 EDT
The problem appears to be the --stage2=@/tmp/method parameter being passed, which is how we pass the FTP URL to anaconda in order to hide the username and password.  Expanding that out for --stage2= got missed when I did all the rest of that work.

I'd hoped to be able to test this entirely through an updates.img but the work also included stuff in loader, so we'll just have to wait for the next build of anaconda to see if it works.
Comment 6 Patrick C. F. Ernzer 2008-10-29 13:46:22 EDT
retested with anaconda-11.4.1.52-1 and pykickstart-1.46-1 still starting the interactive install as described in comment #3 and then feeding it back to anaconda for kickstart installs 

results:
  - bug 468850 made me add an ignoredrives list and remove the --driveorder=... but  from the partition section, but that bug is known and being dealt with.
  - "firewall --service=ssh" line is now dealt with correctly
  - anaconda now writes a nearly correct url line, I get "url --url=ftp://192.10.10.250/pub/Fedora/development/x86_64/os//images/install.img" but that is not yet what is needed, it will complain after 5-10 minutes that it is unable to read package metadata. If I change the line manually to "url --url=ftp://192.10.10.250/pub/Fedora/development/x86_64/os/" the kickstart works as expected.

Chris, I will attach the anaconda-ks.cfg and anaconda.log from the interactive install. Do you need anything else?
Comment 7 Patrick C. F. Ernzer 2008-10-29 13:48:22 EDT
Created attachment 321834 [details]
/root/anaconda-ks.cfg as picked up after an interactive install (anaconda-11.4.1.52-1)
Comment 8 Patrick C. F. Ernzer 2008-10-29 13:49:09 EDT
Created attachment 321835 [details]
/var/log/anaconda.log picked up after an interactive install (anaconda-11.4.1.52-1)
Comment 9 Chris Lumens 2008-10-29 13:59:38 EDT
Does updates=http://clumens.fedorapeople.org/467753.img fix it?
Comment 10 Patrick C. F. Ernzer 2008-10-30 13:01:10 EDT
(In reply to comment #9)
> Does updates=http://clumens.fedorapeople.org/467753.img fix it?

yes, now the anaconda-ks.cfg from an interactive install reads
url --url=ftp://192.10.10.250/pub/Fedora/development/x86_64/os/

Thanks Chris.
Comment 11 Chris Lumens 2008-10-30 13:14:11 EDT
Thanks for testing, this will be in the next build of anaconda.
Comment 12 Patrick C. F. Ernzer 2008-11-04 08:34:06 EST
confirm, the fix is in anaconda now, no more updates.img needed.
tested with 11.4.1.54
this bug can be closed

Note You need to log in before you can comment on or make changes to this bug.