Bug 468850 - HAL shows loop0/ram0/etc. as block devices, confusing anaconda/nautilus
HAL shows loop0/ram0/etc. as block devices, confusing anaconda/nautilus
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
anaconda_trace_hash:71f58af15478cfe7a...
:
: 468957 469122 469149 (view as bug list)
Depends On:
Blocks: F10Preview
  Show dependency treegraph
 
Reported: 2008-10-28 08:12 EDT by James Laska
Modified: 2013-09-02 02:28 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-30 12:36:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (71.74 KB, text/plain)
2008-10-28 08:12 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2008-10-28 08:12:30 EDT
This bug was filed automatically by anaconda.
Comment 1 James Laska 2008-10-28 08:12:33 EDT
Created attachment 321693 [details]
Attached traceback automatically from anaconda.
Comment 2 Orion Poplawski 2008-10-28 10:52:11 EDT
Problem seems to be too many drives in the drive list:

12:11:11 DEBUG   : self.driveList(): ['sda', 'ram0', 'ram1', 'ram2', 'ram3', 'ram4', 'ram5', 'ram6', 'ram7', 'ram8', 'ram9', 'loop0', 'loop1', 'loop2', 'loop3', 'loop4', 'loop5', 'loop6', 'loop7', 'ram10', 'ram11', 'ram12', 'ram13', 'ram14', 'ram15']

Instead of:

13:04:08 DEBUG   : self.driveList(): ['sda']
Comment 3 Warren Togami 2008-10-28 10:55:01 EDT
Anaconda from October 28th rawhide asked if I wanted to initialize ram[0-15] and loop[0-5] devices.  I clicked No to all prompts and it seems to be able to proceed.
Comment 4 Jeremy Katz 2008-10-28 11:04:41 EDT
This is because those devices have started showing up in hal where they didn't before.  It seems to me they shouldn't be showing up as disks in hal, but I guess if we have to, we can filter them out :/

Richard, David?
Comment 5 Richard Hughes 2008-10-28 12:55:56 EDT
Matthias mentioned this to me just now. I can't reproduce on a 2.6.27.4-51.fc10.i686 kernel, but I've got the lshal from him. It contains tons of stuff like this:

udi = '/org/freedesktop/Hal/devices/computer_storage_bdi_disk_6'
  block.device = '/dev/loop7'  (string)
  block.is_volume = false  (bool)
  block.major = 7  (0x7)  (int)
  block.minor = 7  (0x7)  (int)
  block.storage_device = '/org/freedesktop/Hal/devices/computer_storage_bdi_disk_6'  (string)
  info.capabilities = {'storage', 'block'} (string list)
  info.category = 'storage'  (string)
  info.parent = '/org/freedesktop/Hal/devices/computer_bdi_7_7'  (string)
  info.udi = '/org/freedesktop/Hal/devices/computer_storage_bdi_disk_6'  (string)
  linux.hotplug_type = 3  (0x3)  (int)
  linux.sysfs_path = '/sys/devices/virtual/block/loop7'  (string)
  storage.automount_enabled_hint = true  (bool)
  storage.bus = 'bdi'  (string)
  storage.drive_type = 'disk'  (string)
  storage.hotpluggable = false  (bool)
  storage.media_check_enabled = false  (bool)
  storage.model = ''  (string)
  storage.no_partitions_hint = false  (bool)
  storage.originating_device = '/org/freedesktop/Hal/devices/computer'  (string)
  storage.partitioning_scheme = 'none'  (string)
  storage.removable = false  (bool)
  storage.removable.media_available = true  (bool)
  storage.removable.media_size = 0  (0x0)  (uint64)
  storage.requires_eject = false  (bool)
  storage.size = 0  (0x0)  (uint64)
  storage.vendor = ''  (string)

The kernel is telling us / hal is probing this, and then we get a "block" device that doesn't exist. I don't know enough about BDI to tell you what the problem is. I'll have a try.
Comment 6 Richard Hughes 2008-10-28 16:38:15 EDT
Can you try http://koji.fedoraproject.org/koji/taskinfo?taskID=909916 please.
Comment 7 Will Woods 2008-10-28 16:52:15 EDT
Er, it's tricky to inject that into an anaconda image, but as I understand the problem:

* Current Rawhide systems have HAL entries for /dev/{loop,ram}X.
  - This is true on my current Rawhide machines.
* This is confusing Anaconda into thinking they're valid storage devices.
* This HAL update is intended to fix that by not listing /dev/{loop,ram}X.

If I've understood the problem and intended solution correctly, then yes - that hal build works.
Comment 8 Jeremy Katz 2008-10-28 18:10:07 EDT
It looks like it should from a quick check of downloading and running on my system normally.  Can you request the tag for dist-f10 and then we can be certain with tomorrow's rawhide?
Comment 9 Jesse Keating 2008-10-28 18:30:25 EDT
https://fedorahosted.org/rel-eng/ticket/891  requested for tagging.
Comment 10 Jesse Keating 2008-10-28 19:06:59 EDT
It's been tagged, and will need re-testing with tomorrow's rawhide.
Comment 11 Jeremy Katz 2008-10-29 10:11:09 EDT
*** Bug 468957 has been marked as a duplicate of this bug. ***
Comment 12 Will Woods 2008-10-29 22:30:48 EDT
*** Bug 469122 has been marked as a duplicate of this bug. ***
Comment 13 Tomáš Bžatek 2008-10-30 12:17:00 EDT
*** Bug 469149 has been marked as a duplicate of this bug. ***
Comment 14 Orion Poplawski 2008-10-30 12:36:33 EDT
Works for me.

Note You need to log in before you can comment on or make changes to this bug.