Bug 467759 - Doesn't display status on XO
Doesn't display status on XO
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 468740 (view as bug list)
Depends On:
Blocks: FedoraOnXO
  Show dependency treegraph
 
Reported: 2008-10-20 15:10 EDT by Jeremy Katz
Modified: 2008-10-27 15:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 13:15:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gnome-power-manager --nodaemon --verbose output (6.01 KB, text/plain)
2008-10-20 15:10 EDT, Jeremy Katz
no flags Details
output from lshal (50.27 KB, text/plain)
2008-10-20 15:11 EDT, Jeremy Katz
no flags Details

  None (edit)
Description Jeremy Katz 2008-10-20 15:10:37 EDT
Created attachment 320903 [details]
gnome-power-manager --nodaemon --verbose output

On the XO, we don't get any displayed power status with gnome-power-manager.  This could possibly be a hal problem, but we'll start here.

Tested with F10Snap2 live image booted off of SD on the XO.  gnome-power-manager-2.24.0-6.fc10 and hal-0.5.12-3.20081013git.fc10
Comment 1 Jeremy Katz 2008-10-20 15:11:12 EDT
Created attachment 320904 [details]
output from lshal
Comment 2 Richard Hughes 2008-10-20 18:33:07 EDT
Doesn't look like the kernel exposes any batteries. What does ls /sys/class/power_supply/ say?
Comment 3 Jeremy Katz 2008-10-23 08:52:33 EDT
That makes sense.  Probably need to merge in the OLPC pm patches
Comment 4 Jeremy Katz 2008-10-27 13:15:52 EDT
Actually, even easier.  olpc-battery wasn't getting loaded.  Changed to built-in for the next kernel build.
Comment 5 Jeremy Katz 2008-10-27 15:55:26 EDT
*** Bug 468740 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.