Bug 467763 - espeak doesn't work
espeak doesn't work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: espeak (Show other bugs)
10
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Francois Aucamp
Fedora Extras Quality Assurance
:
: 473337 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-20 15:22 EDT by Peter Gückel
Modified: 2009-07-27 03:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 01:51:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Gückel 2008-10-20 15:22:47 EDT
Description of problem:
On the command line, type espeak -f file.txt and wait for the file to be read. Nothing happens (this used to work in F9).

Version-Release number of selected component (if applicable):
1.31-5

How reproducible:
Type command, wait, wait, nothing.

Steps to Reproduce:
1.Enter command
2.Wait
3.No sound
  
Actual results:
No sound is output and the program runs indefinitely until it is killed with ctrl-c.

Expected results:
The file should be read using a synthetic voice.

Additional info:
Matthew Miller said this was due to pulseaudio. he suggested prepending padsp to the espeak -f file.txt command, but this doesn't work. No sound is output.
Comment 1 Francois Aucamp 2008-10-21 04:20:06 EDT
Thanks for the report. I'll do an update as soon as time permits (at latest 19:00 today, SAST). What machine arch are you using?
Comment 2 Francois Aucamp 2008-10-21 11:46:30 EDT
Ok, I've updated espeak to 1.39; it should appear in rawhide in a few hours. I only have a F9 system near me to test though, and it seems fine (with pulseaudio running, and without using padsp). Please test it and let me know if it works for you?

Espeak will however fail if something else is busy using the soundcard - in this case you should see it output the following:

Expression 'parameters->channelCount <= maxChans' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 924
Expression 'ValidateParameters( outputParameters, hostApi, StreamDirection_Out )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 1142

....in which case no audio will be played, and the program will quit. Stopping whatever is using the soundcard will fix this.
Comment 3 Peter Gückel 2008-10-22 15:41:36 EDT
I upgraded to 1.39. I tried it and the program just runs for a long time and nothing happens. Then I abort with ctrl-c, but there is no error output. I ran it without the padsp prefix.
Comment 4 Peter Gückel 2008-10-22 15:42:51 EDT
I am using i386 and use kde, but I run this command from the command line in konsole.
Comment 5 Peter Gückel 2008-10-24 17:59:52 EDT
In case it is significant:

In the latter part of September, I installed kde-live-f10alpha to a clean partition. I did a full update from the rawhide repo at that time. I am not certain whether espeak was on the CD. If not, I got it from the rawhide repo. It worked just fine, then. I tried it using english, french and german. I never ran it with padsp when it was working. Shortly thereafter, I learned that gnome-speech-espeak existed, so I installed it, although I use kde. Either right then, or after an espeak update at about the same time, it ceased to work. After it stopped working, I uninstalled gnome-speech-espeak, but it didn't help, so I reinstalled gnome-speech-espeak, hoping that a future update would correct the problem.
Comment 6 Bug Zapper 2008-11-25 23:02:38 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Francois Aucamp 2008-12-02 05:45:36 EST
*** Bug 473337 has been marked as a duplicate of this bug. ***
Comment 8 Francois Aucamp 2008-12-02 06:05:30 EST
I am completely unable to reproduce this bug; using the following input works fine for me, everytime:

$ espeak -f file.txt --punct="" -v eng

as well as using different voices:

$ espeak -f file.txt --punct="" -v af
$ espeak -f file.txt --punct="" -v de
$ espeak -f file.txt --punct="" -v de
..etc

Also, simply running "espeak" and typing in words to say works fine, until I kill the program with ctrl+C. All these tests were done without gnome-speech-espeak installed, and without using padsp.

Finally, I installed gnome-speech-espeak and tested it with gnome-speech's "test-speech" app, which works fine.

I am guessing that there must be something very specific about your setup that is causing this to fail, as no-one else seems to have experienced this issue. Have you checked whether any other portaudio-based applications (sonic-visualiser, etc) work? 

Unless I can somehow reproduce this bug, I will not be able to fix it.
Comment 9 Peter Gückel 2008-12-02 12:17:00 EST
Yum finds no matches for 'sonic-visualizer' and I don't know what "portaudio-based applications" are. I have pulseaudio.

As I said, I do have gnome-speech-espeak installed, even though I use kde and use espeak from konsole. I let it run a long time, then finally killed it with ctrl-c, but no sound was output.

I don't know what "very specific" there could be about my system, as I use only fedora and rpmfusion packages, no others. My sound card is Creative SB Live, using emu10k1 kernel module. I have a very standard setup, having installed only packages, using yum, not tarballs, etc.

I would like to get this to work.
Comment 10 Peter Gückel 2008-12-02 13:29:00 EST
I just logged into gnome and ran 'test-speech'. The tests ran in total silence, but no errors were reported. I finally opened the volume control and fiddled about. PCM is used for music and all other applications. I have never needed wave for anything, but I decided to enable it. Presto! I got speech. I will go back home to kde and set kmix wave enabled also and see what happens.
Comment 11 Peter Gückel 2008-12-02 13:55:34 EST
Yes, back in kde. All is fine. All it was was the wave volume turned to zero.

Midi uses Synth
TV-Card uses Auxilliary
EVERYTHING ELSE uses PCM

I never had any sound coming from Wave, so I muted it.

I wonder what sound comes from Video? When videos play, their sound comes via PCM, so far. So does sound from flash-plugin.

All the volume settings that don't ever do anything makes it all very confusing.

Strange, festival uses PCM, but espeak uses Wave volume slider.
Comment 12 Francois Aucamp 2008-12-03 01:51:18 EST
I'm glad... "Very specific" in this case was thus your sound card and mixer settings. ;-)

By the way, portaudio is the library that espeak uses to produce audio, which is then output by pulseaudio/alsa (the portaudio lib does not have proper support for pulseaudio at the moment, so that's why I asked). Closing bug as NOTABUG.
Comment 13 Kevin Kofler 2009-01-02 20:48:12 EST
PulseAudio-related issues should be fixed by the portaudio-19-6.fc10 update, see bug 445644.
Comment 14 Skippy 2009-07-26 08:34:08 EDT
I am currently experiencing exactly the same issue. Unfortunately I don't see any "wave" in the volume settings, where everything seems up. My sound card is :
Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

I don't mean to use bugzilla as a forum, but do you have any clue on what I should look at ?
Comment 15 Peter Gückel 2009-07-26 12:36:24 EDT
(In reply to comment #14)
> I am currently experiencing exactly the same issue. Unfortunately I don't see
> any "wave" in the volume settings, where everything seems up. My sound card is
> :
> Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev
> 01)
> 
> I don't mean to use bugzilla as a forum, but do you have any clue on what I
> should look at ?  

Sorry, I have no idea. I am now using fedora 11 and there is no wave in volume settings, but the problem no longer exists.

This bug is closed as the issue is resolved.
Comment 16 Francois Aucamp 2009-07-27 03:34:25 EDT
(In reply to comment #14)
> I don't mean to use bugzilla as a forum, but do you have any clue on what I
> should look at ?  

No, sorry - feel free to open a new bug report, but please include a little bit more information, such as: which version of Fedora, and which version of eSpeak (output of "rpm -q espeak"), as well as which desktop environment (KDE, Gnome, Xfce, etc). Also, are you using pulseaudio? (very important, may be related to #512190) And does eSpeak produce any commandline output when run? Does it pause for a few seconds when uttering a sentence? (in other words, does it seem to be producing sound, but you can't hear it?)

Note You need to log in before you can comment on or make changes to this bug.