Bug 467787 - plymouth hides error messages, continues when there is an error
plymouth hides error messages, continues when there is an error
Status: CLOSED DUPLICATE of bug 460606
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Preview F10DesktopBlocker
  Show dependency treegraph
 
Reported: 2008-10-20 17:23 EDT by Adam Pribyl
Modified: 2008-10-27 15:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 15:39:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Pribyl 2008-10-20 17:23:11 EDT
Description of problem:
Today I found one more problem with text based plymouth - this is
when the system boot fails - e.g. because it is not able to mount root
partition, then progress bar continues silently until the end and there
is no way how to found what got wrong, because the error message is not displayed.

Version-Release number of selected component (if applicable):
mkinitrd-6.0.67-1.fc10

How reproducible:
always

Steps to Reproduce:
1. edit your grub conf, invalidate root=
2. boot the kernel with invalid root parameter
  
Actual results:
Plymouth continues until the end, without any error message, at least at the end.

Expected results:
Plymouth hides when any error message appears, to show up the reason of the failure.

Additional info:
Plymouth should also hide in case there is a failure in any service start.
Comment 1 Jeremy Katz 2008-10-20 17:31:19 EDT
All errors might be difficult, but failure to mount root we should definitely be able to do a 'plymouth --hide-splash' for
Comment 2 Adam Pribyl 2008-10-21 03:48:04 EDT
There is a plymounth --details in the call failure() in init.d/functions script.
For text based boot it seems to do nothing.
Comment 3 Adam Pribyl 2008-10-22 03:21:21 EDT
From the interview in Fedora magazin yesterday I understand that failures in service starts are shown in dialog in GDM after system boot up. This is probably fine, as long as the system gets to GDM. Inteview also meantioned the problem with / mount, therefore I understand this is known problem.
Comment 4 Bill Nottingham 2008-10-27 15:39:35 EDT

*** This bug has been marked as a duplicate of bug 460606 ***

Note You need to log in before you can comment on or make changes to this bug.