Bug 467976 - Method "UpdateSystem" with signature "" on interface "org.freedesktop.PackageKit.Transaction" doesn't exist
Method "UpdateSystem" with signature "" on interface "org.freedesktop.Package...
Status: CLOSED DUPLICATE of bug 469950
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
: 466516 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-21 19:49 EDT by Dave Jones
Modified: 2015-01-04 17:30 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 06:00:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2008-10-21 19:49:52 EDT
pk told me I had two updates. When I clicked update, I got a 'failed to update system' dialog with the following details...

Method "UpdateSystem" with signature "" on interface "org.freedesktop.PackageKit.Transaction" doesn't exist
Comment 1 Dave Jones 2008-10-21 19:50:47 EDT
ah, this is possibly because I have the f9 livna repo enabled on f10.
Comment 2 Ralf Corsepius 2008-10-22 11:13:14 EDT
I just had an encounter with a similar message box:

<snip>
Failed to install package
Unknown error. Please refer to the detailed report and report in bugzilla

Method "UpdateSystem" with signature "as" on interface
"org.freedesktop.PackageKit.Transaction" doesn't exist
</snip>

Version: PackageKit-0.3.8-1.fc10.i386
Comment 3 Richard Hughes 2008-10-26 06:49:08 EDT
*** Bug 466516 has been marked as a duplicate of this bug. ***
Comment 4 Ralf Corsepius 2008-10-31 01:14:12 EDT
AFAICT, this issue somehow is connected to PackageKit's authentication (usermode?).

It only occurs, after having been asked to authenticate as "root" and seemingly having successfully authenticated as root.
I.e. when 1st selecting to add/remove packages and 2nd authenicate, then this error appears.
When returning to the "add/remove packages" dialog, after such error, retrying to process the requested steps (pressing "Apply" again), appear to work.
Comment 5 Richard Hughes 2008-11-06 06:00:53 EST

*** This bug has been marked as a duplicate of bug 469950 ***

Note You need to log in before you can comment on or make changes to this bug.