Bug 467983 - F10 - ATI Driver - Text too large - ATI Xpress 200M rs485
F10 - ATI Driver - Text too large - ATI Xpress 200M rs485
Status: CLOSED DUPLICATE of bug 498457
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
high Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On: 435216
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-21 23:40 EDT by Gerald Cox
Modified: 2018-04-11 05:24 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 05:18:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log when text is large (64.30 KB, text/plain)
2008-10-21 23:40 EDT, Gerald Cox
no flags Details
xorg.conf used for workaround (562 bytes, text/plain)
2008-10-21 23:41 EDT, Gerald Cox
no flags Details
Xorg.0.log when text is large (46.71 KB, text/plain)
2008-10-28 22:03 EDT, Gerald Cox
no flags Details
dmesg when failure occurs (26.27 KB, text/plain)
2008-10-28 22:04 EDT, Gerald Cox
no flags Details
dmesg when failure occurs (26.31 KB, text/plain)
2008-10-31 10:32 EDT, Gerald Cox
no flags Details
Xorg.0.log when text is large (46.74 KB, text/plain)
2008-10-31 10:36 EDT, Gerald Cox
no flags Details
dmesg when failure occurs (28.29 KB, text/plain)
2008-11-01 11:00 EDT, Gerald Cox
no flags Details
Xorg.0.log when text is large (46.13 KB, text/plain)
2008-11-01 11:01 EDT, Gerald Cox
no flags Details
Xorg.0.log when text is large (46.39 KB, text/plain)
2008-11-20 01:03 EST, Gerald Cox
no flags Details
dmesg when failure occurs (26.33 KB, text/plain)
2008-11-20 01:04 EST, Gerald Cox
no flags Details
Screenshot showing random lines artefacts on screen (169.92 KB, text/plain)
2008-12-09 20:11 EST, Gerald Cox
no flags Details
xorg log without "nomodeset" - completely unreadable login screen (37.48 KB, text/plain)
2008-12-19 11:07 EST, Gerald Cox
no flags Details
xorg log without "nomodeset" - completely unreadable login screen (37.35 KB, text/plain)
2008-12-24 22:34 EST, Gerald Cox
no flags Details
screenshot showing text artifacts in gnome terminal (114.68 KB, image/png)
2009-02-12 11:20 EST, Jeff Stern
no flags Details
screenshot showing text artifacts in firefox (150.72 KB, image/png)
2009-02-12 11:22 EST, Jeff Stern
no flags Details
xorg.conf (created by system-config-display by user choosing monitor, etc.) (884 bytes, text/plain)
2009-02-12 11:24 EST, Jeff Stern
no flags Details
xorg.conf (created by "system-config-display --noui --reconfig") (608 bytes, text/plain)
2009-02-12 11:25 EST, Jeff Stern
no flags Details

  None (edit)
Description Gerald Cox 2008-10-21 23:40:50 EDT
Created attachment 321108 [details]
Xorg.0.log when text is large

+++ This bug was initially created as a clone of Bug #435216 +++

Description of problem:

Applied:

xorg-x11-drv-ati-6.9.0-28.fc10.x86_64
kernel-2.6.27.3-27.rc1.fc10.x86_64
xorg-x11-server-Xorg-1.5.2-7.fc10.x86_64
xorg-x11-common-1.5.2-7.fc10.x86_64

All text fonts are ridiculously large and I'm barely able to enter text
commands. 


Version-Release number of selected component (if applicable):
See Description

How reproducible:
Boot the system, appears when normal text is displayed.  GUI appears normal, but
I'm unable to operate a console window or any window with text.


Steps to Reproduce:
1.  See above
2.
3.
  
Actual results:
Unusable.  Text too large to navigate.


Expected results:
Readable text.


Additional info:

Workaround:

As per Bug 435216:

Add statement to Section "Monitor"
--->  DisplaySize 289 210

Add statement to Section "Device"
--->  Option "Monitor-LVDS" "Monitor0"

Please advise when further testing can be done so I can remove the workaround
and validate.

Thanks!
Comment 1 Gerald Cox 2008-10-21 23:41:50 EDT
Created attachment 321109 [details]
xorg.conf used for workaround
Comment 2 Dave Airlie 2008-10-22 00:31:13 EDT
I think if you measure your screen you'll find it isn't 289x210mm, its 330x210mm

The 289x210 is a buggy EDID.

please verify that if you can.

Not sure what the fonts are so big, can you test with a new test a/c for me also.
Comment 3 Gerald Cox 2008-10-22 02:53:14 EDT
Correct... my ruler may be a bit off, but it seems like 334x210mm

I changed xorg.conf to 330 210 and also tried 334 210.

Both times the screen froze during display of the new fedora splash screen with the white progress bar at the bottom.  The freeze happened when the progress bar was almost finished.  

You helped me with this same problem during the F9 beta.  I am using the same laptop.  Looks like something regressed.

Sorry, don't understand what you mean by test a/c - let me know and I will do.

Thanks again for your assistance.
Comment 4 Gerald Cox 2008-10-22 22:55:40 EDT
Output from xrandr - with xorg.conf workaround applied.

Screen 0: minimum 320 x 200, current 1280 x 800, maximum 1280 x 1280
VGA-0 disconnected (normal left inverted right x axis y axis)
LVDS connected 1280x800+0+0 (normal left inverted right x axis y axis) 289mm x 21mm
                  60.1*+
   1024x768       60.0
   800x600        60.3     56.2
   640x480        59.9
Comment 5 Gerald Cox 2008-10-23 18:57:22 EDT
Applied:
xorg-x11-drv-ati-6.9.0-30.fc10.x86_64       
xorg-x11-server-Xorg-1.5.2-8.fc10.x86_64  

No change.  Problem still exists.
Comment 6 Gerald Cox 2008-10-25 00:26:17 EDT
Applied:

xorg-x11-drv-ati-6.9.0-31.fc10.x86_64

No change.  Problem still exists.
Comment 7 Gerald Cox 2008-10-28 22:03:05 EDT
Created attachment 321737 [details]
Xorg.0.log when text is large
Comment 8 Gerald Cox 2008-10-28 22:04:03 EDT
Created attachment 321738 [details]
dmesg when failure occurs
Comment 9 Gerald Cox 2008-10-28 22:05:42 EDT
Applied:

xorg-x11-drv-ati-6.9.0-34.fc10.x86_64

No change.  Problem still occurs.  Posted xorg.0.log and dmesg.
Comment 10 Gerald Cox 2008-10-31 10:32:12 EDT
Created attachment 322074 [details]
dmesg when failure occurs
Comment 11 Gerald Cox 2008-10-31 10:32:52 EDT
Applied:

xorg-x11-drv-ati-6.9.0-37.fc10.x86_64

No change.  Problem still occurs.  Posted updated Xorg.0.log and dmesg.
Comment 12 Gerald Cox 2008-10-31 10:36:30 EDT
Created attachment 322075 [details]
Xorg.0.log when text is large
Comment 13 Gerald Cox 2008-11-01 11:00:44 EDT
Created attachment 322172 [details]
dmesg when failure occurs
Comment 14 Gerald Cox 2008-11-01 11:01:33 EDT
Created attachment 322173 [details]
Xorg.0.log when text is large
Comment 15 Gerald Cox 2008-11-01 11:02:43 EDT
Applied:

xorg-x11-drv-ati-6.9.0-38.fc10.x86_64

No change.  Problem still occurs.  Posted updated Xorg.0.log and dmesg.
Comment 16 Gerald Cox 2008-11-20 01:03:55 EST
Created attachment 324137 [details]
Xorg.0.log when text is large
Comment 17 Gerald Cox 2008-11-20 01:04:49 EST
Created attachment 324138 [details]
dmesg when failure occurs
Comment 18 Gerald Cox 2008-11-20 01:05:59 EST
Applied:

xorg-x11-drv-ati-6.9.0-54.fc10.x86_64

No change.  Problem still occurs.  Posted updated Xorg.0.log and dmesg.
Comment 19 Gerald Cox 2008-11-22 11:36:34 EST
Problem can be circumvented by using "nomodeset" parameter boot time.
Comment 20 Gerald Cox 2008-11-22 11:40:52 EST
Additional clarification, when using "nomodeset" you don't need to use the xorg.conf workaround which is attached to this record.  Specify "nomodeset" without a xorg.conf and everything works fine.  Text is correct size.
Comment 21 Bug Zapper 2008-11-25 23:06:37 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 22 Jóhann B. Guðmundsson 2008-12-01 05:50:46 EST
There have been bunch of bug fixes

Could you retest with the latest kernel 
( -132 at the time of this writing )

You can get the latest kernel build here
http://koji.fedoraproject.org/koji/buildinfo?buildID=72270 

And with the latest xorg-x11-drv-ati. 
( -60 at the time of this writing )

You can get the latest xorg-x11-drv-ati build here
http://koji.fedoraproject.org/koji/packageinfo?packageID=95

And report back if it either improves or fixes this issue..

Thanks.
Comment 23 Gerald Cox 2008-12-09 20:11:04 EST
Created attachment 326436 [details]
Screenshot showing random lines artefacts on screen
Comment 24 Gerald Cox 2008-12-09 20:37:02 EST
Applied kernel -132 and xorg-x11-drv-ati -62
Large text problem, no change.  Circumvention is to boot with "nomodeset" parameter.  With latest updates screen now has random line artefacts.  Attached screenshot.
Comment 25 Gerald Cox 2008-12-09 23:04:41 EST
Random line artefacts occur starting with xorg-x11-drv.ati -61; issue does not occur in -60.
Comment 26 Gerald Cox 2008-12-19 11:06:21 EST
Random screen artefacts are gone now.  At first glance things seem to be
alot better with current updates using "nomodeset".  However, if I don't use
"nomodeset" now I get a completely unreadable, garbage login screen.  The only
way to recover is to press the power button to shutdown and then boot using "nomodeset".  I've attached the xorg.log.  

kernel-2.6.27.7-134.fc10.x86_64
xorg-x11-drv-ati-6.9.0-62.fc10.x86_64
Comment 27 Gerald Cox 2008-12-19 11:07:53 EST
Created attachment 327456 [details]
xorg log without "nomodeset" - completely unreadable login screen
Comment 28 Gerald Cox 2008-12-24 22:33:35 EST
Applied:
kernel-2.6.27.9-159.fc10.x86_64
xorg-x11-drv-ati-6.9.0-63.fc10.x86_64

No apparent change from:
kernel-2.6.27.7-134.fc10.x86_64
xorg-x11-drv-ati-6.9.0-62.fc10.x86_64

Random screen artefacts are gone now as mentioned previously.  At first glance things seem to be
alot better with current updates using "nomodeset".  However, if I don't use
"nomodeset" now I get a completely unreadable, garbage login screen.  The only
way to recover is to press the power button to shutdown and then boot using
"nomodeset".  I've attached the xorg.log.
Comment 29 Gerald Cox 2008-12-24 22:34:52 EST
Created attachment 327829 [details]
xorg log without "nomodeset" - completely unreadable login screen
Comment 30 Mauricio Silveira 2009-02-05 13:39:35 EST
Hi all,

I'm here to add data to this topic:
I have a NoteBook: HP Pavilion zv6130us. I'm having the very same ANNOYING problem.

My Xorg.0.log is pretty much the same like those posted be Gerald Cox.

Basically, i have the same components, except slightly different models, such as my LCD Screen:
(II) RADEON(0):  LGPhilipsLCD
(II) RADEON(0):  LP154W01-TLA9
(II) RADEON(0): EDID (in hex):
(II) RADEON(0): 	00ffffffffffff00320c761700000000
...

I've just updated the xorg-x11-drv-ati to the one from koji: 
xorg-x11-drv-ati-6.10.0-2.fc10.x86_64

Kernel: kernel-2.6.27.12-170.2.5.fc10.x86_64

Xorg: xorg-x11-server-Xorg-1.5.3-6.fc10.x86_64


Just some more information:

This just happens when the session is KDE, when it's GNOME, screen is OK

Here's the relevant part of gnome session xdpyinfo:

screen #0:
  dimensions:    1280x800 pixels (339x212 millimeters)
  resolution:    96x96 dots per inch


What else may I do to help sddressing this bug?
Comment 31 Jeff Stern 2009-02-12 11:20:41 EST
Created attachment 331704 [details]
screenshot showing text artifacts in gnome terminal
Comment 32 Jeff Stern 2009-02-12 11:22:34 EST
Created attachment 331706 [details]
screenshot showing text artifacts in firefox

(see below)
Comment 33 Jeff Stern 2009-02-12 11:24:30 EST
Created attachment 331707 [details]
xorg.conf (created by system-config-display by user choosing monitor, etc.)
Comment 34 Jeff Stern 2009-02-12 11:25:55 EST
Created attachment 331708 [details]
xorg.conf (created by "system-config-display --noui --reconfig")
Comment 35 Jeff Stern 2009-02-12 11:32:50 EST
hey, everyone, just putting in my 2 cents, too.. i am experiencing text artifacts which seem similar to the problem that Gerald describes in comments #23 and #25, so i thought i'd add my case in as well, for additional info, if it will help.

i added the 4 attachments in the previous 4 comments:
  - 2 screenshots of the text artifacts.
  - 2 xorg.conf's i have used -- both with same text artefact problem.

fedora 10 -- (all updates applied)
dell gx260 (2002 vintage)
kernel-2.6.27.12-170.2.5.fc10.i686
xorg-x11-drv-ati-6.10.0-1.fc10.i386
video card is a factory-shipped ati/radeon card that came with the machine. lspci says:

   01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]

fyi i have 2 dell 1801FP monitors hooked to the card via digital connectors/splitter (not analog/vga), and to get the spanning desktops, i use an xrandr command ("xrandr --output DVI-0 --right-of DVI-1") to set up the spanning desktops (since because of bug https://bugzilla.redhat.com/show_bug.cgi?id=443352 system-config-display is currently unable to set up a dual head system -- at least on my system).

when i try the "nomodeset" kernel parameter suggested above, the problem does indeed go away. (*thank you* for this workaround!)

i also recently changed my /etc/X11/Xresources file for the dpi from 96 to 91, to more 

  Xft.dpi: 91

(but i still had the artefacts problem when at 96dpi)

if there is any other information you need which will help, please let me know.

thanks!
Comment 36 Jeff Stern 2009-02-12 12:07:32 EST
okay, another clue and correction to the text-artifacts problem i'm experiencing.

i went back to using my first xorg.conf (the one posted in comment #33).  even with nomodeset i was still getting the text artifacts.  apparently i only made them go away with the second, auto-generated xorg.conf (comment #34) PLUS the nomodeset combination.  but the problem with the second xorg.conf is that it did not accomodate the larger viewport for my dual screen setup.

so i went back to using the first xorg.conf (#33) and noticed that i still got the text artifacts (even with nomodeset).  so i changed only one thing: i hand-edited (i.e., i did *not* use system-config-display) the first xorg.conf i was now using, and changed the two Depth lines from 24 down to 16 (which effectively moves the card down from providing millions of colors, to providing only thousands of colors).  now i do not have the text artifacts.

(also, i should have mentioned originally that i have a 2nd, identical ati/radeon card pulled from a similar dell box, and i've tried switching them out in my computer, but they both display this same text artifact problem.)
Comment 37 Victoria Earl 2009-06-27 17:47:43 EDT
Same bug here on an x86_64 brand new Fedora 11 install.

Executive Summary:
nomodeset (and no xorg.conf file) fixes all related issues.
In KDE, text was impossibly large for programs (though not for menus).
In Gnome, screen appeared fine; HOWEVER, the Firefox 3.5 beta 4 would freeze the screen randomly.  Other browsers, even gecko based ones, (i.e. Galeon) did not do this.
AMD Turion 64 Mobile processor.
ATI Radeon Xpress 200M card.
Comment 38 Matěj Cepl 2009-06-29 08:30:54 EDT
(In reply to comment #37)
> ATI Radeon Xpress 200M card.  

Aaaah, could everybody who could reproduce this bug has this graphics chip?
Comment 39 Matěj Cepl 2009-06-29 08:33:43 EDT
meaning, if yes, then I think we have a duplicate of bug 498457
Comment 40 Victoria Earl 2009-06-29 22:06:25 EDT
(In reply to comment #39)
> meaning, if yes, then I think we have a duplicate of bug 498457  

Yes, these bugs seem to be one and the same.  Judging by the dates of the bugs filed, a regression update in the drivers released in December 2008 caused X to be completely corrupted without the kernel parameter "nomodeset".  Much later, probably in late April/early May, the regression was fixed.  The symptoms described in the posts by date match up perfectly.

Since the title and original description bug more closely match up with the current symptoms (in F11), and since it has a more complete history, my recommendation would be to close bug 498457 as a duplicate.

Additionally, bug 464383 is an even older form of this bug, appearing only in F9.
Comment 41 Matěj Cepl 2009-06-30 05:18:00 EDT

*** This bug has been marked as a duplicate of bug 498457 ***

Note You need to log in before you can comment on or make changes to this bug.